Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430628 - =net-analyzer/metasploit-4.3.0 add revdep-rebuild directory masks
Summary: =net-analyzer/metasploit-4.3.0 add revdep-rebuild directory masks
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-09 16:11 UTC by Joaquim Uchoa
Modified: 2013-12-16 03:57 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joaquim Uchoa 2012-08-09 16:11:59 UTC
revdep-rebuild complains about some files being broken when checking for dynamic linking consistency.

This bug is similar to Bug 377617, but with new version of Metasploit (4.3.0). 



Reproducible: Always

Steps to Reproduce:
1. emerge =net-analyzer/metasploit-4.3.0
2. revdep-rebuild 

Actual Results:  
revdep-rebuild says there are some broken files, but none of them were associated with known packages.


Expected Results:  
revdep-rebuild should ignore files emerged with metasploit.

Output: 
 revdep-rebuild --pretend
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 71% ]  *   broken /usr/lib64/metasploit4.3/lib/gemcache/ruby/1.9.1/arch/linux32/pg-0.13.2/lib/pg_ext.so (requires libpq.so.5)
 *   broken /usr/lib64/metasploit4.3/lib/gemcache/ruby/1.9.1/arch-old/linux32/pg-0.13.2/lib/pg_ext.so (requires libpq.so.5)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *  !!! /usr/lib64/metasploit4.3/lib/gemcache/ruby/1.9.1/arch/linux32/pg-0.13.2/lib/pg_ext.so not owned by any package is broken !!!
 *   /usr/lib64/metasploit4.3/lib/gemcache/ruby/1.9.1/arch/linux32/pg-0.13.2/lib/pg_ext.so -> (none)
 *  !!! /usr/lib64/metasploit4.3/lib/gemcache/ruby/1.9.1/arch-old/linux32/pg-0.13.2/lib/pg_ext.so not owned by any package is broken !!!
 *   /usr/lib64/metasploit4.3/lib/gemcache/ruby/1.9.1/arch-old/linux32/pg-0.13.2/lib/pg_ext.so -> (none)
 * Generated new 4_raw.rr and 4_owners.rr
 * Found some broken files, but none of them were associated with known packages
 * Unable to proceed with automatic repairs.
 * The broken files are listed in 4_owners.rr
Comment 1 Jason A. Donenfeld archtester Gentoo Infrastructure gentoo-dev Security 2012-08-13 00:54:27 UTC
This one takes care of the 9999 build:

diff --git a/usr/portage/net-analyzer/metasploit/metasploit-9999.ebuild b/net-analyzer/metasploit/metasploit-9999.ebuild
index 4c23c97..207c813 100644
--- a/usr/portage/net-analyzer/metasploit/metasploit-9999.ebuild
+++ b/net-analyzer/metasploit/metasploit-9999.ebuild
@@ -76,6 +76,9 @@ src_install() {
                        metasploit \
                        'GNOME;System;Network;' &&
                doicon "${FILESDIR}"/metasploit.icon
+
+    echo "SEARCH_DIRS_MASK=\"${EPREFIX}/usr/lib*/${PN}4.0\"" > "${T}/80${PN}" || die
+    insinto "/etc/revdep-rebuild" && doins "${T}/80${PN}" || die
 }
 
 pkg_postinst() {
Comment 2 Rick Farina (Zero_Chaos) gentoo-dev 2013-12-16 03:57:52 UTC
latest releases don't need this due to fixes in the ebuild to remove bundled crap.