Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430364 - mipsel-linux-uclibc-ldd does not work
Summary: mipsel-linux-uclibc-ldd does not work
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Embedded Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-07 23:18 UTC by Richard Yao (RETIRED)
Modified: 2012-08-08 02:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Yao (RETIRED) gentoo-dev 2012-08-07 23:18:56 UTC
I installed mipsel-linux-uclibc-ldd using `crossdev mipsel-linux-uclibc` and then built a few binaries.

Unfortunately, mipsel-linux-uclibc-ldd does not work:

# mipsel-linux-uclibc-ldd /usr/mipsel-linux-uclibc/usr/bin/ssh
/usr/mipsel-linux-uclibc/usr/bin/dropbearmulti: not an ELF file.

`file` indicates otherwise and the binaries work when transferred to my router.
Comment 1 Richard Yao (RETIRED) gentoo-dev 2012-08-07 23:26:56 UTC
Note that the following versions were installed by crossdev:

binutils-2.22.90
gcc-4.6.3
linux-headers-3.5
uclibc-0.9.33.2-r1