Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430224 - app-office/libreoffice-bin-3.5.4.2 - printing to CUPS fails before the job has been submitted
Summary: app-office/libreoffice-bin-3.5.4.2 - printing to CUPS fails before the job ha...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-06 20:39 UTC by Nils Stöckmann
Modified: 2014-10-24 20:35 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nils Stöckmann 2012-08-06 20:39:55 UTC
I can't print anymore from libreoffice-bin after a world update, including cups and libreoffice-bin. (350m1-Build2)


however i can print from opera, midori, texstudio, leafpad and epdfview and gimp.

I tried all printers i have availible, including the cups pdf printer. Nothing.

I'm sorry, but that's about all information i can give.

I have turned on debug logging in cupsd.conf and restarted cups, however klicking "print" in libreoffice doesn't create any reaction in cups. There is exactly NO new line in the complete /var/log/cups/*, neither in syslog. Sync didn't help either.


The following packages somehow could relate to this problem:

# emerge -pv1 ghostscript-gpl cups libreoffice-bin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-print/cups-1.5.2-r4  USE="X acl dbus gnutls jpeg png python ssl threads tiff -avahi -debug -filters -java -kerberos -ldap -pam -perl (-selinux) -slp -static-libs -usb -xinetd" LINGUAS="de -da -es -eu -fi -fr -id -it -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW" 0 kB
[ebuild   R    ] app-text/ghostscript-gpl-9.05-r1  USE="X cups dbus djvu gtk idn jpeg2k -bindist -static-libs" LINGUAS="-ja -ko -zh_CN -zh_TW" 0 kB
[ebuild   R    ] app-office/libreoffice-bin-3.5.4.2-r1  USE="cups java (-aqua) -debug -gnome -kde" 0 kB


Does anybody have an idea where the problem could be?
Comment 1 Nils Stöckmann 2012-08-06 20:53:11 UTC
Additional Info I forgot:

- compiling cups with USE="$USE debug" doesn't yield a single error message, too.
- print into file works
- export to pdf works
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2012-08-07 07:31:52 UTC
Firstly you don't need to add yourself to CC when you create bug, you get the mail anyway :-)

Also I tried the printing with binary version here right now and it printed me nice 4 page document, so something is really fishy.

Could you try the libreoffice-bin-3.5.5.3 (currently in testing)?

And if you have cpu cycles to spare you could try the non binary version (sadly I have no idea what might be wrong).

CCing printing even if it is basically the same team just for the semantic :-)
Comment 3 Nils Stöckmann 2012-08-08 18:24:36 UTC
Guess what - 
Yesterday just somewhere in between a lot of playing around with printer settings in libreoffice it DID print two jobs. On the first one, all printers i had vanished in return for a "generic printer" that worked. Then all printers reappeared and i could select a working one for my second successful job.

After that, no printer worked.

I have upgraded to libreoffice-bin-3.5.5.3, but it has the same behavior here. 
Cups is "unemployed" - it gets no jobs...
Comment 4 Andreas K. Hüttel gentoo-dev 2013-05-11 15:45:52 UTC
Is this still a problem with libreoffice-bin-3.6 ?
Which version of cups are you using?
Comment 5 Nils Stöckmann 2013-05-27 18:11:48 UTC
Hi Andreas,

the problem 100% persists in libreoffice-bin-3.6.4.3.

I use:

[ebuild   R    ] net-print/cups-1.5.2-r4  USE="X acl dbus gnutls jpeg png python ssl threads tiff -avahi -debug -filters -java -kerberos -ldap -pam -perl (-selinux) -slp -static-libs -usb -xinetd" LINGUAS="-es" 0 kB

[ebuild   R    ] app-office/libreoffice-bin-3.6.4.3 USE="cups java (-aqua) -debug -gnome -kde" 69,574 kB
Comment 6 Tango 2013-09-23 17:47:47 UTC
Maybe related maybe not.........I have had trouble for some time now printing from libreoffice-bin.  If I open a document and print it immediately, it gets sent to cups and the job is printed.  However if I modify the document first and save it and than print it. Printing fails every time. The job appears in cups as stopped, but I can't get cups to print the job even as the superuser. No useful errors are reported by cups. I have several Gentoo workstations. This happens in both openoffice-bin and libreoffice-bin. I thought it might be related to a bug in openoffice-bin so I switched my personal workstation to libreoffice-bin but the problem persists.

My printer always shows up in libreoffice-bin but printing to it can only be done by opening one document at a time and printing it before modifying or opening a second document. Very annoying...........

I had to switch to libreoffice-(source) due to dependency problems with recent boost changes but haven't had the time to see if the problem is there as well.
Comment 7 Matteo Modesti 2013-12-01 18:50:02 UTC
What about now? Do you still have problems with stable 4.1.2.3 or ~unstable 4.1.3.2?
Comment 8 Nils Stöckmann 2013-12-11 12:29:37 UTC
in libreoffice-bin 4.0.4.2, the current status is:
printing the first time does not work under the previously described circumstances.
If I retry within 5 minutes, it works.
If I stop printing for > 5 min it doesn't work anymore, the next tries after that within a 5 minute frame after the last printing action however work.

Now Upgrading to 4.1.2.3.
Let's see what happens.