Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 429576 - app-misc/ola: Open Lighting Architecture
Summary: app-misc/ola: Open Lighting Architecture
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 1 vote (vote)
Assignee: Default Assignee for New Packages
URL: http://www.openlighting.org/
Whiteboard:
Keywords: EBUILD, PullRequest
Depends on:
Blocks:
 
Reported: 2012-08-02 21:00 UTC by jannis
Modified: 2021-02-11 22:48 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ola-0.8.21.ebuild (ola-0.8.21.ebuild,900 bytes, text/plain)
2012-08-02 21:01 UTC, jannis
Details
ola-9999.ebuild (ola-9999.ebuild,893 bytes, text/plain)
2012-08-02 21:02 UTC, jannis
Details
ola-0.8.21.ebuild (ola-0.8.21.ebuild,898 bytes, text/plain)
2012-08-07 14:46 UTC, jannis
Details
ola-9999.ebuild (ola-9999.ebuild,881 bytes, text/plain)
2012-08-07 14:46 UTC, jannis
Details
ola-0.8.22.ebuild (ola-0.8.22.ebuild,779 bytes, text/plain)
2012-08-14 10:14 UTC, jannis
Details
ola-9999.ebuild (ola-9999.ebuild,804 bytes, text/plain)
2012-08-14 10:14 UTC, jannis
Details
ola-0.8.26.ebuild (ola-0.8.26.ebuild,826 bytes, text/plain)
2013-01-20 18:34 UTC, jannis
Details
Updated ebuild for ola-0.8.33 (ola-0.8.33.ebuild,874 bytes, text/plain)
2014-02-22 15:57 UTC, Richard Ash
Details
ola-0.9.1.ebuild (ola-0.9.1.ebuild,887 bytes, text/plain)
2014-07-17 08:00 UTC, jannis
Details
ola-0.10.6.ebuild - Updated ebuild (ola-0.10.6.ebuild,818 bytes, text/plain)
2018-02-24 21:58 UTC, jannis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jannis 2012-08-02 21:00:50 UTC
Open Lighting Architecture (OLA) is a framwork for controlling lighting devices under Linux/Mac OS X. It supports several hardware-interfaces (DMX), network protocols and has a web interface.

Reproducible: Always
Comment 1 jannis 2012-08-02 21:01:57 UTC
Created attachment 320122 [details]
ola-0.8.21.ebuild

ola-0.8.21.ebuild
ebuild for current stable version
Comment 2 jannis 2012-08-02 21:02:40 UTC
Created attachment 320124 [details]
ola-9999.ebuild

ola-9999.ebuild
live-ebuild (git)
Comment 3 jannis 2012-08-02 21:03:18 UTC
Oh, forgot:
partly based on work found at: https://github.com/nativemad/MadOverlay/blob/master/media-disco/ola/ola-0.8.11.ebuild
Comment 4 jannis 2012-08-02 21:08:33 UTC
One more thing: I'll test this on arm (stable) and x86 (stable) tomorrow, wanted to submit them first and don't have the machines running right now
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2012-08-02 23:33:17 UTC
Note: I am changing the URL because the wiki originally referenced is apparently open to everyone to deface.
Comment 6 Peter Stuge 2012-08-04 12:19:11 UTC
Should this inherit python, DEPEND=dev-libs/protobuf[python], and python_* in pkg_setup() also when USE=-python ?

Is IUSE=webserver the best name for the flag? Other packages use "web", "webserver", "http", and "httpd". This looks like a good opportunity to unify those into a single USE flag.

I have added these ebuilds as-is to my layman overlay called 'stuge' for anyone who wants to use them.

Please feel free to email me patches for git://git.stuge.se/stuge-overlay.git
(Even if you attach a patch to this bug, I'd appreciate if you emailed it to me as well.)

Thanks!
Comment 7 jannis 2012-08-06 17:42:15 UTC
(In reply to comment #6)
> Should this inherit python, DEPEND=dev-libs/protobuf[python], and python_*
> in pkg_setup() also when USE=-python ?

Yes, this is intended. I tried to build OLA w/o python support, but it still failed to configure because it was unable to find the protobuf-python-module.

> Is IUSE=webserver the best name for the flag? Other packages use "web",
> "webserver", "http", and "httpd". This looks like a good opportunity to
> unify those into a single USE flag.

No, it's probably not the  best name but I copied that one from the mentioned github-repo. Will change it to "httpd"  and post new ebuilds then.

> I have added these ebuilds as-is to my layman overlay called 'stuge' for
> anyone who wants to use them.

Thanks for adding them.

> Please feel free to email me patches for git://git.stuge.se/stuge-overlay.git
> (Even if you attach a patch to this bug, I'd appreciate if you emailed it to
> me as well.)

I'll send you the changes as a patch as soon as the ebuilds are in here
Comment 8 jannis 2012-08-07 14:46:00 UTC
Created attachment 320628 [details]
ola-0.8.21.ebuild

Updated ebuild:
- changed USE-flag "webserver" to "httpd"
- tested on amd64, x86 and arm
- sorted some stuff alphabetically
Comment 9 jannis 2012-08-07 14:46:17 UTC
Created attachment 320630 [details]
ola-9999.ebuild

Updated ebuild:
- changed USE-flag "webserver" to "httpd"
- sorted some stuff alphabetically
Comment 10 Peter Stuge 2012-08-07 15:34:19 UTC
Thanks, I've committed the patches to my 'stuge' overlay.

http://git.stuge.se/?p=stuge-overlay.git;a=commit;h=78d712dd
Comment 11 jannis 2012-08-11 12:31:11 UTC
Renaming ola-0.8.21.ebuild to ola-0.8.22.ebuild for latest stable version works (for completeness: tested on ~amd64 only).
Comment 12 Peter Stuge 2012-08-11 13:22:13 UTC
(In reply to comment #11)
> Renaming ola-0.8.21.ebuild to ola-0.8.22.ebuild for latest stable version
> works

I've updated my overlay with the rename.
Comment 13 jannis 2012-08-14 10:14:12 UTC
Created attachment 321296 [details]
ola-0.8.22.ebuild

Updated ebuilds for quality :)
Comment 14 jannis 2012-08-14 10:14:28 UTC
Created attachment 321298 [details]
ola-9999.ebuild

Updated ebuilds for quality :)
Comment 15 jannis 2012-09-09 19:37:25 UTC
Renaming ebuild to ola-0.8.23.ebuild works like a charm :)
Comment 16 jannis 2013-01-20 18:34:59 UTC
Created attachment 336234 [details]
ola-0.8.26.ebuild

updated ebuild. the only thing that really changed is the dependency on net-libs/libmicrohttpd which needs to be built with USE="messages". Otherwise ola gets a linking error with >=net-libs/libmicrohttpd-0.9.23

Peter, why does the ebuild in your overlay have "append-ldflags $(no-as-needed)"? I don't see/have a problem with --as-needed.
Comment 17 Richard Ash 2014-02-22 15:57:43 UTC
Created attachment 371056 [details]
Updated ebuild for ola-0.8.33

Updated ebuild, as previous one but for current release, and with the use flag restriction mentioned in the previous comment incorporated.
Comment 18 jannis 2014-07-17 08:00:06 UTC
Created attachment 380874 [details]
ola-0.9.1.ebuild

Update ebuild for 0.9.1. I used Richard's ebuild from comment #17 (thanks!), changed the HOMEPAGE and the SRC_URI.
I didn't test it extensively but it builds fine, starts up and the web server is running.
Comment 19 jannis 2015-03-22 22:41:24 UTC
The ebuild for 0.9.1 works perfectly fine when renamed to ola-0.9.5.ebuild
Comment 20 Thomas R. (TRauMa) 2015-11-27 16:46:36 UTC
(In reply to jannis from comment #19)
> The ebuild for 0.9.1 works perfectly fine when renamed to ola-0.9.5.ebuild

Still true for 0.9.8.
Comment 21 jannis 2016-12-18 16:32:57 UTC
ebuild "ola-0.9.1.ebuild" works also fine when renamed to "ola-0.10.3.ebuild"
Comment 22 jannis 2018-02-24 21:58:51 UTC
Created attachment 520956 [details]
ola-0.10.6.ebuild - Updated ebuild

Hi, I've just updated the ebuild to use the new python eclasses. I'll test if python 2.7 and 3.5 actually work (install list looks okay) and then I hope to create my first pull-request to add an ebuild :)
Comment 23 jannis 2020-03-19 21:25:45 UTC
Comment on attachment 520956 [details]
ola-0.10.6.ebuild - Updated ebuild

Obsoleted the ebuild I attached - please see the PR for the latest version