Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 428118 - dev-scheme/guile is broken on Gentoo FreeBSD with both Clang and GCC
Summary: dev-scheme/guile is broken on Gentoo FreeBSD with both Clang and GCC
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: FreeBSD (show other bugs)
Hardware: All FreeBSD
: Normal normal with 2 votes (vote)
Assignee: Gentoo/BSD Team
URL:
Whiteboard:
Keywords: Goal
Depends on:
Blocks: freebsd-clang-3.1
  Show dependency tree
 
Reported: 2012-07-25 23:52 UTC by Richard Yao
Modified: 2019-03-22 07:18 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-scheme/guile-1.8.8-r1 failure on ~amd64-fbsd with sys-devel/clang-3.1-r4 (build.log,48.82 KB, text/plain)
2012-07-25 23:52 UTC, Richard Yao
Details
dev-scheme/guile-1.8.8-r1 failure on ~amd64-fbsd with sys-devel/gcc-4.6.3 (build.log,51.10 KB, text/plain)
2012-07-25 23:53 UTC, Richard Yao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Yao gentoo-dev 2012-07-25 23:52:32 UTC
Created attachment 319262 [details]
dev-scheme/guile-1.8.8-r1 failure on ~amd64-fbsd with sys-devel/clang-3.1-r4

sys-boot/grub:2 depends on dev-scheme/guile, which is presently broken on FreeBSD with both Clang and GCC. We need to fix it with at least GCC so that users have the option of using sys-boot/grub:2.
Comment 1 Richard Yao gentoo-dev 2012-07-25 23:53:39 UTC
Created attachment 319264 [details]
dev-scheme/guile-1.8.8-r1 failure on ~amd64-fbsd with sys-devel/gcc-4.6.3
Comment 2 Naohiro Aota gentoo-dev 2012-10-09 10:08:29 UTC
(In reply to comment #1)
> Created attachment 319264 [details]
> dev-scheme/guile-1.8.8-r1 failure on ~amd64-fbsd with sys-devel/gcc-4.6.3

> [32;01m*[0m Running elibtoolize in: guile-1.8.8/build-aux/
> [32;01m*[0m   Applying portage/1.2.0 patch ...
> /var/tmp/portage/dev-scheme/guile-1.8.8-r1/temp/environment: line 156: Binary: command not found
> [32;01m*[0m   Applying sed/1.5.6 patch ...
> [32;01m*[0m Running elibtoolize in: guile-1.8.8/guile-readline/
> [32;01m*[0m   Applying portage/1.2.0 patch ...
> /var/tmp/portage/dev-scheme/guile-1.8.8-r1/temp/environment: line 156: Binary: command not found
> [32;01m*[0m   Applying sed/1.5.6 patch ...
> >>> Source prepared.
> (snip)
> In file included from alist.c:379:0:
> ../libguile/alist.x: In function 'scm_init_alist':
> ../libguile/alist.x:2:1: error: unknown type name 'Binary'
> ../libguile/alist.x:2:13: error: expected '=', ',', ';', 'asm' or '__attribute__' before '/' token
> ../libguile/alist.x:2:47: error: too many decimal points in number
> alist.c:380:1: error: expected declaration or statement at end of input
> gmake[3]: *** [libguile_la-alist.lo] Error 1

Are you doing something special in your bashrc or something...?
Comment 3 Anton Kochkov 2016-08-19 06:29:45 UTC
Is that still a case for guile-2.0.12? Can you please retest?
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-03-22 07:18:58 UTC
Obsoleting bugs for ancient clang versions.