Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 427808 - x11-base/xorg-server-1.12.3 crashing at start-up when compiled with sys-devel/clang
Summary: x11-base/xorg-server-1.12.3 crashing at start-up when compiled with sys-devel...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Clang Team (OBSOLETE)
Depends on:
Blocks: systemwide-clang
  Show dependency tree
Reported: 2012-07-23 20:10 UTC by wbrana
Modified: 2015-01-18 12:33 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description wbrana 2012-07-23 20:10:07 UTC
xorg-server is crashing if compiled with clang
Comment 1 Fabio Scaccabarozzi 2015-01-18 11:34:17 UTC
This does not happen anymore with xorg-server-1.16.3-r1 (latest unstable) and clang-3.5.0-r100.
I can't test xorg-server latest stable (1.15.2-r1) as that would mean downgrading many packages and most probably breaking my desktop.

If testing on latest stable passes, I think this bug can be safely closed.

I tried to compile 1.12 and test it through ebuild, but tests fail with a stack trace, so I guess the issue is not solved for this particular version of xorg-server.
I think backporting the patches from 1.16 (or possibly 1.15) to 1.12 would not be worth the time (unless I'm wrong and there's only one patch to apply).