Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 427342 - dev-libs/apr fails to build with clang-3.1-r4
Summary: dev-libs/apr fails to build with clang-3.1-r4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: systemwide-clang 474586
  Show dependency tree
 
Reported: 2012-07-20 15:44 UTC by Fabio Scaccabarozzi
Modified: 2014-01-30 19:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge fail log (dev-libs:apr-1.4.6:20120720-134718.log,30.36 KB, text/plain)
2012-07-20 15:44 UTC, Fabio Scaccabarozzi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Scaccabarozzi 2012-07-20 15:44:38 UTC
Created attachment 318742 [details]
emerge fail log

dev-libs/apr fails to build with clang-3.1-r4, both versions available fail at compile phase.
Comment 1 poletti.marco 2012-12-29 16:55:39 UTC
This seems the same issue as in: https://github.com/jabberwik/homebrew-httpd/issues/2

And it works after adding LTFLAGS=--tag=cc to the econf parameters.
I'm not sure whether this is the proper fix or just a workaround, though.
Comment 2 Bernard Cafarelli gentoo-dev 2014-01-30 19:43:59 UTC
=dev-libs/apr-1.5.0-r1 compiles and passes tests with clang 3.4 (1.4.8 has the same compilation error)