Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 427310 - =dev-libs/ppl-0.12.1 fails tests with clang-3.1-r4
Summary: =dev-libs/ppl-0.12.1 fails tests with clang-3.1-r4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Bernard Cafarelli
Depends on:
Blocks: systemwide-clang
  Show dependency tree
Reported: 2012-07-20 12:44 UTC by Fabio Scaccabarozzi
Modified: 2013-11-07 13:27 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Scaccabarozzi 2012-07-20 12:44:23 UTC
=dev-libs/ppl-0.12.1 fails tests with clang-3.1-r4, I also tested latest stable, and it fails as well.
Comment 1 Fabio Scaccabarozzi 2012-07-25 14:12:12 UTC
Sorry for not attaching the log, it must have slipped through.
Anyway, after further investigation, retesting and recompiling, I am unable to reproduce the problem again.
I don't know if it was some memory/hard disk corruption of the VM I used to do the testing, the issue was consistently showing up every time I tried to recompile ppl (same error log as well). Then something happened (vm reboot, some other application update, don't really know) and the issue is gone. I rebased the VM from scratch yesterday, and the issue keeps NOT showing.
If you are unable to reproduce the issue as well, I think this bug can be closed as invalid.
Comment 2 Jonas Fietz 2013-11-05 17:02:32 UTC
Confirm that this compiles correctly and that test cases run through without error:
Comment 3 Bernard Cafarelli gentoo-dev 2013-11-07 13:27:28 UTC
Testing fine too here with clang-3.3-r100

Thanks for checking!