Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 427098 - Stabilise =app-office/libreoffice-3.5.5.3 and relatives
Summary: Stabilise =app-office/libreoffice-3.5.5.3 and relatives
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: CVE-2012-2665
  Show dependency tree
 
Reported: 2012-07-18 13:57 UTC by Tomáš Chvátal (RETIRED)
Modified: 2012-08-14 20:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Chvátal (RETIRED) gentoo-dev 2012-07-18 13:57:24 UTC
Please stabilise following packages at once:

=app-text/libexttextcat-3.3.1 (already tested on all archs, just needs to go with new binary as the soname changed)
=app-office/libreoffice-3.5.5.3
=app-office/libreoffice-l10n-3.5.5

Again the binary will be done after the source one is finished.

@dilfridge: could you restrict the dep on textcat to 3.2 on the current binary?
Comment 1 Elijah "Armageddon" El Lazkani (amd64 AT) 2012-07-18 14:16:05 UTC
amd64: pass
Comment 2 Maurizio Camisaschi (amd64 AT) 2012-07-19 16:59:16 UTC
amd64 ok
Comment 3 Andreas K. Hüttel archtester gentoo-dev 2012-07-19 21:35:07 UTC
> @dilfridge: could you restrict the dep on textcat to 3.2 on the current
> binary?

Done long ago already...
Comment 4 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2012-07-20 10:36:37 UTC
x86: all packages is OK for me
with *-l10n packefe i am testing "en" and "ru" LINGUAS support: ok
Comment 5 Yixun Lan archtester gentoo-dev 2012-07-21 00:34:42 UTC
Hi, how did YOU test the package? did you do all the USEs combinations?

I'm trying to help stablize, so I'm using "tatt"(arch test tool) to do the verification.

while the USEs combinations generate by tatt tool seems problematic
so, could provide me some sane USEs combinations? or simply emerge this package with default USEs and check the run-time usage is ok?




 * Updating icons cache ...                                            
 * Updating desktop mime database ...
 * Updating shared mime info database ...
 * Fallback PaX marking -m
 *      /usr/lib/libreoffice/program/soffice.bin
 TYPE    PAX   FILE 
ET_EXEC --mxe- /usr/lib/libreoffice/program/soffice.bin 
 * Fallback PaX marking -m
 *      /usr/lib/libreoffice/program/unopkg.bin
 TYPE    PAX   FILE 
ET_EXEC --mxe- /usr/lib/libreoffice/program/unopkg.bin 
 * You will need net-print/cups to be able to print and export to PDF with lib
reoffice.
 * If you plan to use lbase aplication you should enable java or you will get 
various crashes.
>>> app-office/libreoffice-3.5.5.3 merged.

 * Messages for package app-office/libreoffice-3.5.5.3:

 * You will need net-print/cups to be able to print and export to PDF with lib
reoffice.
 * If you plan to use lbase aplication you should enable java or you will get
various crashes.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

 * IMPORTANT: config file '/etc/hosts' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
These are the packages that would be merged, in order:

Calculating dependencies \

!!! Problem resolving dependencies for =app-office/libreoffice-3.5.5.3
... done!

!!! The ebuild selected to satisfy "=app-office/libreoffice-3.5.5.3" has unmet
 requirements.
- app-office/libreoffice-3.5.5.3::gentoo USE="binfilter branding cups dbus gno
me graphite gstreamer mysql nlpsolver nsplugin odk opengl pdfimport postgres t
est (-aqua) -binfilterdebug -eds -gtk -java -jemalloc -kde -svg -vba -webdav -
xmlsec"

  The following REQUIRED_USE flag constraints are unsatisfied:
    nsplugin? ( gtk ) gnome? ( gtk ) nlpsolver? ( java )

  The above constraints are a subset of the following complete expression:
    nsplugin? ( gtk ) gnome? ( gtk ) eds? ( gnome ) nlpsolver? ( java )
(In reply to comment #4)
> x86: all packages is OK for me
> with *-l10n packefe i am testing "en" and "ru" LINGUAS support: ok
Comment 6 Maurizio Camisaschi (amd64 AT) 2012-07-21 09:19:30 UTC
(In reply to comment #5)
> Hi, how did YOU test the package? did you do all the USEs combinations?
> 
> I'm trying to help stablize, so I'm using "tatt"(arch test tool) to do the
> verification.
> 

this isn't the right place to talk about this, if you want to get involved you can send a mail to the recruiters or join gentoo channels on irc to get more info ;)
Comment 7 Yixun Lan archtester gentoo-dev 2012-07-26 14:25:35 UTC
Archtested on x86: Everything fine \n
 both compile and run time OK \n
 all rdeps test passed

 * =app-office/libreoffice-3.5.5.3, test with following USEs combination
 * base
 *   USE: bash-completion binfilter branding dbus graphite gstreamer gtk ldap python templates webdav -java -gnome -eds -kde
 * base-java
 *   USE: bash-completion binfilter branding dbus graphite gstreamer gtk ldap python templates webdav java -gnome -eds -kde
 * kde
 *   USE: bash-completion binfilter branding dbus graphite gstreamer gtk ldap python templates webdav -java -gnome -eds kde
 * kde-java
 *   USE: bash-completion binfilter branding dbus graphite gstreamer gtk ldap python templates webdav java -gnome -eds kde
 * gnome
 *   USE: bash-completion binfilter branding dbus graphite gstreamer gtk ldap python templates webdav -java gnome eds -kde
 * gnome-java
 *   USE: bash-completion binfilter branding dbus graphite gstreamer gtk ldap python templates webdav java gnome eds -kde
Comment 8 Andreas Schürch gentoo-dev 2012-07-27 11:26:02 UTC
x86 stable, thanks Mikle and Dennis!
Comment 9 Andreas K. Hüttel archtester gentoo-dev 2012-07-31 21:25:57 UTC
amd64 and ppc already done by scarabeus
Comment 10 Martin Walch 2012-08-01 08:44:24 UTC
I guess you are aware that now there isn't any version of libreoffice left that can be compiled with gcc:4.4? (Just asking to make sure)
Comment 11 Andreas K. Hüttel archtester gentoo-dev 2012-08-01 08:52:30 UTC
(In reply to comment #10)
> I guess you are aware that now there isn't any version of libreoffice left
> that can be compiled with gcc:4.4? (Just asking to make sure)

Do I know that compiler?
Comment 12 Andreas K. Hüttel archtester gentoo-dev 2012-08-03 08:18:59 UTC
@ amd64, x86: binpackages are up. please test thoroughly and stabilize:

app-office/libreoffice-bin-3.5.5.3
app-office/libreoffice-bin-debug-3.5.5.3
Comment 13 Maurizio Camisaschi (amd64 AT) 2012-08-12 22:09:54 UTC
(In reply to comment #12)
> @ amd64, x86: binpackages are up. please test thoroughly and stabilize:
> 
> app-office/libreoffice-bin-3.5.5.3
> app-office/libreoffice-bin-debug-3.5.5.3

amd64 ok
Comment 14 Andreas Schürch gentoo-dev 2012-08-13 07:24:31 UTC
-bin pkgs on x86 done.
Comment 15 Agostino Sarubbo gentoo-dev 2012-08-14 12:56:00 UTC
amd64 stable
Comment 16 Tomáš Chvátal (RETIRED) gentoo-dev 2012-08-14 20:58:12 UTC
Hmm why did i cc ppc64, dunno.

Anyway it didn't have any stables so removing and closing.