Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 427040 - perl-core/Math-BigInt-1.997.0 "overload arg '..' is invalid" warning
Summary: perl-core/Math-BigInt-1.997.0 "overload arg '..' is invalid" warning
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-07-18 01:01 UTC by Hank Leininger
Modified: 2014-01-25 20:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to suppress warnings while setting up overloads (Math-BigInt-1.997.0_suppress_overload_warning.patch,883 bytes, patch)
2012-07-18 01:03 UTC, Hank Leininger
Details | Diff
Updated Math-BigInt ebuild that applies the overload patch (Math-BigInt-1.997.0-r1.ebuild,766 bytes, text/plain)
2012-07-18 01:04 UTC, Hank Leininger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hank Leininger 2012-07-18 01:01:53 UTC
Since upgrading to perl 5.16.0, Math-BigInt-1.997.0 causes an overload warning when used with -w:

$ perl -w -MMath::BigInt -e 1
overload arg '..' is invalid at /usr/lib64/perl5/vendor_perl/5.16.0/Math/BigInt.pm line 153.

My impression is that this has always(?) been a bug in Math-BigInt, but until perl 5.16.0 it did not generate a warning.

This appears to have been fixed in upstream git:
https://github.com/ilmari/perl/commit/5e0688b6067afdfb59fdfa9923e658ed40c9f246

...and in BigInt-1.998.

I'll attach a patch derived from upstream and an updated ebuild to apply it.

Reproducible: Always

Steps to Reproduce:
1. Upgrade to dev-lang/perl-5.16.0
2. Upgrade to perl-core/Math-BigInt-1.997.0
3. run perl -w -MMath::BigInt -e 1

Any other module that loads Math::BigInt will also trigger the warning.
Actual Results:  
overload arg '..' is invalid at /usr/lib64/perl5/vendor_perl/5.16.0/Math/BigInt.pm line 153.

A real script will still run, but anything watching STDERR (including a human) would react to that warning.

Expected Results:  
Nothing.
Comment 1 Hank Leininger 2012-07-18 01:03:31 UTC
Created attachment 318494 [details, diff]
Patch to suppress warnings while setting up overloads
Comment 2 Hank Leininger 2012-07-18 01:04:14 UTC
Created attachment 318496 [details]
Updated Math-BigInt ebuild that applies the overload patch
Comment 3 Hank Leininger 2012-07-18 01:05:37 UTC
I should have mentioned: I believe this is the root cause of at least this bug:

https://bugs.gentoo.org/show_bug.cgi?id=426356
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2012-07-19 15:41:29 UTC
Comment on attachment 318496 [details]
Updated Math-BigInt ebuild that applies the overload patch

--- Math-BigInt-1.997.0.ebuild  2011-09-05 19:13:28.000000000 +0200
+++ -   2012-07-19 17:41:21.893288805 +0200
@@ -22,3 +22,7 @@
        >=perl-core/Math-BigRat-0.260.200"
 
 SRC_TEST="do"
+
+src_prepare() {
+       epatch "${FILESDIR}/${P}_suppress_overload_warning.patch"
+}
Comment 5 Kristian Fiskerstrand (RETIRED) gentoo-dev 2013-12-17 22:09:01 UTC
I ran into this issue recently, the provided ebuild and patch fixes the issue for me.
Comment 6 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-01-25 20:21:12 UTC
fixed in CVS. Thanks.