Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 426970 - sci-physics/root-5.34.00: fails to build with glibc-2.16
Summary: sci-physics/root-5.34.00: fails to build with glibc-2.16
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrew Savchenko
URL: https://tinderboxlogs.s3.amazonaws.co...
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.16
  Show dependency tree
 
Reported: 2012-07-17 10:39 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2012-07-22 20:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2012-07-17 10:39:01 UTC
Portage 2.2.0_alpha116 (default/linux/amd64/10.0, gcc-4.7.1-asneeded, glibc-2.16.0, 3.4.4-hardened-r1 x86_64)
=================================================================
System uname: Linux-3.4.4-hardened-r1-x86_64-AMD_Opteron-TM-_Processor_6272-with-gentoo-2.1
Timestamp of tree: Thu, 05 Jul 2012 11:30:01 +0000
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p29
dev-java/java-config:     2.1.12
dev-lang/python:          2.6.8, 2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.4_p6-r1, 1.9.6-r3, 1.10.3, 1.11.5, 1.12.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2, 4.6.3, 4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -ggdb -march=native -ftracer -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/entropy /opt/openjms/config /usr/lib64/tomoyo/conf /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/qpsmtpd/plugins /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -ggdb -march=native -ftracer -frecord-gcc-switches"
DISTDIR="/var/cache/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict test test-fail-continue unknown-features-warn unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LC_ALL="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j24"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/var/cache/tinderbox/tree"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowex acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri ffmpeg fortran gdbm gnutls gpm iconv ipv6 mmx modules mudflap multilib ncurses nls nptl openmp pam pax_kernel pcre plasma pppd qt3support readline semantic-desktop session sse sse2 sse3 sse4 ssl ssse3 tcpd unicode vhosts xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19 ree18" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Andrew Savchenko gentoo-dev 2012-07-21 14:25:16 UTC
This is not a parallel build issue. (Have you tried with -j1 anyway?)

/tmp/portage/sci-physics/root-5.34.00/work/root/build/rmkdepend/main.c:64:12: error: conflicting types for 'fchmod'
In file included from /tmp/portage/sci-physics/root-5.34.00/work/root/build/rmkdepend/def.h:42:0,
                 from /tmp/portage/sci-physics/root-5.34.00/work/root/build/rmkdepend/main.c:30:
/usr/include/sys/stat.h:298:12: note: previous declaration of 'fchmod' was here

It looks like a glibc issue: /usr/include/sys/stat.h.

As for now glibc-2.16 is not supported, because it is not yet keyworded for any architecture. (And I can't ruin any of mine systems by installing an unsupported version of the core system library.)

If you will have this problem with glibc-2.15-r2 or less, feel free to reopen this bug. I can't reproduce it with glibc-2.15-r2.

P.S. I'm planning to update root to 5.34.01 soon. You are welcome to check this issue with a new version then.
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-07-21 14:33:26 UTC
Okay, let's start with "I don't care if it's not supported by _you_, but glibc-2.16 _is_ being tested and supported, so this is _not_ INVALID if it's failing with glibc-2.16.

No I didn't test with -j1 because if I had to try everything failing with -j1 it would probably not be able to test anything meaningfully, that's why there was a "?" in the subject.

The correct fix of course would be _not_ redeclaring fchmod.
Comment 3 Andrew Savchenko gentoo-dev 2012-07-21 15:19:43 UTC
Until glibc-2.16 will be keyworded it is impossible for me to test root build with glibc-2.16. Without proper testing fixing this only problem will do nothing, because similar or other glibc-related build issues may appear.

I'll fix this bug when glibc-2.16 will be keyworded if this will be still actual for in-tree root version at that moment.

According to Gentoo Devmanual, not keyworded => not supported.
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-07-21 15:26:57 UTC
It's not keyworded _because we know it breaks stuff_ and we want to fix it _before we keyword it_.

Now instead of trying to tell _the QA lead_ what is and isn't supported, what about setting up a chroot with glibc 2.16 and try to build it there?
Comment 5 Andrew Savchenko gentoo-dev 2012-07-21 15:56:58 UTC
(In reply to comment #4)
> Now instead of trying to tell _the QA lead_ what is and isn't supported,

Rules are supposed to be the same for everyone.

> what about setting up a chroot with glibc 2.16 and try to build it there?

I don't have CPU/time resources for a full chroot right now. Will look later at this issue.
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-07-22 00:57:29 UTC
The problem is that you don't understand the rules. Stating something is "not supported" does not mean "close as INVALID a valid bug because you don't want to spend time to fix it now". It means "patch welcome" if it's something that's _never_ going to be supported or "okay, as soon as I have time" if it's just a matter of time.

In the case of _any_ base system package that is masked _for testing_, whoever opens the bug, it is _not_ invalid. You might not put high priority on it but _you keep it open or we won't really know if there are issues with the package or not_.
Comment 7 Sébastien Fabbro (RETIRED) gentoo-dev 2012-07-22 20:36:52 UTC
fixed with a patch from fedora