Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 426898 - =app-emulation/virtualbox-modules-4.1.12 with sys-kernel/vanilla-sources-3.4.5 - src_test(): .../work/vboxdrv/r0drv/linux/memobj-r0drv-linux.c:1150:9: error: implicit declaration of function ‘do_mmap’
Summary: =app-emulation/virtualbox-modules-4.1.12 with sys-kernel/vanilla-sources-3.4....
Status: RESOLVED DUPLICATE of bug 419361
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-16 19:38 UTC by Toralf Förster
Modified: 2013-10-03 22:04 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (app-emulation:virtualbox-modules-4.1.12:20120716-192855.log.gz,5.56 KB, application/x-gzip)
2012-07-16 19:39 UTC, Toralf Förster
Details
environment file (environment,114.26 KB, text/plain)
2012-07-18 17:44 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2012-07-16 19:38:35 UTC
>>> Test phase [check]: app-emulation/virtualbox-modules-4.1.12
make[1]: Entering directory `/var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv'
make KBUILD_VERBOSE= SUBDIRS=/var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv SRCROOT=/var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/wo
rk/vboxdrv CONFIG_MODULE_SIG= -C /lib/modules/3.5.0-rc7+/build modules
make[2]: Entering directory `/home/tfoerste/devel/linux'
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/linux/SUPDrv-linux.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/SUPDrv.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/SUPDrvSem.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/alloc-r0drv.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/initterm-r0drv.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/memobj-r0drv.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/mpnotification-r0drv.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/powernotification-r0drv.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/linux/assert-r0drv-linux.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/linux/alloc-r0drv-linux.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/linux/initterm-r0drv-linux.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/linux/memobj-r0drv-linux.o
/var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/linux/memobj-r0drv-linux.c: In function ‘rtR0MemObjLinuxDoMmap’:
/var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/linux/memobj-r0drv-linux.c:1150:9: error: implicit declaration of function ‘do_mmap’
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv/r0drv/linux/memobj-r0drv-linux.o] Error 1
make[2]: *** [_module_/var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv] Error 2
make[2]: Leaving directory `/home/tfoerste/devel/linux'
make[1]: *** [vboxdrv] Error 2
make[1]: Leaving directory `/var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/work/vboxdrv'
make: *** [check] Error 2
 * ERROR: app-emulation/virtualbox-modules-4.1.12 failed (test phase):


Reproducible: Always




n22 /var/log/portage # emerge --info virtualbox-modules
Portage 2.1.11.7 (default/linux/x86/10.0/desktop/kde, gcc-4.5.3, glibc-2.14.1-r3, 3.5.0-rc7+ i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.5.0-rc7+-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Mon, 16 Jul 2012 11:15:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo toralf
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --keep-going=y --nospinner --tree --deep --quiet-build"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ http://gentoo.mirror.dkm.cz/pub/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.mneisen.org/ http://www.gtlib.gatech.edu/pub/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://linux.rz.ruhr-uni-bochum.de/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 berkdb bittorrent branding bzip2 cairo cdda cdr classic cli consolekit corefonts cracklib crypt css cups cxx dbus declarative dri dts dvb dvd dvdr emboss encode exif fam fastbuild ffmpeg firefox flac fontconfig fortran g3dvl gdbm gif git gmp gphoto2 gpm gtk hyphenation iconv ipv6 java jpeg kde kipi kqemu kvm lcms ldap libnotify lirc logrotate mad mbox mmx mng modules mp3 mp4 mpeg mudflap mysql mysqli ncurses nls nptl nsplugin ntfs ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd qt3support qt4 rdesktop readline sdl session sna spell sse sse2 sse3 ssl ssse3 startup-notification svg tcpd thinkpad threads tiff tk transparent-proxy truetype udev udisks unicode upower usb vim-syntax vnc vorbis wxwidgets x264 x86 xa xcb xcomposite xinerama xml xorg xpm xscreensaver xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" LIRC_DEVICES="devinput inputlirc" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

app-emulation/virtualbox-modules-4.1.12 was built with the following:
USE="(consolekit) (policykit) test -pax_kernel"
Comment 1 Toralf Förster gentoo-dev 2012-07-16 19:39:45 UTC
Created attachment 318366 [details]
build log
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2012-07-18 16:22:12 UTC
What is src_test() doing in /home/tfoerste/devel/linux? Maybe the environment file[1] can shed light on this matter.


[1] /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/temp/environment
Comment 3 Toralf Förster gentoo-dev 2012-07-18 17:44:37 UTC
Created attachment 318548 [details]
environment file

(In reply to comment #2)
> What is src_test() doing in /home/tfoerste/devel/linux? Maybe the
> environment file[1] can shed light on this matter.
> 
> 
> [1] /var/tmp/portage/app-emulation/virtualbox-modules-4.1.12/temp/environment

I did an
$> ebuild virtualbox-modules-4.1.12.ebuild test
and attached that file
Comment 4 Agostino Sarubbo gentoo-dev 2012-11-13 16:35:21 UTC
@Toralf:

is this still happen with new vanilla-sources?
Comment 5 Toralf Förster gentoo-dev 2012-11-13 16:42:19 UTC
kernel 3.6.6 + vbox 4.2.4. compiles fine so far
Comment 6 Agostino Sarubbo gentoo-dev 2012-11-13 16:55:12 UTC
(In reply to comment #5)
> kernel 3.6.6 + vbox 4.2.4. compiles fine so far

did you try in the past with 3.5.7?
Comment 7 Toralf Förster gentoo-dev 2012-11-13 17:18:09 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > kernel 3.6.6 + vbox 4.2.4. compiles fine so far
> 
> did you try in the past with 3.5.7?

Probably not - I switched to 3.6.2 when it came out. Unfortunately in neither of these emerge log the kernel version is stored :

tfoerste@n22 /var/log/portage $ qlop -gHv app-emulation/virtualbox
virtualbox-4.0.12: Sun Sep 25 17:30:01 2011: 36 minutes, 39 seconds
virtualbox-4.0.12: Thu Oct  6 11:37:38 2011: 36 minutes, 44 seconds
virtualbox-4.0.12: Sat Oct 22 15:25:13 2011: 32 minutes, 34 seconds
virtualbox-4.0.12: Tue Oct 25 09:21:27 2011: 35 minutes, 39 seconds
virtualbox-4.1.4: Wed Dec  7 20:29:17 2011: 56 minutes, 45 seconds
virtualbox-4.1.8: Mon Apr  9 19:32:53 2012: 59 minutes, 56 seconds
virtualbox-4.1.12: Mon Apr 23 15:49:23 2012: 1 hour, 4 minutes, 28 seconds
virtualbox-4.1.18: Mon Jul 23 15:44:43 2012: 1 hour, 48 seconds
virtualbox-4.1.18-r1: Tue Jul 24 18:19:24 2012: 56 minutes, 44 seconds
virtualbox-4.1.20: Tue Aug 21 19:51:22 2012: 53 minutes, 21 seconds
virtualbox-4.1.20-r1: Wed Aug 22 22:18:08 2012: 32 minutes, 49 seconds
virtualbox-4.2.0-r1: Fri Sep 14 18:10:20 2012: 1 hour, 1 minute, 20 seconds
virtualbox-4.2.2: Fri Nov  9 21:58:39 2012: 25 minutes, 29 seconds
virtualbox-4.2.4: Sat Nov 10 23:47:00 2012: 29 minutes, 19 seconds
virtualbox-4.2.4-r1: Mon Nov 12 22:13:21 2012: 26 minutes, 26 seconds
virtualbox: 15 times
Comment 8 Ben Kohler gentoo-dev 2013-10-03 22:04:10 UTC
This has been fixed upstream and all versions in portage contain the fix.  Bug 426898 is still open but I believe the user has a local configuration problem and it will be closed soon.

*** This bug has been marked as a duplicate of bug 419361 ***