Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 426872 - app-emulation/xen-tools-4.1* - disable HPET broadcast
Summary: app-emulation/xen-tools-4.1* - disable HPET broadcast
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Xen Devs
URL: http://lists.xen.org/archives/html/xe...
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2012-07-16 16:06 UTC by Andreas Kinzler
Modified: 2015-04-01 11:37 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
my personal portage overlay for Xen (portOvl-xen-160712.tgz,39.08 KB, application/octet-stream)
2012-07-16 16:08 UTC, Andreas Kinzler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kinzler 2012-07-16 16:06:39 UTC
Please see my mailing list post. Without a patch to completely disable HPET broadcast, you may experience an unstable system on xen 4.0/4.1.

Reproducible: Always
Comment 1 Andreas Kinzler 2012-07-16 16:08:09 UTC
Created attachment 318336 [details]
my personal portage overlay for Xen
Comment 2 Sven 2012-08-12 23:26:32 UTC
Is this fixed in 4.1.3 by any chance?
What was the result of your efforts to push this patch upstream?
Comment 3 Andreas Kinzler 2012-08-13 09:47:39 UTC
I don't think so. My patch is a workaround, not a bugfix. It disables all the HPET code, which as far as I know has never been fixed. But my research shows that you have to disable the buggy code for a stable system on non-ARAT CPUs (it is not used anyway on ARAT CPUs).
Comment 4 Yixun Lan gentoo-dev 2014-05-27 22:53:12 UTC
Andreas Kinzler, do you still have problem with xen's later versions? (4.2.4, 4.3.x)

and also I couldn't see any progress in xen upstream (eg, further discussion or with your patch accepted) ..
Comment 5 Ian Delaney (RETIRED) gentoo-dev 2015-04-01 11:37:17 UTC
No reply since 2012-07-16. No confirmation from any other source.