Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 426848 - net-misc/grive: remove explicit dependency on boost-1.48
Summary: net-misc/grive: remove explicit dependency on boost-1.48
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christoph Junghans
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks:
 
Reported: 2012-07-16 14:39 UTC by Tolga Dalman
Modified: 2012-07-21 19:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Update boost dependencies to >= 1.48 (grive-0.2.0.patch,291 bytes, patch)
2012-07-16 14:40 UTC, Tolga Dalman
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tolga Dalman 2012-07-16 14:39:22 UTC
Currently, grive RDEPENDs on boost:1.48. This isn't necessary as it works well with boost-1.49 (and supposedly higher versions as well). Attached patch updates ebuild. See Bug 407761.
Comment 1 Tolga Dalman 2012-07-16 14:40:04 UTC
Created attachment 318320 [details, diff]
Update boost dependencies to >= 1.48
Comment 2 Marios Andreopoulos 2012-07-21 11:56:25 UTC
Just to confirm, I am testing grive with boost version 1.49.0-r1 and it compiles and runs without problem.

I am on ~amd64.
Comment 3 Christoph Junghans gentoo-dev 2012-07-21 19:20:52 UTC
Fixed, thanks!