Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 426736 - x11-base/xorg-server segfaults at startup with x11-drivers/xf86-video-ati-6.14.4-r1
Summary: x11-base/xorg-server segfaults at startup with x11-drivers/xf86-video-ati-6.1...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-15 17:50 UTC by Honza
Modified: 2015-02-22 21:55 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Xorg log with the segfault (Xorg.4.log.old,26.46 KB, text/plain)
2012-07-15 17:53 UTC, Honza
Details
Xorg log which works (Xorg.4.log,31.62 KB, text/plain)
2012-07-15 17:55 UTC, Honza
Details
Xorg log with newer kernel (Xorg.4.log,31.61 KB, text/plain)
2012-07-16 23:44 UTC, Honza
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Honza 2012-07-15 17:50:38 UTC
When executing startx, the screen blink and then segfaults is reported. xinit needs to be stopped by ctrl+C.

The crash looks like this in Xorg.4.log

[  1238.782] (WW) RADEON(0): You need a newer kernel for sync extension
[  1238.782] (II) RADEON(0): [DRI2] Setup complete
[  1238.782] (II) RADEON(0): [DRI2]   DRI driver: r600
[  1238.782]
Backtrace:
[  1238.782] 0: /usr/bin/X (xorg_backtrace+0x37) [0x80a5c97]
[  1238.782] Segmentation fault at address (nil)
[  1238.782]
Fatal server error:
[  1238.782] Caught signal 11 (Segmentation fault). Server aborting

This actually started as attempt to upgrade to xorg-server 1.12, but when the X stopped working I tried downgrading. Originally working versions are:
media-libs/mesa-7.11.2
x11-drivers/xf86-video-ati-6.14.2
x11-base/xorg-server-1.10.4-r1
x11-libs/libdrm-2.4.27
The versions I tried (last stable as far as I know) when the crash first appeared
media-libs/mesa-8.0.3 
x11-drivers/xf86-video-ati-6.14.4-r1 
x11-base/xorg-server-1.12.2 
x11-libs/libdrm-2.4.33 
And the xserver started again after downgrading to
media-libs/mesa-7.11.2
x11-drivers/xf86-video-ati-6.14.3
x11-base/xorg-server-1.10.6-r1
x11-libs/libdrm-2.4.33


Reproducible: Always

Steps to Reproduce:
1. Have xf86-video-ati-6.14.4-r1
2. startx

Actual Results:  
The server segfaults.

Expected Results:  
It should start.

Portage 2.1.10.65 (hardened/linux/x86, gcc-4.3.4-hardenednopie, glibc-2.11.2-r3, 2.6.32-28-generic-pae i686)
=================================================================
System uname: Linux-2.6.32-28-generic-pae-i686-AMD_Phenom-tm-_II_X3_720_Processor-with-gentoo-1.12.11.1
Timestamp of tree: Sat, 14 Jul 2012 16:45:01 +0000
app-shells/bash:          4.0_p28
dev-java/java-config:     2.1.9-r1
dev-lang/python:          2.6.6-r2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      1.12.11.1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.4_p6, 1.6.3, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11.1
sys-devel/binutils:       2.18-r3, 2.20.1-r1
sys-devel/gcc:            2.95.3-r8::<unknown repository>, 3.4.6-r2, 4.3.4, 4.5.3-r2
sys-devel/gcc-config:     1.4.1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1
sys-libs/glibc:           2.11.2-r3
Repositories: gentoo sunrise x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mtune=k8 -march=k8 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -mtune=k8 -march=k8 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-march=i686 -O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=i686 -O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo http://ftp.sh.cvut.cz/MIRRORS/gentoo/gentoo/ http://gentoo.oregonstate.edu http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowex 3dnowext X Xaw3d aalib acl alsa apache2 apm avi bash-completion berkdb browserplugin bzip2 caps cdr cli cracklib crypt css cups curl cxx dbus dga directfb doc dri dts dvd encode erandom esd fbcon ffmpeg flac fltk force-cgi-redirect gd gdbm ggi gif gpm gtk hardened iconv imagemagick imlib innodb ipv6 jadetex java jpeg jpeg2k lcms lesstif libcaca libwww lirc lua mad mailwrapper matroska mbox mcal memlimit mikmod mmx mmx2 mmxext mng modules motif mozilla mpeg mudflap multislot mysql ncurses nls nptl ogg oggvorbis old-linux opengl openmp oss pam pax_kernel pcre pdflib perl pic png postscript pppd python qt quicktime readline samba sdl session slang snmp spell sqlite sse sse2 ssl svga tcpd tetex theora tiff truetype unicode urandom usb userlocales v4l v4l2 vhosts videos vorbis wmf x264 x86 xgetdefault xml xorg xosd xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access auth auth_dbm auth_anon auth_basic auth_digest authz_host authz_default authz_user alias file-cache echo charset-lite cache disk-cache mem-cache ext-filter case_filter case-filter-in deflate mime-magic cern-meta expires headers usertrack unique-id proxy proxy-connect proxy-ftp proxy-http info include cgi cgid dav dav-fs vhost-alias speling rewrite log_config logio env setenvif mime status autoindex asis negotiation dir imap actions userdir so mem_cache mime_magic vhost_alias filter authn_file" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="alpha arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="r128 radeon radeonhd vesa r300 r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

uname:
Linux rigel 2.6.32-28-generic-pae #55-Ubuntu SMP Mon Jan 10 22:34:08 UTC 2011 i686 AMD Phenom(tm) II X3 720 Processor AuthenticAMD GNU/Linux

The card is
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV730 PRO [Radeon HD 4650] [1002:9498] (prog-if 00 [VGA controller])
        Subsystem: PC Partner Limited Device [174b:e930]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 4 bytes
        Interrupt: pin A routed to IRQ 28
        Region 0: Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Region 2: Memory at fdfe0000 (64-bit, non-prefetchable) [size=64K]
        Region 4: I/O ports at ee00 [size=256]
        [virtual] Expansion ROM at fdf00000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [58] Express (v2) Legacy Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
                        ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <64ns, L1 <1us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Not Supported, TimeoutDis-
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
                LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
                         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                         Compliance De-emphasis: -6dB
                LnkSta2: Current De-emphasis Level: -6dB
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
                Address: 00000000fee0700c  Data: 4191
        Capabilities: [100] Vendor Specific Information <?>
        Kernel driver in use: radeon
        Kernel modules: radeon
Comment 1 Honza 2012-07-15 17:53:18 UTC
Created attachment 318244 [details]
Xorg log with the segfault

This is the log including the segfault with xorg-server already downgraded but xf86-video-ati-6.14.4-r1
Comment 2 Honza 2012-07-15 17:55:15 UTC
Created attachment 318246 [details]
Xorg log which works

This is the Xorg log after downgrading to x11-drivers/xf86-video-ati-6.14.3 which seems to fix the problem.
Comment 3 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2012-07-15 20:33:35 UTC
Upgrading to xf86-video-ati-6.14.5 helps as well.
Comment 4 Honza 2012-07-15 23:15:27 UTC
... noticed that now 3d accelerated application looks VERY weird. Can be "fixed" by eselect mesa set r600 classic ...
Comment 5 Honza 2012-07-16 23:37:43 UTC
Alternatively, after upgrade to linux kernel 2.6.35-32-generic-pae #67-Ubuntu SMP it works even with Gallium.
Comment 6 Honza 2012-07-16 23:44:08 UTC
Created attachment 318390 [details]
Xorg log with newer kernel

Xorg log with newer kernel (2.6.35-32-generic-pae #67-Ubuntu SMP)
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-07-18 11:50:22 UTC
Is there a reason why you are using such an old X server?
Comment 8 Honza 2012-07-18 21:13:12 UTC
(In reply to comment #7)
> Is there a reason why you are using such an old X server?

If you read the report carefully you notice that I tried to upgrade it and then downgrade back DUE to this error. Of course as it didn't helped it may not actually be related - the problem might appear because of upgrade of x11-drivers/xf86-video-ati done when recompiling X drivers.
Comment 9 Matt Turner gentoo-dev 2015-02-22 21:55:51 UTC
Hopefully fixed long ago. If not, open a bug upstream https://bugs.freedesktop.org/enter_bug.cgi?product=xorg&component=Driver/Radeon