Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 426390 - dev-db/mysql-workbench-5.2.35 could not communicating with gnome-keyring-daemon for store password
Summary: dev-db/mysql-workbench-5.2.35 could not communicating with gnome-keyring-dae...
Status: RESOLVED DUPLICATE of bug 423993
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-13 03:44 UTC by dongwm
Modified: 2012-07-26 18:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dongwm 2012-07-13 03:44:26 UTC
When I use emerge to install mysql-workbench,i try to create  a new connection with open "Database -> Manage connections..." menu and fill the required values, click on the "Store in the Keychain..." button and enter the password ,but when i click on the "OK" button, the following message is shown in a popup:

Store Password
Could not store password: Error communicating with gnome-keyring-daemon

Here are some help:
gnome-keyring has up:
dongwm@localhost ~ $ ps -ef |grep gnome-keyring |grep -v grep
root     14151     1  0 11:31 pts/1    00:00:00 /usr/bin/gnome-keyring-daemon -s -d
dongwm@localhost ~ $ sudo ls -la /tmp/keyring-Cr1PaF
total 8
drwx------  2 root root 4096 Jul 13 11:31 .
drwxrwxrwt 21 root root 4096 Jul 13 11:36 ..
srwxr-xr-x  1 root root    0 Jul 13 11:31 control
srwxr-xr-x  1 root root    0 Jul 13 11:31 gpg
srwxr-xr-x  1 root root    0 Jul 13 11:31 pkcs11
srwxr-xr-x  1 root root    0 Jul 13 11:31 ssh

terminal to print information like this:
** Message: secret service operation failed: Message did not receive a reply (timeout by message bus)

dongwm@localhost ~ $ gnome-about --gnome-version

(process:14530): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.  Originally my system language is Chinese
Version: 2.32.1
Distributor: Gentoo
Build Date: 07/11/12

dongwm@localhost ~ $ sudo emerge -s mysql-workbench
Searching...    
[ Results for search key : mysql-workbench ]
[ Applications found : 1 ]

*  dev-db/mysql-workbench
      Latest version available: 5.2.35
      Latest version installed: 5.2.35
      Size of files: 17,455 kB
      Homepage:      http://dev.mysql.com/workbench/
      Description:   MySQL Workbench
      License:       GPL-2

dongwm@localhost ~ $ sudo emerge --info

Portage 2.1.10.65 (default/linux/x86/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r3, 3.2.21-gentoo i686)
=================================================================
System uname: Linux-3.2.21-gentoo-i686-Intel-R-_Core-TM-_i5-2300_CPU_@_2.80GHz-with-gentoo-2.1
Timestamp of tree: Tue, 10 Jul 2012 01:45:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo gentoo-china
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA google-chrome adobe-flash"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news nostrip parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://mirrors.stuhome.net/gentoo/"
LANG="en_us.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/gentoo-china"
SYNC="rsync://rsync.cn.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa ati berkdb bluetooth branding bzip2 cairo cdda cdr cli colord compiz consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss emerald encode evo exif fam firefox flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk handbook iconv ipv6 jpeg kde lcms ldap libkms libnotify mad minizip mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio python qt3 qt3support qt4 readline sasl sdl session socialweb spell sqlite ssl startup-notification svg symlink tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 x86 xcb xml xorg xv xvid zh_CN zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 dongwm 2012-07-18 10:37:16 UTC
No one to help me?
Comment 2 Hans de Graaff gentoo-dev 2012-07-22 12:56:07 UTC
Can you test with mysql-workbench 5.2.40?
Comment 3 dongwm 2012-07-23 01:55:41 UTC
sorry,When i installed mysql-workbench-5.2.40,The error still exists

dongwm@localhost ~ $ sudo emerge -s mysql-workbench
Searching...    
[ Results for search key : mysql-workbench ]
[ Applications found : 1 ]

*  dev-db/mysql-workbench
      Latest version available: 5.2.40
      Latest version installed: 5.2.40
      Size of files: 18,459 kB
      Homepage:      http://dev.mysql.com/workbench/
      Description:   MySQL Workbench
      License:       GPL-2
Comment 4 Hans de Graaff gentoo-dev 2012-07-23 17:19:05 UTC
I can't reproduce this. What version of gnome-keyring and libgnome-keyring are you using? What does mysql-workbench configure output say about gnome-keyring?

You might also want to check .xsession-errors as it may contain more clues.
Comment 5 dongwm 2012-07-24 06:26:09 UTC
The libgnome-keyring version is 2.32.0
The gnome-keyring version is 2.32.1

mysql-workbench error is:
Could not store password: Error communicating with gnome-keyring-daemon

or please see this image:
https://p.twimg.com/AyjDQFRCQAAAVpg.png

will be printed one line on my terminal(error once print a line):
dongwm@localhost ~ $ mysql-workbench
Ready.

** Message: secret service operation failed: Message did not receive a reply (timeout by message bus)
** Message: secret service operation failed: Message did not receive a reply (timeout by message bus)
** Message: secret service operation failed: Message did not receive a reply (timeout by message bus)

depending on your tips,but when reproduce this,~/.xsession-errors did not add any error,this is my .xsession-errors content:
http://pastebin.com/MKsfs0Yg

in this i find:

/etc/X11/gdm/Xsession: Setup done, will execute: /usr/bin/dbus-launch --exit-with-session /usr/bin/ssh-agent -- gnome-session

** (gnome-keyring-daemon:13043): WARNING **: couldn't read 4 bytes from control socket: Connection reset by peer
 
** (gnome-keyring-daemon:13044): WARNING **: couldn't read 4 bytes from control socket: Connection reset by peer

** (gnome-keyring-daemon:13045): WARNING **: couldn't read 4 bytes from control socket: Connection reset by peer
Comment 6 dongwm 2012-07-24 06:39:01 UTC
Added: I manually run this:

dongwm@localhost ~ $ /usr/bin/dbus-launch --exit-with-session /usr/bin/ssh-agent -- gnome-session
** Message: couldn't connect to control socket at: /tmp/keyring-6Z9de0/control: Connection refused
GNOME_KEYRING_CONTROL=/tmp/keyring-wS0tmI
GPG_AGENT_INFO=/tmp/keyring-wS0tmI/gpg:0:1
GNOME_KEYRING_PID=13830
** Message: couldn't connect to control socket at: /tmp/keyring-6Z9de0/control: Connection refused
** Message: couldn't connect to control socket at: /tmp/keyring-6Z9de0/control: Connection refused
** Message: couldn't connect to control socket at: /tmp/keyring-6Z9de0/control: Connection refused
GNOME_KEYRING_CONTROL=/tmp/keyring-wS0tmI
GPG_AGENT_INFO=/tmp/keyring-wS0tmI/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-wS0tmI
GPG_AGENT_INFO=/tmp/keyring-wS0tmI/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-wS0tmI
GPG_AGENT_INFO=/tmp/keyring-wS0tmI/gpg:0:1
SSH_AUTH_SOCK=/tmp/keyring-wS0tmI/ssh
Comment 7 Hans de Graaff gentoo-dev 2012-07-26 05:24:05 UTC
(In reply to comment #6)
> Added: I manually run this:
> 
> dongwm@localhost ~ $ /usr/bin/dbus-launch --exit-with-session
> /usr/bin/ssh-agent -- gnome-session
> ** Message: couldn't connect to control socket at:
> /tmp/keyring-6Z9de0/control: Connection refused

I think this is the real problem, and that it is not related to mysql-workbench. I don't know anything about the permissions mechanisms in Gnome so I can't help you with that.
Comment 8 Pacho Ramos gentoo-dev 2012-07-26 06:32:00 UTC
Please look to /var/log/messages and dmesg to see if kernel is killing gnome-keyring/dbus in some way
Comment 9 dongwm 2012-07-26 12:02:55 UTC
like you say, when i reproduce the error ,
dmesg and  /var/log/messages add this:

gnome-keyring-d[5086] general protection ip:b74fd69f sp:bffa8860 error:0 in libgcrypt.so.11.7.0[b74d3000+77000]


but killed the process ,there is nothing added
Comment 10 dongwm 2012-07-26 12:06:36 UTC
Add:
after i reproduce the error ,the gnome-keyring daemon is dead
Comment 11 Pacho Ramos gentoo-dev 2012-07-26 18:46:46 UTC

*** This bug has been marked as a duplicate of bug 423993 ***