Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 425332 - net-dialup/capisuite-0.4.5 doesn't compile with python 3.* as active python interpreter
Summary: net-dialup/capisuite-0.4.5 doesn't compile with python 3.* as active python i...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Dialup Developers
URL:
Whiteboard:
Keywords: EBUILD
: 467092 (view as bug list)
Depends on: 424892
Blocks:
  Show dependency tree
 
Reported: 2012-07-08 15:25 UTC by Dennis Freise
Modified: 2013-04-24 18:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
capisuite-0.4.5-r7.ebuild (capisuite-0.4.5-r7.ebuild,2.38 KB, text/plain)
2012-07-08 15:25 UTC, Dennis Freise
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Freise 2012-07-08 15:25:21 UTC
Created attachment 317580 [details]
capisuite-0.4.5-r7.ebuild

As capisuite-0.4.5-r6 fails to build with python 3.2, I took the liberty to use portages possibilities to clean up the ebuild and add python_set_active_version 2.

This ebuild uses my patch from bug #424892.

Please verify my work and add this ebuild to portage.
Comment 1 Sergey Popov gentoo-dev 2013-04-01 17:30:00 UTC
+  01 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> +capisuite-0.4.5-r7.ebuild:
+  Revision bump: EAPI 5, use autotools-utils and python-single-r1 eclasses,
+  fixes bugs #315089 and #425332
Comment 2 Jeroen Roovers gentoo-dev 2013-04-24 18:05:57 UTC
*** Bug 467092 has been marked as a duplicate of this bug. ***