Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 425316 - app-misc/fdutils-5.5-r2 - fdmount.c:25:27: fatal error: linux/ext2_fs.h: No such file or directory
Summary: app-misc/fdutils-5.5-r2 - fdmount.c:25:27: fatal error: linux/ext2_fs.h: No s...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Kernel Miscellaneous
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-08 12:45 UTC by Peter Sliepenbeek
Modified: 2013-03-20 18:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The complete build log. (app-misc:fdutils-5.5-r2:20120709-191612.log,9.22 KB, text/plain)
2012-07-09 19:18 UTC, Peter Sliepenbeek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Sliepenbeek 2012-07-08 12:45:55 UTC
app-misc/fdutils-5.5-r2 fails with fatal error: linux/ext2_fs.h: No such file or directory

Reproducible: Always

Steps to Reproduce:
1.emerge -1 app-misc/fdutils
Actual Results:  
...
fdmount.c:25:27: fatal error: linux/ext2_fs.h: No such file or directory
compilation terminated.
...


# emerge --info
Portage 2.1.10.65 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r3, 3.3.8-gentoo x86_64)
=================================================================
System uname: Linux-3.3.8-gentoo-x86_64-AMD_Phenom-tm-_9950_Quad-Core_Processor-with-gentoo-2.1
Timestamp of tree: Sun, 08 Jul 2012 05:30:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB nl"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl acpi alsa amd64 berkdb bzip2 cli cracklib crypt cups cxx dbus dri fortran gdbm gpm iconv ipv6 kde midi mmx modules mudflap multilib ncurses nls nptl opengl openmp pam pcre pppd qt3support qt4 readline session sse sse2 ssl tcpd udev unicode xcomposite xorg zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB nl" NETBEANS_MODULES="*" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Arttu Valo 2012-07-08 14:13:32 UTC
fdutils ebuilds have keywords for x86 and ppc only, and you are trying to emerge one on amd64. I don't think this is supported.
Comment 2 Peter Sliepenbeek 2012-07-08 16:38:41 UTC
Up until now it has always build successfully.
Comment 3 Jeroen Roovers gentoo-dev 2012-07-09 18:50:19 UTC
Please attach the entire build log to this bug report.
Comment 4 Peter Sliepenbeek 2012-07-09 19:18:34 UTC
Created attachment 317724 [details]
The complete build log.
Comment 5 Arttu Valo 2012-07-16 15:54:48 UTC
Kernel headers stuff, way beyond my expertise. But found a Debian/Ubuntu patch "fdmount-compilation_linux_2.6.patch" by Jochen Voss in this tarball:
http://archive.ubuntu.com/ubuntu/pool/universe/f/fdutils/fdutils_5.5-20060227-5.debian.tar.gz

It worked "out of the box", just by adding it to the group of other applied patches in the ebuild. ("Worked" = emerge passed, didn't test further.)

Maybe also add a ~amd64 keyword to the ebuild as well, if it works on amd64?
Comment 6 Paul Hartman 2012-12-12 05:51:37 UTC
(In reply to comment #5)
> Kernel headers stuff, way beyond my expertise. But found a Debian/Ubuntu
> patch "fdmount-compilation_linux_2.6.patch" by Jochen Voss in this tarball:
> http://archive.ubuntu.com/ubuntu/pool/universe/f/fdutils/fdutils_5.5-
> 20060227-5.debian.tar.gz
> 
> It worked "out of the box", just by adding it to the group of other applied
> patches in the ebuild. ("Worked" = emerge passed, didn't test further.)
> 
> Maybe also add a ~amd64 keyword to the ebuild as well, if it works on amd64?

Thanks, I am on ~amd64 as well. Compiled fdutils using that additional patch and the fdutils commands I have tried so far seem to work as intended on kernel 3.7.0.
Comment 7 Michael Mair-Keimberger (iamnr3) 2013-03-20 17:23:01 UTC
I've updated the ebuild (see bug 337721) and added this patch. Also seems to work for me on 3.7.10
Comment 8 Samuli Suominen gentoo-dev 2013-03-20 18:39:27 UTC
fixed in version fdutils-5.5.20060227