Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 42519 - portage 2.0.50 emerge unmegre ends in traceback
Summary: portage 2.0.50 emerge unmegre ends in traceback
Status: RESOLVED CANTFIX
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 81356
  Show dependency tree
 
Reported: 2004-02-22 14:29 UTC by Percy Jahn
Modified: 2005-02-09 21:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Percy Jahn 2004-02-22 14:29:08 UTC
ive just installes portage 2.0.50 and tried to unmerge the gentoo-sources (im using stable now...). It ends with the folowing output:



Reproducible: Always
Steps to Reproduce:
1. emerge -C sys-kernel/gentoo-sources
2.
3.

Actual Results:  
<cut>
<<<        obj /usr/src/linux-2.4.22-gentoo-r4/Documentation/00-INDEX
<<<        obj /usr/src/linux-2.4.22-gentoo-r4/CREDITS
<<<        obj /usr/src/linux-2.4.22-gentoo-r4/COPYING
<<<        obj /usr/share/doc/gentoo-sources-2.4.22-r4/patches.txt.gz
Traceback (most recent call last):
  File "/usr/bin/emerge", line 2366, in ?
    if 1==unmerge(myaction, myfiles):
  File "/usr/bin/emerge", line 1852, in unmerge
    retval=portage.unmerge(mysplit[0],mysplit
[1],portage.root,mysettings,unmerge_action not in ["clean","prune"])
  File "/usr/lib/portage/pym/portage.py", line 2496, in unmerge
    mylink.unmerge(trimworld=mytrimworld,cleanup=1)
  File "/usr/lib/portage/pym/portage.py", line 5291, in unmerge
    if (pkgfiles[obj][0] not in ("dir","fif","dev","sym")) and (lmtime != 
pkgfiles[obj][1]):
KeyError: '.'


Expected Results:  
complete removing of the sources ...

Ive had 2 other revisions of the gentoo-sources installed. There was no problem 
unmegring both with the same portage version.
emerge info output:

Portage 2.0.50-r1 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r9, 2.4.23_pre8-gss-
r2)
=================================================================
System uname: 2.4.23_pre8-gss-r2 i686 Celeron (Coppermine)
Gentoo Base System version 1.4.3.10
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.7.7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -mcpu=pentium2 -pipe"
CHOST="i586-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/
config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -mcpu=pentium2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp.uni-
erlangen.de/pub/mirrors/gentoo http://mirrors.sec.informatik.tu-
darmstadt.de/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/pub/krypi/src/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X apm arts avi berkdb crypt cups encode foomaticdb gdbm gif gnome gpm gtk 
gtk2 imlib java jpeg kde libg++ libwww mad mikmod motif mpeg ncurses nls 
oggvorbis opengl oss pam pdflib perl png postgres python qt quicktime readline 
ruby sdl slang spell ssl svga tcpd truetype x86 xml2 xmms xv zlib"
Comment 1 Brian Harring gentoo-dev 2004-08-11 14:37:34 UTC
Can't reproduce this; offhand I'd suspect a corrupted CONTENTS file.
Reopen if you're still encountering it.