Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 424906 - dev-libs/boost-1.49.0 clashes with sys-libs/glibc-2.16
Summary: dev-libs/boost-1.49.0 clashes with sys-libs/glibc-2.16
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: C++ Team [disbanded]
URL:
Whiteboard:
Keywords:
: 429984 432586 440688 (view as bug list)
Depends on:
Blocks: glibc-2.16
  Show dependency tree
 
Reported: 2012-07-05 13:20 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2012-11-01 08:27 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
boost-1.49.0-xtime.patch (boost-1.49.0-xtime.patch,1.86 KB, patch)
2012-07-05 22:45 UTC, Stevan Bajić
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2012-07-05 13:20:28 UTC
Building sci-visualisation/nonolith-connect (but I guess the same applied to other packages as drizzle failed to find boost!):


x86_64-pc-linux-gnu-g++ -o streaming_device/ws_api.o -c -O2 -pipe -ggdb -march=native -ftracer -frecord-gcc-switches -Ilibusb -Iwebsocketpp/src -Wall streaming_device/ws_api.cpp
In file included from /usr/include/boost/thread/pthread/mutex.hpp:14:0,
                 from /usr/include/boost/thread/mutex.hpp:16,
                 from /usr/include/boost/thread/pthread/thread_data.hpp:12,
                 from /usr/include/boost/thread/thread.hpp:17,
                 from /usr/include/boost/thread.hpp:13,
                 from usb.cpp:13:
/usr/include/boost/thread/xtime.hpp:23:5: error: expected identifier before numeric constant
/usr/include/boost/thread/xtime.hpp:23:5: error: expected '}' before numeric constant
/usr/include/boost/thread/xtime.hpp:23:5: error: expected unqualified-id before numeric constant
/usr/include/boost/thread/xtime.hpp:46:14: error: expected type-specifier before 'system_time'


line 23 of that file is the first line of this enum:


enum xtime_clock_types
{
    TIME_UTC=1
//    TIME_TAI,
//    TIME_MONOTONIC,
//    TIME_PROCESS,
//    TIME_THREAD,
//    TIME_LOCAL,
//    TIME_SYNC,
//    TIME_RESOLUTION
};

and of course it's defined now in time.h when ISOC11 is enabled (which seems to be for whatever reason in that case):

# ifdef __USE_ISOC11
/* Time base values for timespec_get.  */
# define TIME_UTC 1
# endif
Comment 1 Stevan Bajić 2012-07-05 22:45:06 UTC
Created attachment 317366 [details, diff]
boost-1.49.0-xtime.patch

This patch fixes the issue.
Comment 2 SpanKY gentoo-dev 2012-07-06 03:48:00 UTC
not a bug in glibc, so not anything for toolchain@g.o to do i can see
Comment 3 Martin Jansa 2012-07-06 10:04:28 UTC
It's fixed in upstream version 1.50, probably upgrading boost would be better.
Comment 4 Arfrever Frehtes Taifersar Arahesis 2012-07-07 20:09:59 UTC
boost::TIME_UTC has been renamed to boost::TIME_UTC_ in Boost 1.50, which is now available in gentoo-x86.
Comment 5 Arfrever Frehtes Taifersar Arahesis 2012-07-07 20:11:10 UTC
(In reply to comment #4)

https://svn.boost.org/trac/boost/ticket/6940
https://svn.boost.org/trac/boost/changeset/78802
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-08-05 23:31:10 UTC
*** Bug 429984 has been marked as a duplicate of this bug. ***
Comment 7 Andrew Aladjev 2012-10-12 12:57:52 UTC
same issue. I've just installed 1.51.0 from poly-c overlay
Comment 8 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-10-31 01:00:03 UTC
*** Bug 432586 has been marked as a duplicate of this bug. ***
Comment 9 Christohper Harrington 2012-11-01 00:10:19 UTC
Having the same symptom but while building boost itself (ie dev-libs/boost-1.49.0-r2) shortly after merging sys-libs/glibc-2.16.0. Can attach emerge --info, boost buildlog, etc if requested.
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-11-01 07:00:36 UTC
*** Bug 440688 has been marked as a duplicate of this bug. ***