Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 424657 - app-portage/g-cpan-0.16.4-r1 uses code that is depreciated in perl-5.16.0
Summary: app-portage/g-cpan-0.16.4-r1 uses code that is depreciated in perl-5.16.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal minor (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-03 21:35 UTC by Paul McDermott
Modified: 2014-07-14 11:45 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Modify qw sintax (g-cpan-0.16.4-perlver.patch,2.84 KB, patch)
2012-07-18 05:25 UTC, Roberto Araneda
Details | Diff
-r2 ebuild (g-cpan-0.16.4-r2.ebuild,1.26 KB, text/plain)
2012-07-18 05:32 UTC, Roberto Araneda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul McDermott 2012-07-03 21:35:44 UTC
g-cpan warns about depreciated code when run under perl 5.16

Reproducible: Always

Steps to Reproduce:
1.g-cpan
2.
3.
Actual Results:  
Use of qw(...) as parentheses is deprecated at /usr/lib/perl5/vendor_perl/5.16.0/Gentoo/CPAN.pm line 324.
Use of qw(...) as parentheses is deprecated at /usr/lib/perl5/vendor_perl/5.16.0/Gentoo/CPAN.pm line 386.
Use of qw(...) as parentheses is deprecated at /usr/bin/g-cpan line 716.


Expected Results:  
g-cpan runs normally

[5002:~]$ emerge --info
Portage 2.1.10.65 (default/linux/x86/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r3, 3.2.12-gentoo i686)
=================================================================
System uname: Linux-3.2.12-gentoo-i686-Intel-R-_Core-TM-_i7_CPU_950_@_3.07GHz-with-gentoo-2.1
Timestamp of tree: Tue, 03 Jul 2012 01:45:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 Oracle-BCLA-JavaSE AdobeFlash-10.3"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-2.2/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://mirror.bih.net.ba/gentoo/ http://128.61.111.9/pub/gentoo rsync://212.219.56.133/www.ibiblio.org/gentoo/ ftp://gentoo.imj.fr/pub/gentoo/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB en"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa bash-completion bluetooth branding bzip2 bzlib cairo cdda cdr cli colord consolekit cracklib crypt ctype cups cxx dba dbus dovecot-sasl dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv imap java5 jpeg lcms libnotify libwww logrotate mad maildir mmx mng modules mp3 mp4 mpeg mudflap mysql nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 readline sasl scanner sdl session socialweb spell ssl startup-notification svg syslog tcpd threads tiff truetype udev udisks unicode upower usb userlocales vim vim-syntax vorbis wxwidgets x264 x86 xcb xml xmlrpc xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Roberto Araneda 2012-07-18 05:22:16 UTC
starting with perl 5.14  the sintax "for ... qw()" should be "for ... (qw ())".

I attached a patch file very simple, for used this is necessary modify (attached too) the  ebuild for included this patch and verify the perl version (greather of 5.16 because 5.14 is marked as masked)
Comment 2 Roberto Araneda 2012-07-18 05:25:20 UTC
Created attachment 318506 [details, diff]
Modify qw sintax

This patch modify the sintax qw for new perl version
Comment 3 Roberto Araneda 2012-07-18 05:32:23 UTC
Created attachment 318508 [details]
-r2 ebuild

Ebuild for validate the perl version and include the patch
Comment 4 Tony Vroon gentoo-dev 2014-07-14 11:45:44 UTC
+*g-cpan-0.16.5 (14 Jul 2014)
+
+  14 Jul 2014; Tony Vroon <chainsaw@gentoo.org> +g-cpan-0.16.5.ebuild:
+  Release incorporating fixes from bugs #420617, #424657 & #484108. With both
+  my thanks and my apologies to Sergiy Borodych, Roberto Araneda & Petr Pisar.