Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 424201 - media-video/miro-5.0.1 - .../work/miro-5.0.1/linux/miro-segmenter.c:236:45: error: ‘URL_WRONLY’ undeclared (first use in this function)
Summary: media-video/miro-5.0.1 - .../work/miro-5.0.1/linux/miro-segmenter.c:236:45: e...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jeff (JD) Horelick (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-30 04:57 UTC by Mathieu Z
Modified: 2016-05-06 10:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Z 2012-06-30 04:57:51 UTC
cc failed.

Reproducible: Always

Steps to Reproduce:
1. emerge miro
2.
3.
Actual Results:  
# cat /var/log/portage/build/media-video/miro-5.0.1\:20120629-224729.log 
 * Package:    media-video/miro-5.0.1
 * Repository: gentoo
 * Maintainer: jdhore@gentoo.org
 * USE:        aac amd64 elibc_glibc kernel_linux libnotify multilib musepack userland_GNU xvid
 * FEATURES:   ccache preserve-libs sandbox
>>> Unpacking source...
>>> Unpacking miro-5.0.1.tar.gz to /var/tmp/portage/media-video/miro-5.0.1/work
>>> Source unpacked in /var/tmp/portage/media-video/miro-5.0.1/work
>>> Preparing source in /var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux ...
python2.7 setup.py build
running build
creating build
creating build/miro-segmenter
creating build/miro-segmenter/var
creating build/miro-segmenter/var/tmp
creating build/miro-segmenter/var/tmp/portage
creating build/miro-segmenter/var/tmp/portage/media-video
creating build/miro-segmenter/var/tmp/portage/media-video/miro-5.0.1
creating build/miro-segmenter/var/tmp/portage/media-video/miro-5.0.1/work
creating build/miro-segmenter/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1
creating build/miro-segmenter/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux
cc -march=native -fomit-frame-pointer -O2 -pipe -I/usr/include/ffmpeg -c /var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux/miro-segmenter.c -o build/miro-segmenter/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux/miro-segmenter.o
/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux/miro-segmenter.c: In function ‘add_output_stream’:
/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux/miro-segmenter.c:43:5: warning: ‘av_new_stream’ is deprecated (declared at /usr/include/libavformat/avformat.h:1557) [-Wdeprecated-declarations]
/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux/miro-segmenter.c: In function ‘main’:
/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux/miro-segmenter.c:165:5: warning: ‘av_find_stream_info’ is deprecated (declared at /usr/include/libavformat/avformat.h:1357) [-Wdeprecated-declarations]
/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux/miro-segmenter.c:231:9: warning: ‘avcodec_open’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3380) [-Wdeprecated-declarations]
/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux/miro-segmenter.c:236:45: error: ‘URL_WRONLY’ undeclared (first use in this function)
/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux/miro-segmenter.c:236:45: note: each undeclared identifier is reported only once for each function it appears in
error: command 'cc' failed with exit status 1
 * ERROR: media-video/miro-5.0.1 failed (compile phase):
 *   Building failed
 * 
 * Call stack:
 *     ebuild.sh, line   85:  Called src_compile
 *   environment, line 5357:  Called distutils_src_compile
 *   environment, line 1262:  Called die
 * The specific snippet of code:
 *               "$(PYTHON)" "${setup_file#*|}" "${_DISTUTILS_GLOBAL_OPTIONS[@]}" build "$@" || die "Building failed";
 * 
 * If you need support, post the output of `emerge --info '=media-video/miro-5.0.1'`,
 * the complete build log and the output of `emerge -pqv '=media-video/miro-5.0.1'`.
 * The complete build log is located at '/var/log/portage/build/media-video/miro-5.0.1:20120629-224729.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/media-video/miro-5.0.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/miro-5.0.1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux'
 * S: '/var/tmp/portage/media-video/miro-5.0.1/work/miro-5.0.1/linux'


Portage 2.2.0_alpha114 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r2, 3.3.4-ck x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.3.4-ck-x86_64-Intel-R-_Core-TM-_i7_CPU_L_620_@_2.00GHz-with-gentoo-2.1
Timestamp of tree: Fri, 29 Jun 2012 16:30:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p29
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5, 1.12.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: x11 lisp science desktop-effects gentoo-zh gentoo-haskell java-overlay cj-overlay sunrise mz-overlay gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -fomit-frame-pointer -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -fomit-frame-pointer -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --quiet-build n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles metadata-transfer news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms sign split-elog split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://gentoo.osuosl.org/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O2 -Wl,--hash-style=both"
LINGUAS="en ja zh zh_CN zh_TW en_US en_GB"
MAKEOPTS="-j4 --load-average"
PKGDIR="/usr/portage//packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/lisp /var/lib/layman/science /var/lib/layman/desktop-effects /var/lib/layman/gentoo-zh /var/lib/layman/haskell /var/lib/layman/java-overlay /var/lib/layman/cj-overlay /var/lib/layman/sunrise /usr/local/portage /usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acl acpi aim alsa amd64 apache2 audiofile avahi bash-completion bcmath berkdb bidi bittorrent blas bluetooth branding btrfs bzip2 c++0x cairo calendar caps ccache cdaudio cdda chm cjk cleartype cli clisp consolekit cracklib crypt cscope css ctype cups curl curlwrappers cxx dbus dbx dga dhcpcd directfb djvu dri dts dv dvd dvdread dvi ebook eds emacs emacs-w3 encode enscript evo exif expat faac fam fastcgi fbcon ffmpeg fftw flac flash fontconfig foomaticdb fortran freetds ftp fuse gallium gcl gconf gd gdbm ginac git glib glitz glut gmp gnome gnome-keyring gnuplot gnutls gpg gphoto2 gpm gps gs gsl gstreamer gtk gtk3 gtkhtml gzip hdaps highlight httpd iconv icq icu idn ieee1394 imagemagick imap imlib innodb inotify introspection ipod ipv6 jabber java javascript joystick jpeg jpeg2k kpathsea lame lapack laptop latex latex3 lcms libcaca libnotify llvm lm_sensors lua luatex lzma m17n-lib mad matroska mercurial mime mmx mmxext mng modplug modules mp3 mp4 mpeg mpi mplayer msn mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses netboot networkmanager nis nls nntp nptl nsplugin nss ntp odbc ogg openal openexr opengl openmp openntpd openssl osc oscar pae pam pch pcre pda pdf plotutils png policykit posix postgres postscript ppds pppd pulseaudio qq qt3support qt4 quicktime rar rcs readline recode resolvconf rss rtmp samba sasl scanner sdl session simplexml slang sndfile snmp sockets socks5 speex spell sql sqlite sqlite3 sse sse2 sse3 ssl ssse3 subversion svg system-sqlite t1lib taglib tcpd theora threads tidy tiff timidity tk truetype tta udev unicode upnp usb v4l v4l2 vaapi vcd vhosts vim vim-syntax vorbis wav wavepack wicd wifi wma wmf wmp wxwidgets wxwindows x264 x86emu xattr xcb xcomposite xetex xforms xfs xft xine xinerama xml xmmp xorg xosd xrandr xsl xv xvid yahoo zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy_http proxy" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="lvm crypt syslog ssh-client caps" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en ja zh zh_CN zh_TW en_US en_GB" NETBEANS_MODULES="cnd php mobility websvccommon apisupport java ide harness nb dlight enterprise profiler" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel i965 vesa vga fbdev v4l modesetting" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================
USE="aac libnotify (multilib) musepack xvid"

media-video/miro-4.0.6 was built with the following:
Comment 1 Jeroen Roovers gentoo-dev 2012-07-03 13:58:37 UTC
Looks like it doesn't respect CC either.
Comment 2 Mathieu Z 2012-07-11 03:26:33 UTC
(In reply to comment #1)
> Looks like it doesn't respect CC either.

Actually it has to do with ffmpeg-0.11.1 being unmasked in my system. Rolling back to 0.10.3 fixes this. Mark as invalid???
Comment 3 Pacho Ramos gentoo-dev 2016-05-06 10:15:03 UTC
please also check with 6.0 release