Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 424041 - app-text/sgml-common-0.6.3-r5 fails with automake-1.12 - mkdir -p
Summary: app-text/sgml-common-0.6.3-r5 fails with automake-1.12 - mkdir -p
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo SGML project
Depends on:
Reported: 2012-06-29 10:43 UTC by crabbed halo ablution
Modified: 2013-05-12 22:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build log (build.log,7.70 KB, text/plain)
2012-07-31 13:39 UTC, Robert Förster
work/sgml-common-0.6.3/bin/Makefile (Makefile,12.12 KB, text/plain)
2012-09-06 05:23 UTC, quietlik
emerge --info (emerge--info,4.34 KB, text/plain)
2012-09-06 05:25 UTC, quietlik

Note You need to log in before you can comment on or make changes to this bug.
Description crabbed halo ablution 2012-06-29 10:43:14 UTC
>>> Install sgml-common-0.6.3-r5 into /var/tmp/portage/app-text/sgml-common-0.6.3-r5/image/ category app-text
make -j8 DESTDIR=/var/tmp/portage/app-text/sgml-common-0.6.3-r5/image/ install 
Making install in bin
make[1]: Entering directory `/var/tmp/portage/app-text/sgml-common-0.6.3-r5/work/sgml-common-0.6.3/bin'
make[2]: Entering directory `/var/tmp/portage/app-text/sgml-common-0.6.3-r5/work/sgml-common-0.6.3/bin'
make[2]: Nothing to be done for `install-data-am'.
 @MKDIR_P@ '/var/tmp/portage/app-text/sgml-common-0.6.3-r5/image//usr/bin'
/bin/sh: line 3: @MKDIR_P@: command not found
make[2]: *** [install-binSCRIPTS] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-text/sgml-common-0.6.3-r5/work/sgml-common-0.6.3/bin'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/var/tmp/portage/app-text/sgml-common-0.6.3-r5/work/sgml-common-0.6.3/bin'
make: *** [install-recursive] Error 1
emake failed
Comment 1 crabbed halo ablution 2012-06-29 10:45:16 UTC
MAKEOPTS=-j1 emerge -1 sgml-common
Finishes without error
Comment 2 Mike Gilbert gentoo-dev 2012-07-03 13:46:58 UTC
That error doesn't seem to have anything to do with a race condition. Please provide a full log.
Comment 3 Charles Nérot 2012-07-04 10:28:17 UTC
Same error for me during an "emerge -e @system" with gcc-4.7.1.
retrying emerging it alone works for me :
emerge -1 sgml-common 
=> OK
Comment 4 Robert Förster 2012-07-31 13:39:55 UTC
Created attachment 319862 [details]
build log
Comment 5 Mike Gilbert gentoo-dev 2012-08-30 20:43:08 UTC
Can someone attach a copy of work/sgml-common-0.6.3/bin/Makefile from a failed install?

Also please provide emerge --info.
Comment 6 quietlik 2012-09-06 05:23:33 UTC
Created attachment 323040 [details]
Comment 7 quietlik 2012-09-06 05:25:25 UTC
Created attachment 323042 [details]
emerge --info
Comment 8 Mike Gilbert gentoo-dev 2012-09-10 02:12:30 UTC
This is very strange... the following check is missing from the configure output.

checking for a thread-safe mkdir -p... /bin/mkdir -p

This means that configure doesn't substitute @MKDIR_P@ in
Comment 9 Olipro 2012-09-11 12:22:08 UTC
I am experiencing exactly the same error whilst using gcc 4.7.1
Comment 10 Justin Lecher (RETIRED) gentoo-dev 2012-10-10 07:20:34 UTC

has the solution.
Comment 11 Mike Gilbert gentoo-dev 2012-10-13 18:56:21 UTC
(In reply to comment #10)

I still can't reproduce the problem; no sense in hacking up the build system if I can't isolate the issue.
Comment 12 Mike Gilbert gentoo-dev 2013-05-12 22:09:42 UTC
I fixed this by repackaging the tarball with newer autotools.