Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 423593 - net-misc/openssh-6.0_p1-r1: ssh hangs with 100% cpu connecting to HPUX sshd
Summary: net-misc/openssh-6.0_p1-r1: ssh hangs with 100% cpu connecting to HPUX sshd
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-26 08:13 UTC by Jeffrey Ratcliffe
Modified: 2017-11-15 17:45 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
strace output for openssh-5.9_p1-r4 (strace-openssh-5.9_p1-r4.log,53.46 KB, text/plain)
2012-07-02 06:47 UTC, Jeffrey Ratcliffe
Details
strace output for openssh-6.0_p1-r1 (strace-openssh-6.0_p1-r1.log,20.62 KB, text/plain)
2012-07-02 06:48 UTC, Jeffrey Ratcliffe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey Ratcliffe 2012-06-26 08:13:01 UTC
ssh hangs with 100% cpu with no output on -vvv except version info on following packages:

=net-misc/openssh-6.0_p1-r1
=net-misc/openssh-6.0_p1

=net-misc/openssh-5.9_p1 works as expected.
Comment 1 Jeroen Roovers gentoo-dev 2012-06-27 02:10:45 UTC
That doesn't happen here on any of my systems, so please:
1) post your `emerge --info net-misc/openssh' output in a comment.
2) provide more details on what exact command you ran, how the client and host
   were configured (`emerge --info net-misc/openssh' of the remote host if
   possible/applicable), installed public keys or information on alternative
   authentication methods you used, and so on.
Comment 2 Jeffrey Ratcliffe 2012-06-28 14:39:42 UTC
All I did was

$ ssh -vvv <hostname>

where <hostname> was a machine running HPUX. I tried forcing protocol 1 or 2 with -1 or -2 with the same results.

$ emerge --info net-misc/openssh
Portage 2.2.01.20430-prefix (prefix/linux/amd64, gcc-4.6.3, unavailable, 2.6.18-238.9.1.el5 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.18-238.9.1.el5-x86_64-Intel-R-_Xeon-R-_CPU_E5450_@_3.00GHz-with-redhat-5.6-Tikanga
Timestamp of tree: Wed, 20 Jun 2012 21:53:41 +0000
app-shells/bash:          4.2_p29::gentoo_prefix
dev-lang/python:          2.7.3-r2::gentoo_prefix
dev-util/cmake:           2.8.8-r3::gentoo_prefix
dev-util/pkgconfig:       0.26::gentoo_prefix
sys-devel/autoconf:       2.69::gentoo_prefix
sys-devel/automake:       1.11.5::gentoo_prefix
sys-devel/binutils:       2.22-r1::gentoo_prefix
sys-devel/gcc:            4.6.3::gentoo_prefix
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2::gentoo_prefix
sys-devel/make:           3.82::gentoo_prefix
sys-kernel/linux-headers: 3.4::gentoo_prefix
Repositories: gentoo_prefix local-repo
Installed sets:
ACCEPT_KEYWORDS="~amd64-linux"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/portage /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/home/jeff/prefix/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles force-prefix news parallel-fetch preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/home/jeff/prefix/usr/portage/packages"
PORTAGE_CONFIGROOT="/home/jeff/prefix/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/scratch"
PORTDIR="/home/jeff/prefix/usr/portage"
PORTDIR_OVERLAY="/home/jeff/prefix/usr/local/portage"
SYNC="rsync://rsync.prefix.freens.org/gentoo-portage-prefix"
USE="X amd64 bash-completion berkdb bzip2 cairo cli cracklib crypt cxx djvu dri emacs fontconfig fortran gdbm gif gtk iconv ipv6 jpeg mmx modules mudflap ncurses nls nptl openmp pcre png pppd prefix readline session sse sse2 ssl svg tcpd tiff truetype unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

net-misc/openssh-5.9_p1-r4 was built with the following:
USE="X hpn (prefix) tcpd -X509 -kerberos -ldap -libedit (-pam) (-selinux) -skey -static"
LDFLAGS="-Wl,-O1 -Wl,--allow-multiple-definition -Wl,--allow-multiple-definition -Wl,--allow-multiple-definition -Wl,--allow-multiple-definition -Wl,--allow-multiple-definition -Wl,--allow-multiple-definition -Wl,--allow-multiple-definition"
Comment 3 SpanKY gentoo-dev 2012-06-29 04:45:29 UTC
try building openssh w/USE=-hpn
Comment 4 Jeffrey Ratcliffe 2012-06-29 05:57:19 UTC
(In reply to comment #3)
> try building openssh w/USE=-hpn

Unfortunately, that didn't help - ssh still hangs with 100% cpu
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-06-29 15:39:24 UTC
"host is running HPUX sshd", is very vague - can you at least say what version of HPUX (and arch)?

Most likely, the bug will have to be taken upstream for a fix.
Comment 6 Fabian Groffen gentoo-dev 2012-06-29 15:44:14 UTC
would probably help to have an strace, or even a gdb backtrace
Comment 7 Jeffrey Ratcliffe 2012-07-02 06:47:46 UTC
Created attachment 316947 [details]
strace output for openssh-5.9_p1-r4
Comment 8 Jeffrey Ratcliffe 2012-07-02 06:48:26 UTC
Created attachment 316949 [details]
strace output for openssh-6.0_p1-r1
Comment 9 Jeffrey Ratcliffe 2012-07-02 06:50:37 UTC
I've just attached strace output for strace -ttT ssh for openssh-6.0_p1-r1 and openssh-5.9_p1-r4 for comparison.

It seems that 6.0_p1-r1 hangs trying to read /etc/ssl/openssl.cnf
Comment 10 Jeffrey Ratcliffe 2012-11-12 12:36:02 UTC
Also affects openssh-6.1_p1
Comment 11 Fabian Groffen gentoo-dev 2013-04-24 18:46:07 UTC
I'm just bitten by a similar problem when connecting to Solaris.  It seems on Linux, the baud speed (stty) is 0, which makes Solaris send zero bytes at a time.  Setting baud speed to something (stty speed 38400) makes logging in work like a charm.  Perhaps this is a similar problem for HPUX?
Comment 12 Jeffrey Ratcliffe 2013-05-01 07:06:44 UTC
stty speed 38400

simply prints 38400, as, checking man, stty speed returns the current speed.

I tried

stty ispeed 38400

and

stty ospeed 38400

which apparently set the speed, before I tried logging in, but this had no effect.

Am I doing something wrong, or is this a different problem?
Comment 13 Fabian Groffen gentoo-dev 2013-05-01 07:16:33 UTC
different problem then, thanks for trying
Comment 14 Fabian Groffen gentoo-dev 2017-11-15 17:45:53 UTC
I think the lack of a system to try this against makes it impossible to solve this.