Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 423167 - dev-php/pecl-http-1.7.4 fails at runtime with "undefined symbol: gcry_control" when using net-libs/gnutls[nettle]
Summary: dev-php/pecl-http-1.7.4 fails at runtime with "undefined symbol: gcry_control...
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-23 17:58 UTC by Anthony Parsons
Modified: 2013-04-08 12:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
pecl-http info (info.log,10.25 KB, text/plain)
2012-06-26 17:25 UTC, Anthony Parsons
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Parsons 2012-06-23 17:58:34 UTC
Error message is triggered as soon as I try to run "rc-service php-fpm start".

This sounds like the same problem a lot of other packages are having: I've checked and it works fine with USE="-nettle".
Comment 1 Ole Markus With (RETIRED) gentoo-dev 2012-06-24 15:53:48 UTC
Hi,

Please post a few more details, such as error message you got and the usual stuff (emerge --info etc)

Cheers,
Ole Markus
Comment 2 Anthony Parsons 2012-06-26 17:25:52 UTC
Created attachment 316345 [details]
pecl-http info
Comment 3 Anthony Parsons 2012-06-26 17:26:04 UTC
Runtime error:


 # rc-service php-fpm restart
 * Stopping PHP FastCGI Process Manager ...                                                                   [ ok ]
 * Starting PHP FastCGI Process Manager ...
/usr/lib/php5.4/bin/php-fpm: symbol lookup error: /usr/lib64/php5.4/lib/extensions/no-debug-zts-20100525/http.so: undefined symbol: gcry_control
 * start-stop-daemon: failed to start `/usr/lib/php5.4/bin/php-fpm'                                           [ !! ]
 * ERROR: php-fpm failed to start
Comment 4 Matthew Schultz 2012-07-01 17:53:55 UTC
Did you try reemerging pecl-http?
Comment 5 Anthony Parsons 2012-07-03 19:05:33 UTC
(In reply to comment #4)
> Did you try reemerging pecl-http?

Multiple times, with the zero change in outcome that I expected.
Comment 6 Matthew Schultz 2012-07-03 19:53:52 UTC
I had the same error before reemerging.  Apache wouldn't restart and crashed until I reemerged pecl-http.  When it emerged, it displayed this gcry_control in the configure portion.  Unfortunately it only did it once and I can't reproduce the error when reemerging.  I also have net-libs/gnutls[nettle] set and so the only difference I can see is that I'm using the php module instead of fastcgi.  Maybe it's something specific with fastcgi?
Comment 7 Ole Markus With (RETIRED) gentoo-dev 2012-08-01 12:00:35 UTC
I cannot reproduce this either. But it may be curl that needs recompiling.
Comment 8 Ole Markus With (RETIRED) gentoo-dev 2013-03-15 08:45:04 UTC
Is this still a problem?
Comment 9 Anthony Parsons 2013-03-18 23:56:44 UTC
Not a problem for me any more, I gave up on PHP a few months ago...