The configure script of this ebuild only works with python >= 2.4 and < 3.0.
Steps to Reproduce:
# emerge =app-emulation/qemu-user-1.0.0
>>> Configuring source in /var/tmp/portage/app-emulation/qemu-user-1.1.0/work/qemu-1.1.0 ...
Cannot use 'python', Python 2.4 or later is required.
Note that Python 3 or later is not yet supported.
Use --python=/path/to/python to specify a supported Python.
Created attachment 316069 [details, diff]
Um, dev-lang/python-2.5 is the lowest version still in the tree.
(In reply to comment #2)
> Um, dev-lang/python-2.5 is the lowest version still in the tree.
My thought was that if someone had python-2.4 still installed for some reason, this ebuild shouldn't force the user to update to 2.5 or higher, but then of course I'm not too familiar with the official gentoo policy on such matters ;)
Created attachment 316475 [details, diff]
patch for 1.1.0-r1, requires python>=2.5
Still someone with python-2.4? I propose to close this bug
qemu-user has been removed from the tree as its functionality has been superseded by the combined app-emulation/qemu package. if you find the qemu package does not support something that the qemu-user package did, please file a new bug explicitly detailing things so we can get it added.