Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 423151 - app-emulation/qemu-user-1.1.0 requires python2 >= 2.4
Summary: app-emulation/qemu-user-1.1.0 requires python2 >= 2.4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Luca Barbato
Depends on: 508098
  Show dependency tree
Reported: 2012-06-23 14:15 UTC by Joseph C. Lehner
Modified: 2014-05-30 04:40 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

ebuild patch (qemu-user-1.1.0.patch,723 bytes, patch)
2012-06-23 14:16 UTC, Joseph C. Lehner
Details | Diff
patch for 1.1.0-r1, requires python>=2.5 (fix-python-rdepend.patch,710 bytes, patch)
2012-06-27 21:02 UTC, Joseph C. Lehner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph C. Lehner 2012-06-23 14:15:12 UTC
The configure script of this ebuild only works with python >= 2.4 and < 3.0.

Reproducible: Always

Steps to Reproduce:
# emerge =app-emulation/qemu-user-1.0.0
>>> Configuring source in /var/tmp/portage/app-emulation/qemu-user-1.1.0/work/qemu-1.1.0 ...
Cannot use 'python', Python 2.4 or later is required.
Note that Python 3 or later is not yet supported.
Use --python=/path/to/python to specify a supported Python.
Comment 1 Joseph C. Lehner 2012-06-23 14:16:40 UTC
Created attachment 316069 [details, diff]
ebuild patch
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2012-06-26 14:57:45 UTC
Um, dev-lang/python-2.5 is the lowest version still in the tree.
Comment 3 Joseph C. Lehner 2012-06-26 18:15:04 UTC
(In reply to comment #2)
> Um, dev-lang/python-2.5 is the lowest version still in the tree.

My thought was that if someone had python-2.4 still installed for some reason, this ebuild shouldn't force the user to update to 2.5 or higher, but then of course I'm not too familiar with the official gentoo policy on such matters ;)
Comment 4 Joseph C. Lehner 2012-06-27 21:02:40 UTC
Created attachment 316475 [details, diff]
patch for 1.1.0-r1, requires python>=2.5
Comment 5 jannis 2013-10-13 07:35:43 UTC
Still someone with python-2.4? I propose to close this bug
Comment 6 SpanKY gentoo-dev 2014-05-30 04:40:35 UTC
qemu-user has been removed from the tree as its functionality has been superseded by the combined app-emulation/qemu package.  if you find the qemu package does not support something that the qemu-user package did, please file a new bug explicitly detailing things so we can get it added.