Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 422843 - =media-libs/tiff-4.0.3-r1 fails test "raw_decode" (was: and "tiff2rgba-quad-tile.jpg.sh")
Summary: =media-libs/tiff-4.0.3-r1 fails test "raw_decode" (was: and "tiff2rgba-quad-t...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Low minor (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard: The raw_decode issue from this bug ha...
Keywords: TESTFAILURE
: 423535 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-21 14:07 UTC by Toralf Förster
Modified: 2016-01-31 15:27 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (media-libs:tiff-4.0.2:20120621-132833.log.gz,25.07 KB, application/x-gzip)
2012-06-21 14:07 UTC, Toralf Förster
Details
tiff-4.0.2-jpeg7.patch (tiff-4.0.2-jpeg7.patch,2.93 KB, patch)
2012-09-18 20:08 UTC, David Leverton
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2012-06-21 14:07:19 UTC
n22 / # emerge --info tiff
Portage 2.1.10.65 (default/linux/x86/10.0, gcc-4.6.3, glibc-2.15-r2, 3.4.4-rc1 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.4.4-rc1-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Thu, 21 Jun 2012 11:15:01 +0000
app-shells/bash:          4.2_p29
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.69
sys-devel/automake:       1.12.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo toralf
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --keep-going=y --nospinner --tree --deep --quiet-build"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl apache2 berkdb bzip2 cli cracklib crypt cups cxx dri fam fastbuild gdbm gmp gpm iconv ipv6 logrotate mmx modules mudflap mysql mysqli ncurses nls nptl openmp pam pcre pppd readline session sse sse2 sse3 ssl ssse3 tcpd threads unicode userlocales webmail x86 xml xorg zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi compat dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so socache_shmcb speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

media-libs/tiff-4.0.2 was built with the following:
USE="cxx test zlib -jbig -jpeg -lzma -static-libs"


Reproducible: Always
Comment 1 Toralf Förster gentoo-dev 2012-06-21 14:07:59 UTC
Created attachment 315919 [details]
build log
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2012-06-21 15:32:48 UTC
I can confirm the raw_decode test failure on HPPA, but not the other one. :)
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2012-06-27 11:29:26 UTC
*** Bug 423535 has been marked as a duplicate of this bug. ***
Comment 4 Dustin Polke 2012-08-20 13:07:22 UTC
(In reply to comment #2)
> I can confirm the raw_decode test failure on HPPA, but not the other one. :)
+1 on sparc
Comment 5 Samuli Suominen (RETIRED) gentoo-dev 2012-09-16 17:35:02 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > I can confirm the raw_decode test failure on HPPA, but not the other one. :)
> +1 on sparc

Fixed by:

http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/tiff/files/tiff-4.0.2-bigendian.patch?rev=1.1&view=markup

http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/tiff/tiff-4.0.2-r1.ebuild?r1=1.1&r2=1.2

Leaving open for the another failure and setting back to UNCONFIRMED for now.
Comment 6 Toralf Förster gentoo-dev 2012-09-16 20:14:50 UTC
Hhm, at my stable x86 Gentoo w/ gcc-4.6.3 the package version 4.0.2-r1 now emerges fine with no test failures, whereas for my user mode linux image (stable x86 +  gcc-4.6.2) I'm getting two failures :  raw_decode and tiff2rgba-quad-tile.jpg.sh) - and for my other user mode linux image (unstable ~x86, gcc-4.7.1) I get same 2 failures.

FWIW into the UML image I do simply do chroot into each respectively to compile packages (much faster than starting the UML guest and emerging package/s it then).
Comment 7 Hendrik v. Raven 2012-09-18 19:21:51 UTC
I can confirm both test failures if the jpeg USE-flag is disabled.
If it is enabled it builds fine on all my systems (some hardened some normal unstable amd64) with gcc-4.7.1 as well as with clang-3.1-r5.
Comment 8 David Leverton 2012-09-18 20:08:22 UTC
Created attachment 324242 [details, diff]
tiff-4.0.2-jpeg7.patch

(In reply to comment #6)
> Hhm, at my stable x86 Gentoo w/ gcc-4.6.3 the package version 4.0.2-r1 now
> emerges fine with no test failures, whereas for my user mode linux image
> (stable x86 +  gcc-4.6.2) I'm getting two failures :  raw_decode and
> tiff2rgba-quad-tile.jpg.sh) - and for my other user mode linux image
> (unstable ~x86, gcc-4.7.1) I get same 2 failures.

If the systems that are failing use media-libs/jpeg, see if the attached patch (from upstream CVS and tweaked slightly to apply to the release) fixes raw_decode.  Can't help with the other one I'm afraid....

(Corresponding upstream ML thread: http://www.asmail.be/msg0054801794.html)
Comment 9 Toralf Förster gentoo-dev 2012-09-19 17:09:55 UTC
(In reply to comment #8)
> Created attachment 324242 [details, diff] [details, diff]
> tiff-4.0.2-jpeg7.patch


Nope, I get :

=================================================
   LibTIFF Software 4.0.2: test/test-suite.log
=================================================

2 of 81 tests failed.

.. contents:: :depth: 2


FAIL: raw_decode (exit: 1)
==========================

TIFFReadDirectory: Warning, Unknown field with tag 347 (0x15b) encountered.
images/quad-tile.jpg.tiff: JPEG compression support is not configured.
images/quad-tile.jpg.tiff: JPEG compression support is not configured.
Did not get expected result code from TIFFReadEncodedTile()(-1 instead of 24576)

FAIL: tiff2rgba-quad-tile.jpg.sh (exit: 1)
==========================================

 /var/tmp/portage/media-libs/tiff-4.0.2-r1/work/tiff-4.0.2/tools/tiff2rgba ./images/quad-tile.jpg.tiff o-tiff2rgba-quad-tile.jpg.tiff
TIFFReadDirectory: Warning, Unknown field with tag 347 (0x15b) encountered.
./images/quad-tile.jpg.tiff: JPEG compression support is not configured.
./images/quad-tile.jpg.tiff: Sorry, requested compression method is not configured.
Returned failed status 1!
Output (if any) is in "o-tiff2rgba-quad-tile.jpg.tiff".





BTW what would be fine if the ebuild would honour /etc/portage/patches/ :-)
Comment 10 Markus Oehme 2012-11-10 09:43:35 UTC
I too see the raw_decode test failure on hardened ~amd64 with gcc-4.7.2 and tiff-4.0.3-r1. No other tests fail. I have the jgep useflag enabled, but do not have media-libs/jpeg installed.
Comment 11 Godfath3r 2012-12-12 22:50:26 UTC
I'm getting the same error (x86 here) and it's fixed when enable jpeg flag for media-libs/tiff
Comment 12 elvis4526 2013-01-08 04:15:42 UTC
Same bug here on stable amd64 without the jpeg flag enabled.
Comment 13 Toralf Förster gentoo-dev 2016-01-31 15:27:59 UTC
obsolete