Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 422707 - media-plugins/gst-plugins-ffmpeg-0.10.13-r2 blocking, conflicts ffmpeg and libav
Summary: media-plugins/gst-plugins-ffmpeg-0.10.13-r2 blocking, conflicts ffmpeg and libav
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GStreamer package maintainers
URL:
Whiteboard:
Keywords:
Depends on: 423379
Blocks:
  Show dependency tree
 
Reported: 2012-06-20 19:45 UTC by tman
Modified: 2013-03-14 22:53 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2012-06-20 19:45:59 UTC
it would be nice if it possible to use libav or ffmpeg



Reproducible: Always

Actual Results:  

cks B     ] media-video/ffmpeg ("media-video/ffmpeg" is blocking media-video/libav-0.8.3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-video/ffmpeg-0.10.3::gentoo, ebuild scheduled for merge) pulled in by
    media-video/ffmpeg required by (media-plugins/gst-plugins-ffmpeg-0.10.13-r2::gentoo, ebuild scheduled
for merge)

  (media-video/libav-0.8.3::gentoo, installed) pulled in by
    >=media-video/libav-0.8.2-r2[X,encode,jpeg2k,mp3,sdl,theora,threads,truetype,vaapi,vdpau,x264] required by (virtual/ffmpeg-0.10.3::gentoo, installed)
    media-video/libav[x264,xvid,mp3,encode,theora,jpeg2k] required by (media-gfx/blender-9999::lokal, installed)
    media-video/libav[x264,xvid,mp3,encode,theora] required by (media-gfx/blender-9999::lokal, installed)

system updated
Comment 1 Jeroen Roovers gentoo-dev 2012-06-21 14:37:21 UTC
    media-video/libav[x264,xvid,mp3,encode,theora] required by (media-gfx/blender-9999::lokal, installed)

We don't support ebuilds in local overlays.
Comment 2 tman 2012-06-21 18:24:44 UTC
hi.

i tried to take your advice and unmerge thi local ebuild to test. but it seems to be this package has anways a conflict with libav. it would be nice if i have here the choice to use libav instead of ffmpeg.


this ist the block.


 emerge -uDN world --keep-going
--- Invalid atom in /usr/portage/profiles/package.mask: =dev-utils/febootstrap-3.*

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] app-emulation/virtualbox-additions-4.1.18 [4.1.16]
[ebuild     U  ] app-emulation/virtualbox-modules-4.1.18 [4.1.16]
[ebuild     U  ] media-libs/tiff-4.0.2 [4.0.1-r1]
[ebuild     U  ] dev-util/kbuild-0.1.9998_pre20110817-r1 [0.1.9998_pre20110817]
[ebuild     U  ] dev-python/pyxdg-0.20_rc1 [0.19] USE="-examples%" 
[ebuild     U  ] dev-db/metakit-2.4.9.7-r1 [2.4.9.7]
[ebuild     U  ] dev-java/ant-core-1.8.4-r1 [1.8.4]
[ebuild  N     ] media-video/ffmpeg-0.10.3  USE="X aac alsa bzip2 cdio dirac encode faac gnutls hardcoded-tables ieee1394 jack jpeg2k mmx mmxext mp3 network openal oss pic pulseaudio schroedinger sdl speex ssse3 theora threads truetype vorbis x264 xvid zlib -3dnow -3dnowext -aacplus (-altivec) -amr -avx -bindist (-celt) -cpudetection -debug -doc -frei0r -gsm -libass -libv4l -modplug (-neon) -openssl -rtmp -static-libs -test -v4l -vaapi -vdpau (-vis) -vpx" FFTOOLS="aviocat cws2fws ffeval graph2dot ismindex pktdumper qt-faststart trasher" 
[ebuild     U  ] net-analyzer/nmap-6.01 [6.00] USE="-ncat% -ndiff% -nmap-update% -nping%" 
[ebuild     U  ] media-plugins/gst-plugins-ffmpeg-0.10.13-r2 [0.10.13-r1]
[ebuild     U  ] app-portage/gentoolkit-0.3.0.6-r3 [0.3.0.6-r2]
[ebuild     U #] www-client/opera-next-12.01.1473 [12.00.1467]
[ebuild     U  ] app-emulation/virtualbox-4.1.18 [4.1.16]
[ebuild     U  ] app-emulation/virtualbox-extpack-oracle-4.1.18 [4.1.16]
[blocks B      ] media-video/ffmpeg ("media-video/ffmpeg" is blocking media-video/libav-0.8.3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-video/ffmpeg-0.10.3::gentoo, ebuild scheduled for merge) pulled in by
    media-video/ffmpeg required by (media-plugins/gst-plugins-ffmpeg-0.10.13-r2::gentoo, ebuild scheduled for merge)

  (media-video/libav-0.8.3::gentoo, installed) pulled in by
    >=media-video/libav-0.8.2-r2[X,encode,jpeg2k,mp3,sdl,theora,threads,truetype,vaapi,vdpau,x264] required by (virtual/ffmpeg-0.10.3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2012-06-22 09:04:42 UTC
You seem to use testing libav but stable system.

This means your libpostproc is not around.

That results in confusion in the postproc condition:

|| ( media-video/ffmpeg media-libs/libpostproc <media-video/libav-0.8.2-r1 )

So your choice is to use stable libav, or keyword testing libpostproc so it fits the condition.
Comment 4 Alexander Tsoy 2012-06-24 17:33:13 UTC
See also bug 385547
Comment 5 Alexander Tsoy 2012-06-24 19:16:36 UTC
And bug 423379(In reply to comment #4)
> See also bug 385547

and bug 423379
Comment 6 Anton Bolshakov 2012-07-01 14:57:38 UTC
(In reply to comment #3)
> 
> || ( media-video/ffmpeg media-libs/libpostproc <media-video/libav-0.8.2-r1 )
> 

I think the main problem is that media-video/libav-0.8.3 went stable so the aforesaid conditions are broken. That's the reason why portage is trying to pull ffmpeg even when libav is already installed.

As a workaround, I had to mask ffmpeg manually and install libpostproc as it is also required by vlc +postproc.

What was the reason of having <0.8.2-r1 limit? Please investigate.


emerge --info
Portage 2.1.10.65 (hardened/linux/amd64, gcc-4.5.3, glibc-2.14.1-r3, 2.6.37-hardened-r7 x86_64)
=================================================================
System uname: Linux-2.6.37-hardened-r7-x86_64-Intel-R-_Core-TM-_i5_CPU_M_520_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Sun, 01 Jul 2012 07:00:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4::pentoo
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo local-overlay pentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA PUEL AdobeFlash-10.3 google-talkplugin dlj-1.1 google-chrome Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-2.2/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.nus.edu.sg/gentoo "
INSTALL_MASK="*.la"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en ru"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /pentoosvn"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 avahi bash-completion berkdb branding bzip2 cli consolekit cracklib crypt cups cxx dbus dri exif flac fuse gdbm gnome gnome-keyring gphoto2 gstreamer gtk hardened iconv ipv6 java jpeg justify libnotify mmx modules mp3 mudflap multilib ncurses networkmanager nls nptl opengl openmp oss pam pax_kernel pcre policykit pppd qt3support qt4 readline samba sdl session spell sse sse2 ssl syslog tcpd udev unicode urandom vaapi x264 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2 canon samsung" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en ru" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev vesa intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 7 Alexander Tsoy 2012-07-01 21:39:33 UTC
(In reply to comment #6)
> (In reply to comment #3)
> > 
> > || ( media-video/ffmpeg media-libs/libpostproc <media-video/libav-0.8.2-r1 )
> > 
> 
> I think the main problem is that media-video/libav-0.8.3 went stable so the
> aforesaid conditions are broken. That's the reason why portage is trying to
> pull ffmpeg even when libav is already installed.

In my opinion this

"
        >=virtual/ffmpeg-0.10
        || ( media-video/ffmpeg media-libs/libpostproc <media-video/libav-0.8.2-r1 )
"

means

( media-video/ffmpeg || <media-video/libav-0.8.2-r1 || ( >=media-video/libav-0.8.2-r1 && media-libs/libpostproc ) )

isn't it?

> 
> What was the reason of having <0.8.2-r1 limit? Please investigate.

See ebuilds. <0.8.2-r1 configure with --enable-postproc, but newer ebuilds configure without this flag and depens on external lib media-libs/libpostproc.
Comment 8 Alexander Tsoy 2012-07-02 08:00:15 UTC
(In reply to comment #7)
> newer ebuilds configure without this flag and depens on
> external lib media-libs/libpostproc.

libav itself does not depend on libpostproc but the software that need it, should do.

fixed
Comment 9 Anton Bolshakov 2012-07-06 05:49:52 UTC
(In reply to comment #7)
> In my opinion this
> means
..
> 
> isn't it?

No. It means any of specified packages and its version.
That's the reason why "<media-video/libav-0.8.2-r1" does not match the currently stable 0.8.3

Here it is:
http://devmanual.gentoo.org/general-concepts/dependencies/index.html
Any of Many Dependencies
To depend on either foo or bar:
DEPEND="|| ( app-misc/foo app-misc/bar )"
Comment 10 Anton Bolshakov 2012-07-09 14:28:58 UTC
ok, and there is the same problem with media-libs/xine-lib
Comment 11 Roger 2012-09-03 16:58:56 UTC
My system is in conflict as well since:

media-video/libav "!media-video/ffmpeg"

And virtual/ffmpeg seems to be trying to pull in both media-video/ffmpeg and media-video/libav.
Comment 12 Roger 2012-09-03 18:03:01 UTC
Seems I also just solved this by adding "media-video/ffmpeg" to the /etc/portage/package.mask file.  (Seems xine (and maybe xbmc) are pulling in the media-video/ffmpeg package here.)  And this bug is seen again with =media-video/mplayer-1.1 as mplayer-1.1 seems to explicitly depend on media-video/ffmpeg even though virtual/ffmpeg and libav are already installed.

Somebody enjoys endless loops here.
Comment 13 Gilles Dartiguelongue gentoo-dev 2013-03-14 22:53:35 UTC
The ebuild has this blocker dependency on libav because it does not build with 
higher versions. While this caused unfortunate dependency conflicts, there is 
nothing better to do here.

Anyway, the problem should be gone now that we have a snapshot that builds with 
more recent libav/ffmpeg.