Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 421849 - dev-vcs/gitolite and dev-vcs/gitolite-gentoo - gl-setup fails:Unsuccessful stat on filename containing newline at /usr/bin/sshkeys-lint line 142, <> line 2.
Summary: dev-vcs/gitolite and dev-vcs/gitolite-gentoo - gl-setup fails:Unsuccessful st...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Lance Albertson (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-18 20:57 UTC by schmitt953
Modified: 2013-03-03 17:10 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description schmitt953 2012-06-18 20:57:59 UTC
This is a duplicate of a debian bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=653994

hit enter...
creating gitolite-admin...
Initialized empty Git repository in /var/lib/gitolite/repositories/gitolite-admin.git/
creating testing...
Initialized empty Git repository in /var/lib/gitolite/repositories/testing.git/
[master (root-commit) 78dccaf] start
 2 files changed, 8 insertions(+), 0 deletions(-)
 create mode 100644 conf/gitolite.conf
 create mode 100644 keydir/id_ecdsa.pub
Unsuccessful stat on filename containing newline at /usr/bin/sshkeys-lint line 142, <> line 2.
file not found: command="/usr/bin/gl-auth-command id_ecdsa",no-port-forwarding,no-X11-forwarding,no-agent-forwarding,no-pty ecdsa-sha2-nistp256

gl-setup will not configure gitolite with either gitolite or gitolite-gentoo
Comment 1 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2012-06-23 22:23:05 UTC
What gitolite/-gentoo version do you use?
Comment 2 schmitt953 2012-06-28 20:12:53 UTC
(In reply to comment #1)
> What gitolite/-gentoo version do you use?

The one that was stable last week, I will check once I get back to that server. (that server is currently offline since we are out of ports on the switch and I am currently setting up a new one xD)
Comment 3 Pacho Ramos gentoo-dev 2013-03-03 17:10:44 UTC
Please retry with gitolite-3.3