Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 421041 - media-sound/pulseaudio-2.0-r1 fails to emerge with error saying XML::Parser perl module is required for intltool
Summary: media-sound/pulseaudio-2.0-r1 fails to emerge with error saying XML::Parser ...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-13 23:41 UTC by rainer
Modified: 2013-09-06 13:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rainer 2012-06-13 23:41:07 UTC
emerge pulseaudio yields the following error:

checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-sound/pulseaudio-2.0-r1/work/pulseaudio-2.0/config.log
 * ERROR: media-sound/pulseaudio-2.0-r1 failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *          ebuild.sh, line   85:  Called src_configure
 *        environment, line 2532:  Called econf '--enable-largefile' '--enable-glib2' '--disable-solaris' '--enable-asyncns' '--disable-oss-output' '--enable-alsa' '--enable-lirc' '--enable-tcpwrap' '--disable-jack' '--enable-lirc' '--enable-avahi' '--disable-hal' '--enable-dbus' '--enable-gconf' '--enable-gtk2' '--disable-samplerate' '--enable-bluez' '--enable-x11' '--disable-default-build-tests' '--enable-udev' '--enable-ipv6' '--enable-openssl' '--enable-webrtc-aec' '--disable-xen' '--with-caps' '--without-fftw' '--disable-adrian-aec' '--disable-esound' '--localstatedir=/var' '--with-udev-rules-dir=/lib/udev/rules.d' '--with-database=gdbm'
 *   phase-helpers.sh, line  467:  Called die
 * The specific snippet of code:
 *   			die "econf failed"


Reproducible: Always




#  emerge --info '=media-sound/pulseaudio-2.0-r1' 
Portage 2.1.10.65 (default/linux/amd64/10.0/desktop, gcc-4.6.3, glibc-2.15-r2, 3.3.5-gentoocfg-2012-03-25 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.3.5-gentoocfg-2012-03-25-x86_64-Intel-R-_Core-TM-_i7_CPU_860_@_2.80GHz-with-gentoo-2.1
Timestamp of tree: Wed, 13 Jun 2012 22:45:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p29
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4 -mcx16 -msahf -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -msse4 -mcx16 -msahf -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo"
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aim alsa amd64 ao audiofile avahi bash-completion bcmath berkdb blas bluetooth branding bzip2 cairo calendar caps cdda cddb cdparanoia cdr cli consolekit cracklib crypt css cups curl curlwrappers cxx dbus dga directfb djvu dri dts dv dvd dvdr emacs emboss encode exif fam fbcon ffmpeg firefox flac fontconfig fortran ftp gcj gd gdbm gif gimp ginac glut gnome gnome-keyring gnuplot gnutls gphoto2 gpm graphviz gsm gstreamer gtk gtkhtml gzip hddtemp iconv icq ieee1394 imagemagick imap imlib iodbc ipv6 jabber java java6 javascript jbig jingle jpeg jpeg2k kde kontact lame lapack lash latex lcms ldap libgda libnotify lirc lm_sensors lzo mad matroska mikmod mime mmx mng modules mono mozilla mp3 mp4 mpeg mpi mplayer msn mudflap mule multilib musepack musicbrainz mysql mysqli nas ncurses neXt nls nntp nocd nptl nsplugin odbc offensive ofx ogg openal openexr opengl openmp osc oscar oss pam pango pcre pdf perl php plasma plotutils png policykit ppds pppd pulseaudio python qt3support qt4 quicktime raw readline rss ruby samba scanner sdl semantic-desktop session smp sockets socks5 sox speex spell sqlite sqlite3 sse sse2 ssl startup-notification svg symlink syslog sysvipc szip tcl tcpd theora threads tiff truetype udev udisks unicode upower usb v4l v4l2 vcd vde video vnc vorbis wmf wxwidgets x264 xattr xcb xcomposite xemacs xft xml xorg xosd xpm xsl xulrunner xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 rainer 2012-06-13 23:52:11 UTC
The error seems to be related to the recent update of the perl packages.
The same type of error occurs when emerging net-im/pidgin-2.10.4

I have dev-perl/XML-Parser-2.410.0 installed.
Comment 2 rainer 2012-06-14 00:09:50 UTC
XML-Parser cannot be found although it is installed:

# /usr/bin/perl -e "require XML::Parser" 
Can't locate XML/Parser.pm in @INC (@INC contains: /etc/perl /usr/local/lib64/perl5/5.16.0/x86_64-linux /usr/local/lib64/perl5/5.16.0 /usr/lib64/perl5/vendor_perl/5.16.0/x86_64-linux /usr/lib64/perl5/vendor_perl/5.16.0 /usr/lib64/perl5/5.16.0/x86_64-linux /usr/lib64/perl5/5.16.0 .) at -e line 1.


The XML-Parser files are installed for the previous perl version:

# equery files XML-Parser
 * Searching for XML-Parser ...
 * Contents of dev-perl/XML-Parser-2.410.0:
/usr
/usr/lib64
/usr/lib64/perl5
/usr/lib64/perl5/vendor_perl
/usr/lib64/perl5/vendor_perl/5.12.4
/usr/lib64/perl5/vendor_perl/5.12.4/x86_64-linux
/usr/lib64/perl5/vendor_perl/5.12.4/x86_64-linux/XML
/usr/lib64/perl5/vendor_perl/5.12.4/x86_64-linux/XML/Parser
/usr/lib64/perl5/vendor_perl/5.12.4/x86_64-linux/XML/Parser.pm

Therefore, the error can be resolved by re-emerging XML-Parser.
# emerge -1 XML-Parser

Then XML-Parser is installed in the correct directory:

# equery files XML-Parser
 * Searching for XML-Parser ...
 * Contents of dev-perl/XML-Parser-2.410.0:
/usr
/usr/lib64
/usr/lib64/perl5
/usr/lib64/perl5/vendor_perl
/usr/lib64/perl5/vendor_perl/5.16.0
/usr/lib64/perl5/vendor_perl/5.16.0/x86_64-linux
/usr/lib64/perl5/vendor_perl/5.16.0/x86_64-linux/XML
/usr/lib64/perl5/vendor_perl/5.16.0/x86_64-linux/XML/Parser
/usr/lib64/perl5/vendor_perl/5.16.0/x86_64-linux/XML/Parser.pm


As a conclusion, the bug is related to the perl update.
Comment 3 rainer 2012-06-14 00:18:12 UTC
It seems that I have missed the setup warning when dev-lang/perl-5.16.0 was installed:

WARN:setup                                                                       UPDATE THE PERL MODULES:        
After updating dev-lang/perl you must reinstall the installed perl modules.                                        
Use: perl-cleaner --all
Comment 4 Jeroen Roovers gentoo-dev 2013-09-06 13:32:37 UTC

*** This bug has been marked as a duplicate of bug 41124 ***