Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 420715 - x11-misc/imake hardcodes /usr/lib/X11 paths (ignoring multilib settings)
Summary: x11-misc/imake hardcodes /usr/lib/X11 paths (ignoring multilib settings)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: x32
  Show dependency tree
 
Reported: 2012-06-11 17:48 UTC by Xavier Miller
Modified: 2019-03-17 05:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Miller gentoo-dev 2012-06-11 17:48:22 UTC
Ebuilds using imake don't work anymore with ABI=x32:

Imakefile.c:34:0: fatal error: Imake.tmpl: No such file or directory

But file is present:
# find / -type f -name Imake.tmpl
/usr/libx32/X11/config/Imake.tmpl


Reproducible: Always
Comment 1 Xavier Miller gentoo-dev 2012-06-11 17:50:39 UTC
Example of ebuild: 
=games-board/spider-1.2_p4
Comment 2 SpanKY gentoo-dev 2012-08-03 19:20:58 UTC
it isn't just ABI=x32.  imake stuff appears to have /usr/lib/ hardcoded, so if you build on any system where /usr/lib doesn't point to your native ABI, it'll fail.  i hit this while building tightvnc.

symlinking /usr/lib*/X11 /usr/lib/ worked around the issue.
Comment 3 Matt Turner gentoo-dev 2019-03-17 05:47:13 UTC
media-libs/nas is the only package in tree that I see that is actually multilib (many packages inherit multilib for get_libdir()) that depends on imake, and it seems to deal with imake's deficiency sufficiently.

imake is basically unmaintained, and the /usr/lib*/X11 lib paths don't exist anymore. Let's WONTFIX since I expect fewer and fewer projects to use imake over time.