Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 420527 - app-emulation/virt-viewer makes use of gtk3 useflag
Summary: app-emulation/virt-viewer makes use of gtk3 useflag
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Virtualization Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: use_gtk3
  Show dependency tree
 
Reported: 2012-06-10 18:21 UTC by Julian Ospald
Modified: 2012-12-05 05:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Ospald 2012-06-10 18:21:53 UTC
This package makes use of gtk3 useflag which indicates that there are issues of migration to gtk+:3.
Gtk3 and similar useflags should be avoided.

Adding to tracker. Please have a look.
Comment 1 Doug Goldstein gentoo-dev 2012-06-11 02:32:00 UTC
There are no issues with this package. It requires all depends be built with gtk3 or gtk2 and not mixing and matching as I would expect many apps do. 

The tracker which you refer to doesn't have solution so not really sure what you're expecting here.
Comment 2 Samuli Suominen gentoo-dev 2012-09-24 10:51:06 UTC
To have slotted virt-viewer, for example :2 and :3, GTK+-2 and GTK+-3

SLOTs are preferred over the mistake called USE="gtk2" or "gtk3"
Comment 3 Doug Goldstein gentoo-dev 2012-12-04 23:52:30 UTC
(In reply to comment #2)
> To have slotted virt-viewer, for example :2 and :3, GTK+-2 and GTK+-3
> 
> SLOTs are preferred over the mistake called USE="gtk2" or "gtk3"

And have the mess that is webkit-gtk? -r2xx is gtk2 based and -r3xx is gtk3 based. No thanks.
Comment 4 Julian Ospald 2012-12-05 00:19:06 UTC
why not force gtk+3 here and drop the useflag entirely?
Comment 5 Doug Goldstein gentoo-dev 2012-12-05 05:35:13 UTC
(In reply to comment #4)
> why not force gtk+3 here and drop the useflag entirely?

What's the advantage for users to pull in nearly 20 packages and rebuilds just so you don't have to see the ugly that is the gtk3 use flag?

USE=gtk3 emerge -pv virt-viewer is pretty hefty on my system.