Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 420291 - net-irc/xchat-2.8.8-r2 fails to build
Summary: net-irc/xchat-2.8.8-r2 fails to build
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-08 18:00 UTC by Palmer Dabbelt
Modified: 2013-07-11 21:05 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch that fixes the build (xchat-2.8.8-libgmodule.patch,752 bytes, text/plain)
2012-06-08 18:00 UTC, Palmer Dabbelt
Details
Adds the described patch to xchat-2.8.8.ebuild (xchat-2.8.8-r2.patch,800 bytes, text/plain)
2012-06-08 18:00 UTC, Palmer Dabbelt
Details
Patch that fixes the build (xchat-2.8.8-libgmodule.patch,535 bytes, text/plain)
2012-06-08 19:31 UTC, Palmer Dabbelt
Details
xchat build log (build.log,110.24 KB, text/plain)
2012-06-11 18:43 UTC, Palmer Dabbelt
Details
emerge --info xchat (emerge_info_xchat,5.17 KB, text/plain)
2012-06-11 18:44 UTC, Palmer Dabbelt
Details
emerge --info xchat (file_420291.txt,6.85 KB, text/plain)
2013-04-02 01:03 UTC, Denys Dmytriyenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Palmer Dabbelt 2012-06-08 18:00:15 UTC
Created attachment 314715 [details]
Patch that fixes the build

I believe the problem here is that new versions of glib (I'm using 2.32.3) don't pull in libgmodule-2.0.so when you link libglib-2.0.so.  I've attached a patch that has autoconf test that g_module_symbol gets pulled in by -lglib-2.0 and if not adds -lgmodule-2.0 to the library list.

I don't think this bug is prefix-specific, but I don't have a non-prefix ~amd64 testbed to try this with so I've filed the bug against prefix.  The patched ebuild works on both by amd64 box and my ~amd64-linux box.

I've also filed an upstream bug

https://sourceforge.net/tracker/?func=detail&aid=3533549&group_id=239&atid=100239

I'll attach a diff of the ebuild as well.
Comment 1 Palmer Dabbelt 2012-06-08 18:00:44 UTC
Created attachment 314717 [details]
Adds the described patch to xchat-2.8.8.ebuild
Comment 2 Rafał Mużyło 2012-06-08 19:19:56 UTC
Let's try something a bit less ugly.
Add 4th argument to AM_PATH_GLIB_2_0: 'gmodule'.
Comment 3 Palmer Dabbelt 2012-06-08 19:31:52 UTC
Created attachment 314723 [details]
Patch that fixes the build

(In reply to comment #2)
> Let's try something a bit less ugly.
> Add 4th argument to AM_PATH_GLIB_2_0: 'gmodule'.

This new patch works for me, and it's significantly cleaner.  The ebuild remains the same.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2012-06-11 11:02:25 UTC
Although I belive you've found a valid bug I'm unable to reproduce this on any of my ~amd64 testmachines with glib-2.32.3.
Therefore I'd like to request the full build.log file of the failed build from you as well as the output of "emerge --info xchat".
Comment 5 Palmer Dabbelt 2012-06-11 18:43:56 UTC
Created attachment 315027 [details]
xchat build log

This the output of

MAKEOPTS="-j1" ebuild xchat-2.8.8-r2.ebuild clean install

using the xchat ebuild from portage (ie, not with the patch suggested in the build).
Comment 6 Palmer Dabbelt 2012-06-11 18:44:41 UTC
Created attachment 315029 [details]
emerge --info xchat
Comment 7 ncahill_alt 2013-03-14 19:51:53 UTC
This happened to me today, the patch from comment 3 fixed the problem.  This was using gcc 4.7.2, 32-bit x86.
Comment 8 Denys Dmytriyenko 2013-04-02 01:03:31 UTC
Created attachment 344034 [details]
emerge --info xchat

Switched from gcc-4.6.3 to gcc-4.7.2 on ~amd64 and xchat now breaks.
Comment 9 Denys Dmytriyenko 2013-04-02 01:04:11 UTC
I switched from gcc-4.6.3 to gcc-4.7.2 on ~amd64 and xchat now breaks. Submitted my own emerge --info xchat in the attachments.
Comment 10 Sergey Popov gentoo-dev 2013-07-11 21:05:12 UTC
Packages was removed from tree, see bug #460038