Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 420077 - net-libs/ptlib-2.6.7-r1 with sys-devel/gcc-4.7 - work/ptlib-2.6.7/include/ptlib/array.h:526:9: ошибка: «SetAt» was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
Summary: net-libs/ptlib-2.6.7-r1 with sys-devel/gcc-4.7 - work/ptlib-2.6.7/include/ptl...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: voip herd (OBSOLETE)
URL: http://sourceforge.net/tracker/index....
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.7 422635
  Show dependency tree
 
Reported: 2012-06-07 10:25 UTC by anonymous
Modified: 2012-10-24 14:26 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,16.79 KB, text/plain)
2012-06-07 10:25 UTC, anonymous
Details
Patch by Dominique Leuenberger - http://sourceforge.net/tracker/index.php?func=detail&aid=3505516&group_id=520015&atid=2113043 (libpt2-gcc47.patch,380 bytes, patch)
2012-06-07 13:04 UTC, David Kredba
Details | Diff
ptlib-2.6.7-r2.ebuild (ptlib-2.6.7-r2.ebuild,7.42 KB, text/plain)
2012-08-08 15:48 UTC, Jason A. Donenfeld
Details
ptlib-2.6.7-gcc-4.7.patch (ptlib-2.6.7-gcc-4.7.patch,380 bytes, patch)
2012-08-08 15:49 UTC, Jason A. Donenfeld
Details | Diff
ptlib-2.6.7-gcc-4.7.patch (v2) (ptlib-2.6.7-gcc-4.7.patch,513 bytes, patch)
2012-08-08 17:03 UTC, Jason A. Donenfeld
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description anonymous 2012-06-07 10:25:07 UTC
Created attachment 314525 [details]
build.log

Portage 2.1.10.49 (default/linux/amd64/10.0, gcc-4.7.0, glibc-2.14.1-r3, 3.2.12-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.2.12-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5600+-with-gentoo-2.1
Timestamp of tree: Tue, 05 Jun 2012 10:05:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r1, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.6.2, 4.7.0
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo sunrise nektoo kde qt x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -g -march=k8-sse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -g -march=k8-sse3"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=" --autounmask=n --with-bdeps=y"
FEATURES="assume-digests binpkg-logs candy distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_UA.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en uk"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/nektoo /var/lib/layman/kde /var/lib/layman/qt /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext acl alsa amd64 berkdb bzip2 cli consolekit cracklib crypt cxx dbus dri fortran gdbm gpm iconv ipv6 kde mmx modules mudflap multilib ncurses nls nptl opengl openmp pam pcre pppd qt3support qt4 readline semantic-desktop session sse sse2 sse3 ssl symlink tcpd unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en uk" NGINX_MODULES_HTTP="gzip fastcgi autoindex proxy rewrite access" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

net-libs/ptlib-2.6.7-r1 was built with the following:
USE="alsa asn audio ipv6 (multilib) ssl stun video wav -debug -doc -dtmf -examples -ffmpeg -ftp -http -jabber -ldap -mail -odbc -oss -pch -qos -remote -sasl -sdl -serial -shmvideo -snmp -soap -socks -static-libs -telnet -tts -v4l -vxml -xml -xmlrpc"
Comment 1 David Kredba 2012-06-07 13:04:10 UTC
Created attachment 314565 [details, diff]
Patch by Dominique Leuenberger - http://sourceforge.net/tracker/index.php?func=detail&aid=3505516&group_id=520015&atid=2113043
Comment 2 Jason A. Donenfeld archtester Gentoo Infrastructure gentoo-dev Security 2012-08-03 06:18:15 UTC
I can confirm this patch works. Please bump the ebuild.
Comment 3 Jason A. Donenfeld archtester Gentoo Infrastructure gentoo-dev Security 2012-08-08 15:48:42 UTC
Created attachment 320714 [details]
ptlib-2.6.7-r2.ebuild
Comment 4 Jason A. Donenfeld archtester Gentoo Infrastructure gentoo-dev Security 2012-08-08 15:49:18 UTC
Created attachment 320716 [details, diff]
ptlib-2.6.7-gcc-4.7.patch
Comment 5 Jason A. Donenfeld archtester Gentoo Infrastructure gentoo-dev Security 2012-08-08 16:55:56 UTC
Actually, one more change is needed for opal to compile against its headers. Attaching a new patch.
Comment 6 Jason A. Donenfeld archtester Gentoo Infrastructure gentoo-dev Security 2012-08-08 17:03:04 UTC
Created attachment 320724 [details, diff]
ptlib-2.6.7-gcc-4.7.patch (v2)
Comment 7 Andrew John Hughes 2012-09-24 21:35:31 UTC
Works for me. Please add to the version in tree.
Comment 8 Martin Jansa 2012-10-03 14:41:03 UTC
I can confirm that all 3 patches work, just rebuilt world with gcc-4.7.2.
Comment 9 Jesus Rivero (RETIRED) gentoo-dev 2012-10-24 14:26:48 UTC
This version bump should take care of this issue:

23 Oct 2012; Jesus Rivero <neurogeek@gentoo.org> +ptlib-2.10.8.ebuild,
+files/ptlib-2.10.8-disable-telnet-symbols.patch,
+files/ptlib-2.10.8-pkgconfig_ldflags.patch,
+files/ptlib-2.10.8-respect_cxxflags.patch,
+files/ptlib-2.10.8-svn_revision_override.patch, metadata.xml:
Version bump. Closes several bugs. Added myself as maintainer