Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 420073 - <dev-haskell/cabal-1.14 doesn't build against >=ghc-7.4.1
Summary: <dev-haskell/cabal-1.14 doesn't build against >=ghc-7.4.1
Status: RESOLVED DUPLICATE of bug 457714
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Haskell Language team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-07 10:21 UTC by M. B.
Modified: 2013-06-17 18:48 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,34.96 KB, text/plain)
2012-11-14 15:04 UTC, Robert Malek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M. B. 2012-06-07 10:21:34 UTC
ghc-7.4.1 includes cabal, hence the new cabal ebuild is just a placeholder. still there is no requirement that associates cabal-1.14 <=> ghc-7.4.1 and cabal-1.10 <=> ghc-7.04.

Needless to mention that the builds fail, if those dependencies are not heeded.

Reproducible: Always
Comment 1 Sergei Trofimovich gentoo-dev 2012-06-07 16:40:14 UTC
(In reply to comment #0)
> ghc-7.4.1 includes cabal, hence the new cabal ebuild is just a placeholder.
> still there is no requirement that associates cabal-1.14 <=> ghc-7.4.1 and
> cabal-1.10 <=> ghc-7.04.
> 
> Needless to mention that the builds fail, if those dependencies are not
> heeded.
> 
> Reproducible: Always

Sorry, I don't understand what you are talking about.
Please, clarify what is broken for you.
Comment 2 Sergei Trofimovich gentoo-dev 2012-06-07 16:46:44 UTC
> > ghc-7.4.1 includes cabal, hence the new cabal ebuild is just a placeholder.
> > still there is no requirement that associates cabal-1.14 <=> ghc-7.4.1 and
> > cabal-1.10 <=> ghc-7.04.
> > 
> > Needless to mention that the builds fail, if those dependencies are not
> > heeded.
> > 
> > Reproducible: Always
> 
> Sorry, I don't understand what you are talking about.
> Please, clarify what is broken for you.

Oh, my bad. I've misread the topic, sorry.

Yes, a lot of old stuff is broken against newer ghc.
Cabal is special here. Older Cabal versions don't
support newer ghc's .conf file format.

Do you really need Cabal-1.10?
Comment 3 M. B. 2012-06-09 07:39:04 UTC
It's just the ebuild dependencies that are broken.

Right now, if you have ghc-7.4.1 and try to build cabal, cabal stable is 1.10. cabal emerges and fails with (haskell) dependencies missing. This is not caught by ebuild-logic, where it should be circumvented by ebuild-logic.

so:
cabal-1.10 should depend on <ghc-7.4.1
cabal 1.14 should depend on >=ghc-7.4.1
Comment 4 Robert Malek 2012-11-14 14:55:24 UTC
after upgrading to dev-lang/ghc-7.4.2

Writing new package config file... done.
 * Package Cabal-1.14.0 is shipped with 7.4.2.
 * Ebuild author forgot CABAL_CORE_LIB_GHC_PV entry.
 * Found in ///usr/lib64/ghc-7.4.2/package.conf.d.initial.
 * ERROR: dev-haskell/cabal-1.14.0 failed (install phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_install
 *   environment, line 2648:  Called haskell-cabal_src_install
 *   environment, line 1983:  Called cabal_src_install
 *   environment, line  626:  Called die
 * The specific snippet of code:
 *                       die;
Comment 5 Robert Malek 2012-11-14 15:04:53 UTC
Created attachment 329542 [details]
build.log
Comment 6 Sergei Trofimovich gentoo-dev 2012-11-14 21:16:37 UTC
(In reply to comment #4)
> after upgrading to dev-lang/ghc-7.4.2
> 
> Writing new package config file... done.
>  * Package Cabal-1.14.0 is shipped with 7.4.2.
>  * Ebuild author forgot CABAL_CORE_LIB_GHC_PV entry.
>  * Found in ///usr/lib64/ghc-7.4.2/package.conf.d.initial.
>  * ERROR: dev-haskell/cabal-1.14.0 failed (install phase):
>  *   (no error message)
>  * 
>  * Call stack:
>  *     ebuild.sh, line   93:  Called src_install
>  *   environment, line 2648:  Called haskell-cabal_src_install
>  *   environment, line 1983:  Called cabal_src_install
>  *   environment, line  626:  Called die
>  * The specific snippet of code:
>  *                       die;

Yeah, fixed it some hours ago (found by DemonWitch on #gentoo-haskell)
Comment 7 Reinis Danne 2012-11-18 12:03:31 UTC
The same issue with extensible-exceptions-0.1.1.4. Maybe there are more of those and they all should be reviewed?
Comment 8 Sergei Trofimovich gentoo-dev 2012-11-18 14:29:00 UTC
(In reply to comment #7)
> The same issue with extensible-exceptions-0.1.1.4. Maybe there are more of
> those and they all should be reviewed?

Yeah. It was lost as well as dev-haskell/time-1.4 update from overlay.

Now should be better.

Thanks for the report!
Comment 9 Sergei Trofimovich gentoo-dev 2013-06-17 18:48:22 UTC
Closing as a dupe of 'bug #457714' (where upper bound was added).

*** This bug has been marked as a duplicate of bug 457714 ***