Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 41963 - [kde-testing]Ebuild: kdesudo (new package)
Summary: [kde-testing]Ebuild: kdesudo (new package)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD
: 210585 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-02-17 15:32 UTC by trejkaz
Modified: 2009-10-24 22:23 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild for app-admin/kdesudo (kdesudo-1.0.ebuild,496 bytes, text/plain)
2004-02-17 15:33 UTC, trejkaz
Details
ebuild for app-admin/kdesudo-2.3 (kdesudo-2.3.ebuild,1.09 KB, text/plain)
2008-02-17 11:17 UTC, Jiri Tyr
Details
kdesudo-2.4.ebuild (kdesudo-2.4.ebuild,1.07 KB, text/plain)
2008-02-18 16:23 UTC, Jiri Tyr
Details
kdesudo-2.4-r1.ebuild (kdesudo-2.4-r1.ebuild,1.08 KB, text/plain)
2008-02-21 11:33 UTC, Jiri Tyr
Details
kdesudo-2.5.1.ebuild (kdesudo-2.5.1.ebuild,1.09 KB, text/plain)
2008-04-12 18:22 UTC, Jiri Tyr
Details
kdesudo-2.6.ebuild (kdesudo-2.6.ebuild,1.09 KB, text/plain)
2008-04-21 13:21 UTC, Jiri Tyr
Details
app-admin/kdesudo (kdesudo-3.3.1.ebuild,1.29 KB, text/plain)
2008-11-11 18:11 UTC, Oleg Blednov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description trejkaz 2004-02-17 15:32:51 UTC
KdeSudo is a front-end to sudo for KDE, and IMO the way KDE should have done things in the first place, instead of going with KdeSu.

Reproducible: Always
Steps to Reproduce:




Will attach ebuild.
Comment 1 trejkaz 2004-02-17 15:33:51 UTC
Created attachment 25804 [details]
Ebuild for app-admin/kdesudo
Comment 2 trejkaz 2005-01-10 01:16:24 UTC
This bug seems to be lingering forever.  How hard is it to check in a working ebuild anyway?
Comment 3 Gregorio Guidi (RETIRED) gentoo-dev 2005-01-11 09:52:04 UTC
Development of kdesudo stopped nearly two years ago. I don't think this can go in portage...
Comment 4 trejkaz 2005-01-11 13:21:29 UTC
But it works, and I can't find any bugs.  What's the problem, exactly?
Comment 5 Gregorio Guidi (RETIRED) gentoo-dev 2005-01-11 14:26:01 UTC
Our resources are very limited, and every package that we add to the tree
- even if nearly bugfree - increases a bit our maintainance duties. For this
reason we are forced to restrict the candidate ebuilds for inclusion to 
include only packages that adhere to certain standards: they must have a 
decent audience and be actively maintained.

This can change in the future, if we increase our resources to those of - say 
- Debian.

The ebuild is not lost, though, anyone can find it here in bugzilla and use it.
Comment 6 Jiri Tyr 2008-02-17 09:34:01 UTC
It looks like there is some progress:
http://www.kde-apps.org/content/show.php/KdeSudo?content=72106
It would be nice to have this ebuild in portage tree. Please re-open this bug.
Comment 7 Jiri Tyr 2008-02-17 11:17:32 UTC
Created attachment 143767 [details]
ebuild for app-admin/kdesudo-2.3

Ebuild for app-admin/kdesudo-2.3.
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2008-02-18 15:55:29 UTC
*** Bug 210585 has been marked as a duplicate of this bug. ***
Comment 9 Jiri Tyr 2008-02-18 16:01:34 UTC
(In reply to comment #8)
> *** Bug 210585 has been marked as a duplicate of this bug. ***

OK, so can you reopen this bug please?
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2008-02-18 16:09:12 UTC
*** Bug 210585 has been marked as a duplicate of this bug. ***
Comment 11 Wulf Krueger (RETIRED) gentoo-dev 2008-02-18 16:21:05 UTC
Seems to be alive again. I'm going look at this soon.
Comment 12 Jiri Tyr 2008-02-18 16:23:09 UTC
(In reply to comment #11)
> Seems to be alive again. I'm going look at this soon.
> 

Thanks.
Comment 13 Jiri Tyr 2008-02-18 16:23:58 UTC
Created attachment 143884 [details]
kdesudo-2.4.ebuild

Ebuild for kdesudo-2.4.
Comment 14 Jiri Tyr 2008-02-21 11:33:07 UTC
Created attachment 144197 [details]
kdesudo-2.4-r1.ebuild

Dependency on >=app-admin/sudo-1.6.9_p12.
Comment 15 John Stile 2008-04-12 00:04:48 UTC
Is this supposed to work with kde 3.5.8?

I ran kcontrol under strace.
When I click 'System Administration' login manger, 
and then click 'Administrator Mode',
kdesudo dialog box does display, and I enter my passwd, and click OK.  
Then I am left to reselect the area of 'System Administration' but do not have administrative rights.  When I click 'Administrator Mode', strace shows:
  QLayout "unnamed" added to QVBox "m_body", which already has a layout passprompt
  kcmshell (kdelibs): WARNING: Could not find module 'kdm'.

I am using the ebuild kdesudo-2.4-r1.ebuild, and to install I had to unmask and emerge the following package versions:

   emerge --update --newuse --deep -ta  app-admin/kdesudo
      Calculating dependencies... done!
      [ebuild  N    ] app-admin/kdesudo-2.4-r1  USE="arts -debug -xinerama"
      [ebuild     U ]  app-admin/sudo-1.6.9_p14 [1.6.8_p12-r1]
      [ebuild  N    ]   sys-auth/pambase-20080318  USE="cracklib gnome -consolekit -debug -mktemp -passwdqc (-selinux)"
      [ebuild     U ]    sys-libs/pam-0.99.10.0 [0.99.9.0]
Comment 16 Jiri Tyr 2008-04-12 18:21:38 UTC
(In reply to comment #15)
> Is this supposed to work with kde 3.5.8?
> 
> I ran kcontrol under strace.
> When I click 'System Administration' login manger, 
> and then click 'Administrator Mode',
> kdesudo dialog box does display, and I enter my passwd, and click OK.  
> Then I am left to reselect the area of 'System Administration' but do not have
> administrative rights.  When I click 'Administrator Mode', strace shows:
>   QLayout "unnamed" added to QVBox "m_body", which already has a layout
> passprompt
>   kcmshell (kdelibs): WARNING: Could not find module 'kdm'.
> 
> I am using the ebuild kdesudo-2.4-r1.ebuild, and to install I had to unmask and
> emerge the following package versions:
> 
>    emerge --update --newuse --deep -ta  app-admin/kdesudo
>       Calculating dependencies... done!
>       [ebuild  N    ] app-admin/kdesudo-2.4-r1  USE="arts -debug -xinerama"
>       [ebuild     U ]  app-admin/sudo-1.6.9_p14 [1.6.8_p12-r1]
>       [ebuild  N    ]   sys-auth/pambase-20080318  USE="cracklib gnome
> -consolekit -debug -mktemp -passwdqc (-selinux)"
>       [ebuild     U ]    sys-libs/pam-0.99.10.0 [0.99.9.0]
> 

You should contact the author of kdesudo: http://www.kde-apps.org/content/show.php/KdeSudo?content=72106
Comment 17 Jiri Tyr 2008-04-12 18:22:11 UTC
Created attachment 149492 [details]
kdesudo-2.5.1.ebuild

Ebuild for kdesudo-2.5.1.
Comment 18 Jiri Tyr 2008-04-21 13:21:17 UTC
Created attachment 150500 [details]
kdesudo-2.6.ebuild

Ebuild for kdesudo-2.6.
Comment 19 Oleg Blednov 2008-11-11 18:09:56 UTC
Ebuild for kdesudo-3.3.1 on kde 4.1
Comment 20 Oleg Blednov 2008-11-11 18:11:00 UTC
Created attachment 171447 [details]
app-admin/kdesudo
Comment 21 Oleg Blednov 2008-11-11 18:13:00 UTC
Comment on attachment 171447 [details]
app-admin/kdesudo

Ebuild for kdesudo-3.3.1 and kde 4.1
Comment 22 Oleg Blednov 2008-11-11 18:14:38 UTC
Comment on attachment 171447 [details]
app-admin/kdesudo

Ebuild for kdesudo-3.3.1 and kde 4.1
Comment 23 Tomáš Chvátal (RETIRED) gentoo-dev 2008-11-12 12:24:13 UTC
This ebuild is already in kde-testing (and kde-crazy) so add one of the overlays if you want to use this app.
Comment 24 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-29 18:53:29 UTC
(this is an automated message based on filtering criteria that matched this bug)

Hello, The Gentoo Team would like to firstly thank you for your ebuild
submission. We also apologize for not being able to accomendate you on a timely
manor. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The sunrise
overlay[1] is a overlay for Gentoo which we allow trusted users to commit to and
all users can have ebuilds reviewed by Gentoo devs for entry into the overlay.
So, the sunrise team is suggesting that you look into this and submit your
ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. We
anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 25 trejkaz 2008-12-29 23:36:46 UTC
These days it's also possible to use sudo via kdesu itself.
http://dev-loki.blogspot.com/2006/11/kdesu-with-sudo.html
Comment 26 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-30 18:14:31 UTC
Sorry, I have refined my search to exclude [kde-* in the summary.
Comment 27 Maciej Mrozowski gentoo-dev 2009-08-31 08:10:40 UTC
Yeah, what's advantage of kdesudo over kdesu now? is it really worthy being kept?
Comment 28 Tomáš Chvátal (RETIRED) gentoo-dev 2009-10-24 22:23:11 UTC
Sorry guys but its rater more safe to use kdesu which now even supports using sudo as backend.