Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 419557 - games-action/cortex-command-0.25 new ebuild
Summary: games-action/cortex-command-0.25 new ebuild
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 1 vote (vote)
Assignee: Default Assignee for New Packages
Keywords: EBUILD
Depends on:
Reported: 2012-06-04 03:10 UTC by Jared B.
Modified: 2018-12-03 12:57 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

games-action/cortex-command-0.25.ebuild (cortex-command-0.25.ebuild,2.15 KB, text/plain)
2012-06-04 03:11 UTC, Jared B.
DataRealms license (DataRealms,5.00 KB, text/plain)
2012-06-04 03:11 UTC, Jared B.
games-action/cortex-command-1.0_rc1.ebuild (cortex-command-1.0_rc1.ebuild,2.16 KB, text/plain)
2013-03-20 01:59 UTC, Jared B.

Note You need to log in before you can comment on or make changes to this bug.
Description Jared B. 2012-06-04 03:10:47 UTC
New ebuild for Cortex Command.  This is for version 0.25, which is the most recent version available through the Humble Indie Bundle download page, but version 0.26 is available if you buy direct.

Couple things worth mentioned:

1. By far, the worst part of the game is that it saves it's settings file in the application directory (specifically, ./Base.rte/Settings.ini).  I tried working around this with a crapton of symlinks under ~/.cortex-command/, but I couldn't get it to work.  It's apparently a known issue based on a forum post, but the developers don't seem particular included to fix it.  This, obviously, would need to be solved or worked around before it's ready for portage inclusion.

2. The release package includes some bundled libraries, some of which are mandatory as they don't exist in portage and some of which can be replaced by portage packages.  I used the system-libs USE flag to control installation of the optional bundled libs.  The exception is this library is provided by media-libs/openal, and running an ldd on the game binary even shows that it finds the system version, but the game will crash when using it.  No idea why, but restoring the bundled version fixes the problem, so that's what's done in the ebuild.

Other than the above, the ebuild should be pretty self-explanatory.

Reproducible: Always
Comment 1 Jared B. 2012-06-04 03:11:09 UTC
Created attachment 314121 [details]
Comment 2 Jared B. 2012-06-04 03:11:35 UTC
Created attachment 314123 [details]
DataRealms license
Comment 3 Jared B. 2013-03-20 01:59:59 UTC
Created attachment 342684 [details]

minor update for 1.0rc release.  Unfortunately, the same issues mentioned above still apply.  Only difference in this ebuild (aside from supporting the new installer file name) is that I added a chmod -R g+w to the installation directory.  Ugly, I know, but it's the only way I can get it to save preferences and game progress.