Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 419421 - new ebuilds: games-fps/unvanquished games-fps/unvanquished-data
Summary: new ebuilds: games-fps/unvanquished games-fps/unvanquished-data
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 2 votes (vote)
Assignee: Default Assignee for New Packages
Whiteboard: [hasufell-overlay]
Keywords: EBUILD, InOverlay, PATCH
Depends on:
Reported: 2012-06-02 23:32 UTC by Julian Ospald
Modified: 2018-12-03 12:57 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

unvanquished-0.4.0-r1.ebuild (unvanquished-0.4.0-r1.ebuild,3.98 KB, text/plain)
2012-06-02 23:32 UTC, Julian Ospald
unvanquished-0.4.0-cmake.patch (unvanquished-0.4.0-cmake.patch,8.04 KB, patch)
2012-06-02 23:32 UTC, Julian Ospald
Details | Diff
unvanquished-data-0.4.0.ebuild (unvanquished-data-0.4.0.ebuild,516 bytes, text/plain)
2012-06-02 23:32 UTC, Julian Ospald

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Ospald 2012-06-02 23:32:04 UTC
Created attachment 313985 [details]

Unvanquished is a free and open-source team-based first person shooter based on Tremulous.
Comment 1 Julian Ospald 2012-06-02 23:32:24 UTC
Created attachment 313987 [details, diff]
Comment 2 Julian Ospald 2012-06-02 23:32:40 UTC
Created attachment 313989 [details]
Comment 3 Julian Ospald 2012-06-02 23:35:11 UTC
This is in my private overlay:
I'm not gonna add all those stuff from FILESDIR. Add my overlay to get it:

# layman -a hasufell

I think this would be nice to add to the tree once it reaches beta stage.
Comment 4 asp 2012-06-08 15:43:45 UTC
These worked perfectly for me on both ~amd64 and ~x86.
Thanks for the ebuilds!
Comment 5 lordcirth 2012-10-09 00:55:44 UTC
Thanks for adding this game! Version 0.8 alpha just came out, please add it. Thanks.
Comment 6 Julian Ospald 2012-10-09 17:37:56 UTC
yeah, you can open issues/bump requests/pull requests and such on the github site for now

makes it easier to catch for me and doesn't bloat this bug report (since it's not officially supported yet)
Comment 7 Wojciech Myrda 2016-04-17 16:11:17 UTC
there is new version .50 available. I tried to update Games-overlay ebuild to new version but it dint work for me due to empty libRocket folder. I did not try to install dev-libs/libRocket to see if game would use it instead of missing bundled version as game did not list it as required dependency

Few other observations I made

1) ebuild needs in DEPEND section
2) enewuser command does not work for new installs if "${PN}-server" group does not exists. New group needs to be created first
3) Ncurses patch does not seem required anymore as it seems to double with other entries in the patched file, but I might be wrong

On the side note why do we use patch removing  -ffast-math and -fvisibility=hidden from code and then inform users it might helpful to use it? Does LTO hurt ebuild as well as it is turned of in the configure section?
Comment 8 Wojciech Myrda 2016-12-26 07:42:38 UTC
I did install external libRocket-1.3.0 from the portage, but the game source does not look for it. Could anyone look at the code and prepare patch allowing the game to use external libRocket library? I failed at this task completely :(