Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 419415 - net-im/pidgin: Freeze on startup
Summary: net-im/pidgin: Freeze on startup
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-02 22:11 UTC by robo9k
Modified: 2013-03-19 06:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge net-im/pidgin-2.10.4::gentoo build (pidgin-2.10.4:20120602-221610.log,602.11 KB, text/plain)
2012-06-02 22:22 UTC, robo9k
Details
gdb backtrace for finch core dump (file_419415.txt,720 bytes, text/plain)
2012-06-02 22:24 UTC, robo9k
Details
gdb backtrace for pidgin after freezing (file_419415.txt,1.60 KB, text/plain)
2012-06-02 22:25 UTC, robo9k
Details
configure log for pidgin outside portage (pidgin-2.10.4-configure.log,18.05 KB, text/plain)
2012-06-02 22:28 UTC, robo9k
Details
make log for pidgin outside portage (pidgin-2.10.4-make.log,233.50 KB, text/plain)
2012-06-02 22:29 UTC, robo9k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robo9k 2012-06-02 22:11:38 UTC
After updating some other packages on my system Pidgin no longer works.

When launching Pidgin or Finch they freeze (consume 100% CPU).

From how I understand GDB the processes are stuck in tls_get_addr_tail() (more in the attached backtrace).

With the help from +hasufell on #gentoo I already tried a few things with pidgin-2.10.4;
- re-emerged pidgin and disabling/enabling use flags one-by-one
- modified the ebuild not to set --with-system-ssl-certs and --with-dynamic-prpls
- emerged with CFLAGS="" LDFLAGS="" FEATURES="-ccache"
- emerged with both ld.bfd and ld.gold
- started pidgin with a previously working ~/.purple/ as well as a blank folder
- removed all external plugins from the pidgin installation

I also tried to downgrade to pidgin-2.10.3, but it froze as well. I did however not try all the options liste above, just a regular emerge.

I then downloaded the source for pidgin-2.10.4 from upstream and compiled it outside portage like this;
../configure --disable-meanwhile --disable-avahi --disable-tcl --prefix=/home/robo/pidgin && make && make install
The pidgin and finch executables generated by this do not freeze, i.e. they work as expected!

On a sidenote, one time finch even died with a segfault. Unfortunately I do not remember the exact circumstances anymore (backtrace attached).

I don't know how finch internals work compared to pidgin, but finch at least draws my buddy list upon start. Its sub-processes for each of my accounts however just freeze once I go online.

Reproducible: Always

Steps to Reproduce:
Run "pidgin" or "finch".
Actual Results:  
Process consumes 100% at startup.


Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r3, 3.2.12-gentoo x86_64)
=================================================================
System uname: Linux-3.2.12-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Sat, 02 Jun 2012 17:45:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r1, 3.2.3
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo local
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=4 --load-average=1.5 --autounmask-write"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://mirror.netcologne.de/gentoo/ http://gentoo.mneisen.org/ http://mirror.ovh.net/gentoo-distfiles/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1"
LINGUAS="en de"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran fuse gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk hal iconv ipv6 jpeg laptop lcms ldap libnotify lm_sensors mad mmx mng modules mp3 mp4 mpeg mudflap multilib multitarget nautilus ncurses networkmanager nls nptl nvidia ogg openal opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support readline sdl session smp socialweb spell sse sse2 ssl ssse3 startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb vdpau vorbis wxwidgets x264 xcb xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 robo9k 2012-06-02 22:22:04 UTC
Created attachment 313971 [details]
emerge net-im/pidgin-2.10.4::gentoo build

Build log from emerging net-im/pidgin-2.10.4::gentoo with default use flags
Comment 2 robo9k 2012-06-02 22:24:19 UTC
Created attachment 313973 [details]
gdb backtrace for finch core dump
Comment 3 robo9k 2012-06-02 22:25:56 UTC
Created attachment 313975 [details]
gdb backtrace for pidgin after freezing
Comment 4 robo9k 2012-06-02 22:28:55 UTC
Created attachment 313977 [details]
configure log for pidgin outside portage
Comment 5 robo9k 2012-06-02 22:29:20 UTC
Created attachment 313979 [details]
make log for pidgin outside portage
Comment 6 robo9k 2012-06-16 22:36:00 UTC
After a sync and updating world, various packages failed compiling, some died with segfaults, up to a point where I decided that re-installing the system was the way to go.
Therefor I *guess* the messup was not related to pidgin, but located elsewhere in the system. Due to the reinstallation I can no longer provide any additional information on this problem.

Feel free to close this bugreport.
I am sorry for the noise.
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2013-03-19 06:54:23 UTC
Closing...