Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 418281 - [science overlay] sci-mathematics/scilab-5.3.3-r1 - .../work/scilab-5.3.3/modules/renderer/src/java/org/scilab/modules/renderer/utils/textRendering/*.java:[N]: package com.sun.opengl.util.[*] does not exist
Summary: [science overlay] sci-mathematics/scilab-5.3.3-r1 - .../work/scilab-5.3.3/mod...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Mathematics related packages
Depends on:
Reported: 2012-05-30 18:11 UTC by Juergen Rose
Modified: 2013-10-31 16:52 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log.bz2 (build.log.bz2,41.94 KB, application/x-bzip2)
2012-05-30 18:11 UTC, Juergen Rose

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2012-05-30 18:11:15 UTC
Created attachment 313631 [details]

'emerge scilab' fails with:
    [javac] /var/tmp/portage/sci-mathematics/scilab-5.3.3-r1/work/scilab-5.3.3/modules/renderer/src/java/org/scilab/modules/renderer/utils/textRendering/
    [javac] /var/tmp/portage/sci-mathematics/scilab-5.3.3-r1/work/scilab-5.3.3/modules/renderer/src/java/org/scilab/modules/renderer/utils/ package com.sun.opengl.util.texture does not exist
    [javac] import com.sun.opengl.util.texture.Texture;
    [javac]                                   ^
    [javac] /var/tmp/portage/sci-mathematics/scilab-5.3.3-r1/work/scilab-5.3.3/modules/renderer/src/java/org/scilab/modules/renderer/utils/ package com.sun.opengl.util.texture does not exist
    [javac] import com.sun.opengl.util.texture.TextureCoords;
    [javac]                                   ^
    [javac] /var/tmp/portage/sci-mathematics/scilab-5.3.3-r1/work/scilab-5.3.3/modules/renderer/src/java/org/scilab/modules/renderer/utils/ package com.sun.opengl.util.texture does not exist
    [javac] import com.sun.opengl.util.texture.TextureData;
    [javac]                                   ^
    [javac] /var/tmp/portage/sci-mathematics/scilab-5.3.3-r1/work/scilab-5.3.3/modules/renderer/src/java/org/scilab/modules/renderer/utils/ package com.sun.opengl.util.texture does not exist
    [javac] import com.sun.opengl.util.texture.TextureIO;
    [javac]                                   ^
    [javac] /var/tmp/portage/sci-mathematics/scilab-5.3.3-r1/work/scilab-5.3.3/modules/renderer/src/java/org/scilab/modules/renderer/utils/ cannot find symbol
    [javac] symbol  : class Texture
    [javac] location: class org.scilab.modules.renderer.utils.TexturedColorMap
    [javac] 	private Texture colorMapTexture;
    [javac] 	        ^
    [javac] 		gl.glColor3d(color[0], color[1], color[2]);
    [javac] 		  ^
    [javac] 100 errors

/var/tmp/portage/sci-mathematics/scilab-5.3.3-r1/work/scilab-5.3.3/build.incl.xml:163: Compile failed; see the compiler error output for details.

Total time: 1 second
make[3]: *** [java] Error 1

root@moose:/usr/local/portage/sci-libs(100)# emerge --info '=sci-mathematics/scilab-5.3.3-r1'
Portage (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.15-r2, 3.4.0-gentoo x86_64)
                        System Settings
System uname: Linux-3.4.0-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9650_@_3.00GHz-with-gentoo-2.1
Timestamp of tree: Wed, 30 May 2012 09:30:01 +0000
app-shells/bash:          4.2_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo x11 arcon bicatali sage-on-gentoo science lisp sunrise java-overlay ibormuth x-portage x-cpan g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10.3 cadsoft Oracle-BCLA-JavaSE"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-march=native -O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/arcon /var/lib/layman/bicatali /var/lib/layman/sage-on-gentoo /var/lib/layman/science /var/lib/layman/lisp /var/lib/layman/sunrise /var/lib/layman/java-overlay /var/lib/layman/ibormuth /usr/local/portage /var/lib/cpan /var/lib/g-octave"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 applet archive arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit corba cracklib crypt css cuda cups curl cxx daap db dbase dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse g3dvl galago garmin gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp ginac git glade glib glpk gml gmp gmtsuppl gnome gnome-keyring gnome-print gnuplot gnutls gphoto2 gpm grammar graphics graphtft graphviz grass gs gsl gsm gstreamer gtk gtk3 gudev guile harness hddtemp hdf hdf5 hdri http httpd hvm hwdb iconv icq icu id3 ide imagemagick imap innodb inotify ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdepim kdrive kerberos kpathsea kqemu kvm ladspa lame lapack latex latex3 lcms ldap lensfun libffi libgda libnotify libsamplerate lirc live lm_sensors lua lzo mad mail maildir mapnik math matroska media-library mkl mmx mmxext mng modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nsplugin ntfs ntp numpy nvidia obex objc ocaml ocr octave odbc ogdi ogg ole openexr opengl openmp overview pae pam pango pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime readline reiserfs reports rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smbclient smp sms sndfile snmp soup sox speex spell sql sqlite sse sse2 sse4 ssl ssse3 startup-notification stlport subtitles subversion suexec svg svm swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs tgif theora threads thunderbird tidy tiff tk tools truetype udev udisks unicode upower usb userlocales utempter vaapi video virtualbox visio vorbis wav webdav webdav-serf webkit wifi wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc yaml zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nv nouveau vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

root@moose:/usr/local/portage/sci-libs(101)# emerge -pqv '=sci-mathematics/scilab-5.3.3-r1'
 * EAPI assignment in ebuild 'dev-java/jgraphx-' does
 * not conform with PMS section 7.3.1 (see bug #402167):
 *      valid EAPI assignment must occur on or before line: 5
 * NOTE: This error will soon become unconditionally fatal in a future
 * version of Portage, but at this time, it can by made non-fatal by
 * setting FEATURES=-parse-eapi-ebuild-head in make.conf.
[ebuild     U ] sci-mathematics/scilab-5.3.3-r1 [5.3.3] USE="bash-completion%* doc fftw gui hdf5* matio nls openmp%* tk umfpack xcos -debug% -static-libs% -test%" LINGUAS="de%* -ca_ES% -es_ES% -fr_FR% -it% -ja% -pl% -pt_BR% -ru% -uk% -zh_CN% -zh_TW%"
Comment 1 Guillaume Horel 2012-05-31 00:51:02 UTC
Which version of java did you use? (java-config -L)
and which version of jogl and gluegen do you have installed?
Comment 2 Juergen Rose 2012-06-05 10:47:41 UTC
I have Sun JDK

root@moose:/root(54)# java-config -L
The following VMs are available for generation-2:
1)      IcedTea JDK 7.2.2 [icedtea-7]
*)      Sun JDK [sun-jdk-1.6]

moose ~ # qlist -Iv gluegen
moose ~ # qlist -Iv jogl   
Comment 3 Juergen Rose 2012-06-05 11:17:05 UTC
If I switch to IcedTea JDK 7.2.2, 'emerge scilab' fails with the same error:

root@moose:/root(2)# java-config -L
The following VMs are available for generation-2:
*)      IcedTea JDK 7.2.2 [icedtea-7]
2)      Sun JDK [sun-jdk-1.6]

root@moose:/root(3)# emerge -vuND --resume  world
These are the packages that would be merged, in order:
Calculating dependencies... done!
[ebuild     U  ] sci-mathematics/scilab-5.3.3-r1::science [5.3.3::science] USE="bash-completion%* doc fftw gui hdf5* matio nls openmp%* tk umfpack xcos -debug% -static-libs% -test%" LINGUAS="de%* -ca_ES% -es_ES% -fr_FR% -it% -ja% -pl% -pt_BR% -ru% -uk% -zh_CN% -zh_TW%" 0 kB
Total: 1 package (1 upgrade), Size of downloads: 0 kB
*** Resuming merge...
>>> Emerging (1 of 1) sci-mathematics/scilab-5.3.3-r1 from science
 * scilab-5.3.3-src.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                            [ ok ]
 * Using: icedtea-7
Using JAVAC=/usr/lib64/icedtea7/bin/javac
Java found in /usr/lib64/icedtea7
checking type of jvm... jdk
checking java API version... 1.6
Using the following JNI include flags -I/usr/lib64/icedtea7/include -I/usr/lib64/icedtea7/include/linux
    [javac] /var/tmp/portage/sci-mathematics/scilab-5.3.3-r1/work/scilab-5.3.3/modules/renderer/src/java/org/scilab/modules/renderer/utils/ error: package com.sun.opengl.util.texture does not exist
    [javac] import com.sun.opengl.util.texture.Texture;
    [javac]                                   ^
    [javac] /var/tmp/portage/sci-mathematics/scilab-5.3.3-r1/work/scilab-5.3.3/modules/renderer/src/java/org/scilab/modules/renderer/arcDrawing/ error: cannot find symbol
    [javac]             gl.glPopMatrix();
    [javac]               ^
    [javac]   symbol:   method glPopMatrix()
    [javac]   location: variable gl of type GL
    [javac] 100 errors
    [javac] 1 warning

/var/tmp/portage/sci-mathematics/scilab-5.3.3-r1/work/scilab-5.3.3/build.incl.xml:163: Compile failed; see the compiler error output for details.

Total time: 2 seconds
make[3]: *** [java] Error 1
Comment 4 Guillaume Horel 2012-06-14 00:47:48 UTC
It's because you have both jogl-1 and jogl-2 installed at the same time. The scilab configure script gets confused and picks up the location of jogl-2. If you remove jogl-2, it should compile fine. I'm working on a fix.
Comment 5 Juergen Rose 2012-06-15 15:00:59 UTC
Thanks Guillaume,

your recipe worked. But what I don't understand, is that, it seems me, that jogl-2.0_rc8 was installed as dependency of scilab-5.3.3:

root@moose:/root(44)# emerge -pv  --depclean =jogl-2.0_rc8
Calculating dependencies... done!
  dev-java/jogl-2.0_rc8 pulled in by:

If I remove forcible jogl-2.0_rc8:
root@moose:/root(45)# emerge -C =jogl-2.0_rc8

the next:
root@moose:/root(50)# emerge -vuND world

emerges scilab-5.3.3-r1.
Comment 6 Sébastien Fabbro (RETIRED) gentoo-dev 2013-10-31 16:52:40 UTC
was fixed.