Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 418211 - sys-process/xjobs - reads job descriptions line by line and executes them in parallel
Summary: sys-process/xjobs - reads job descriptions line by line and executes them in ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://www.maier-komor.de/xjobs.html
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2012-05-30 07:58 UTC by Andrej Gelenberg
Modified: 2014-10-19 00:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xjobs 20120412 ebuild (xjobs-20120412.ebuild,535 bytes, text/plain)
2012-05-30 07:59 UTC, Andrej Gelenberg
Details
xjobs ebuild (xjobs-20120412.ebuild,419 bytes, text/plain)
2012-05-30 18:09 UTC, Andrej Gelenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrej Gelenberg 2012-05-30 07:58:53 UTC
xjobs is useful tool for paralel tasks.

Reproducible: Always
Comment 1 Andrej Gelenberg 2012-05-30 07:59:53 UTC
Created attachment 313587 [details]
xjobs 20120412 ebuild
Comment 2 Jeroen Roovers gentoo-dev 2012-05-30 13:20:54 UTC
Comment on attachment 313587 [details]
xjobs 20120412 ebuild

DEPEND=""
RDEPEND=""

These can go, since they're empty anyway.

src_compile() {

This is exactly like the default src_compile for EAPI=0, so it should be removed too.

Speaking of EAPI, it should probably be set to 4, and then the || die() after dobin can go away too.

What is RESTRICT=mirror intended to do? It's GPL-2, so redistribution/mirroring should be freely allowed.
Comment 3 Andrej Gelenberg 2012-05-30 18:09:22 UTC
Created attachment 313629 [details]
xjobs ebuild

new try.
Comment 4 Michael Orlitzky gentoo-dev 2012-05-30 21:46:21 UTC
(In reply to comment #3)
> Created attachment 313629 [details]
> xjobs ebuild
> 
> new try.

The default src_install is no longer a no-op in EAPI4, so you can actually drop the whole thing, and portage will figure out what to do.

Other minor things:

* Copyright year should be updated

* Description is a little too long

* The IUSE variable is required, even if it's empty

This would be an easy review, so I'd suggest submitting it to the sunrise[1] overlay. There is will be reviewed by a Gentoo developer, giving it a better chance of making it into the portage tree.


[1] http://www.gentoo.org/proj/en/sunrise/
Comment 5 Michael Orlitzky gentoo-dev 2014-10-19 00:20:55 UTC
*xjobs-20140125 (19 Oct 2014)

  19 Oct 2014; Michael Orlitzky <mjo@gentoo.org> +metadata.xml,
  +xjobs-20140125.ebuild:
  New package: sys-process/xjobs fixing bug #418211. Original ebuild contributed
  by Andrej Gelenberg.