Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 418199 - sci-libs/mathgl-1.11.2 install phase - ln: failed to create symbolic link './mathgl-1.11.2/ChangeLog' -> '': No such file or directory
Summary: sci-libs/mathgl-1.11.2 install phase - ln: failed to create symbolic link './...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Andrey Grozin
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-30 04:48 UTC by Anton Kochkov
Modified: 2013-10-15 14:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
full build log (mathgl-1.11.2-build.log,79.58 KB, text/plain)
2012-05-30 04:48 UTC, Anton Kochkov
Details
emerge --info output (emerge-info.log,4.68 KB, text/plain)
2012-05-30 04:48 UTC, Anton Kochkov
Details
sci-libs/mathgl-1.11.2-r1.ebuild (mathgl-1.11.2-r1.ebuild,3.61 KB, text/plain)
2012-06-04 09:41 UTC, Dmitry Dzhus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Kochkov 2012-05-30 04:48:33 UTC
Created attachment 313571 [details]
full build log

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment -R .GCC.command.line
   usr/bin/mgl2png
   usr/bin/mgl2gif
   usr/bin/mgl2svg
   usr/bin/mgl2eps
   usr/bin/mgl2cpp
   usr/bin/mgl_qt_example
   usr/bin/mgl_example
   usr/lib64/libmgl.so.5.0.0
   usr/lib64/libmgl-qt.so.5.0.0
   usr/lib64/python2.7/site-packages/_mathgl.so
ln: failed to create symbolic link './mathgl-1.11.2/ChangeLog' -> '': No such file or directory
ln: failed to create symbolic link './mathgl-1.11.2/ChangeLog' -> '': No such file or directory
ecompressdir: bzip2 -9 /usr/share/doc
 [31;01m*[0m ERROR: sci-libs/mathgl-1.11.2 failed:
 [31;01m*[0m   ecompressdir failed
 [31;01m*[0m 
 [31;01m*[0m If you need support, post the output of `emerge --info '=sci-libs/mathgl-1.11.2'`,
 [31;01m*[0m the complete build log and the output of `emerge -pqv '=sci-libs/mathgl-1.11.2'`.
 [31;01m*[0m The complete build log is located at '/var/tmp/portage/sci-libs/mathgl-1.11.2/temp/build.log'.
 [31;01m*[0m The ebuild environment file is located at '/var/tmp/portage/sci-libs/mathgl-1.11.2/temp/environment'.
 [31;01m*[0m Working directory: '/var/tmp/portage/sci-libs/mathgl-1.11.2/image/usr/share/doc'
 [31;01m*[0m S: '/var/tmp/portage/sci-libs/mathgl-1.11.2/work/mathgl-1.11.2'
Comment 1 Anton Kochkov 2012-05-30 04:48:52 UTC
Created attachment 313573 [details]
emerge --info output
Comment 2 Dmitry Dzhus 2012-06-04 09:41:36 UTC
Created attachment 314143 [details]
sci-libs/mathgl-1.11.2-r1.ebuild

I've stumbled upon the same issue.
It seems to be caused by ChangeLog symlinked to ChangeLog.txt.
If we overwrite the symlink with the original ChangeLog, the package installs just fine.
Comment 3 Justin Lecher gentoo-dev 2013-10-15 14:58:18 UTC
Version already removed. newer do not suffer from this.