Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 417983 - media-libs/ffmpegsource-2.17 with =media-video/ffmpeg-0.11 - In function `main': conftest.c:(.text.startup+0x7): undefined reference to `avcodec_init'
Summary: media-libs/ffmpegsource-2.17 with =media-video/ffmpeg-0.11 - In function `mai...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Nikoli
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ffmpeg-0.11-breakage
  Show dependency tree
 
Reported: 2012-05-28 13:15 UTC by shinydoofy
Modified: 2012-11-08 11:31 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log.bz2,2.65 KB, application/x-bzip)
2012-05-28 13:16 UTC, shinydoofy
Details
config.log (config.log.bz2,7.71 KB, application/x-bzip)
2012-05-28 13:19 UTC, shinydoofy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shinydoofy 2012-05-28 13:15:53 UTC
During ./configure, linking to ffmpeg fails. See the attached logs for details.

Reproducible: Always

Steps to Reproduce:
1. Have =media-video/ffmpeg-0.11 installed
2. # emerge -1v ffmpegsource
Actual Results:  
./configure succeeds

Expected Results:  
./configure fails

Portage 2.2.0_alpha108 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r2, 3.3.0-64 x86_64)
=================================================================
System uname: Linux-3.3.0-64-x86_64-Intel-R-_Core-TM-_i7_CPU_X_980_@_3.33GHz-with-gentoo-2.1
Timestamp of tree: Sun, 27 May 2012 14:45:01 +0000
app-shells/bash:          4.2_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo local glc
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula cadsoft ut2003 AdobeFlash-10.3 QUAKE4 Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS=""
MAKEOPTS="-j13"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/glc"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa amd64 bash-completion berkdb bluetooth bluray branding bzip2 cdr cjk cli consolekit cracklib crypt cups cursors cxx dbus dri dts dvd dvdr enca ffmpeg firefox flac fortran gdbm gif glut gpm gtk icons iconv id3 id3tag introspection ipv6 java jpeg jpeg2k kde libcaca libnotify libsamplerate lm_sensors lzo mad matroska mmx mmxext modules mp3 mp4 mpeg mudflap multilib mysql ncurses networkmanager nls nptl nsplugin nvidia ogg ogm opengl openmp pcre pdf png policykit pppd qt3support qt4 readline samba sdl session smp speex srt sse sse2 ssl ssse3 svg tcpd tetex theora tiff truetype unicode usb vdpau vorbis wmf x264 xattr xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="x86_64" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 shinydoofy 2012-05-28 13:16:36 UTC
Created attachment 313379 [details]
build.log
Comment 2 shinydoofy 2012-05-28 13:19:38 UTC
Created attachment 313381 [details]
config.log
Comment 3 Jeroen Roovers gentoo-dev 2012-05-28 23:26:34 UTC
Comment on attachment 313381 [details]
config.log

Please don't compress (small) files.
Comment 4 Moonfire 2012-07-24 17:54:31 UTC
Okay, I have the same problem and it looks like, there is still no fix or patch.
------snip------
checking for LIBAV... yes
checking whether linking with FFmpeg or Libav... FFmpeg
checking whether FFmpeg works... no
configure: error: in `/var/tmp/portage/media-libs/ffmpegsource-2.17/work/ffmpegsource-2.17_build':
configure: error: cannot link with FFmpeg
See `config.log' for more details
------snip------

I've rebuild my ffmpeg and all needed libs, but it still doesn't work.

Any ideas?
Comment 5 Alexis Ballier gentoo-dev 2012-11-08 11:31:28 UTC
fixed