Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 417887 - Date format specifiers should be documented in man page
Summary: Date format specifiers should be documented in man page
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: FreeBSD (show other bugs)
Hardware: All FreeBSD
: Low enhancement (vote)
Assignee: Gentoo/BSD Team
URL:
Whiteboard:
Keywords: NeedPatch
Depends on:
Blocks:
 
Reported: 2012-05-27 23:23 UTC by Richard Yao
Modified: 2012-08-06 21:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Yao gentoo-dev 2012-05-27 23:23:07 UTC
The bottom of the date(1) man page has `date -j -f "%a %b %d %T %Z %Y" "`date`" "+%s"`, but it does not document the meaning of the format specifers.

It would be nice if the date command had documentation on the format specifiers to it.
Comment 1 Alexis Ballier gentoo-dev 2012-05-28 15:22:59 UTC
you should submit this upstream
Comment 2 Naohiro Aota gentoo-dev 2012-06-02 03:13:05 UTC
# man date
...
> The format string may contain any of the conversion specifications described in the strftime(3) manual page, as well as any arbitrary text.
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-06-03 14:18:10 UTC

*** This bug has been marked as a duplicate of bug 419473 ***
Comment 4 Alexis Ballier gentoo-dev 2012-08-06 21:43:08 UTC
(In reply to comment #2)
> # man date
> ...
> > The format string may contain any of the conversion specifications described in the strftime(3) manual page, as well as any arbitrary text.

closing as upstream (or maybe invalid)