Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 417859 - app-emulation/emul-linux-x86-medialibs-20120520 - broken /usr/lib32/libavdevice.so.53.4.100 (requires libpulse-simple.so.0 libpulse.so.0)
Summary: app-emulation/emul-linux-x86-medialibs-20120520 - broken /usr/lib32/libavdevi...
Status: RESOLVED DUPLICATE of bug 416751
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: AMD64 Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-27 19:37 UTC by DaggyStyle
Modified: 2012-06-03 14:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DaggyStyle 2012-05-27 19:37:49 UTC
see snip:
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 31% ]  *   broken /usr/lib32/libavdevice.so.53.4.100 (requires libpulse-simple.so.0
libpulse.so.0)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/lib32/libavdevice.so.53.4.100 -> app-emulation/emul-linux-x86-medialibs
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --complete-graph=y --oneshot --keep-going --quiet-build=n  app-emulation/emul-linux-x86-medialibs:0
..........
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) app-emulation/emul-linux-x86-medialibs-20120520
 * emul-linux-x86-medialibs-20120520.tar.xz RMD160 SHA1 SHA256 size ;-) ...                                              [ ok ]
>>> Unpacking source...
>>> Unpacking emul-linux-x86-medialibs-20120520.tar.xz to /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work
>>> Source unpacked in /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work
>>> Preparing source in /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/work ...
>>> Source compiled.
>>> Test phase [not enabled]: app-emulation/emul-linux-x86-medialibs-20120520

>>> Install emul-linux-x86-medialibs-20120520 into /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/image/ category app-emulation
>>> Completed installing emul-linux-x86-medialibs-20120520 into /var/tmp/portage/app-emulation/emul-linux-x86-medialibs-20120520/image/


 * QA Notice: The following files contain runtime text relocations
 *  Text relocations force the dynamic linker to perform extra
 *  work at startup, waste system resources, and may pose a security
 *  risk.  On some architectures, the code may not even function
 *  properly, if at all.
 *  For more information, see http://hardened.gentoo.org/pic-fix-guide.xml
 *  Please include the following list of files in your report:
 * TEXTREL usr/lib32/libx264.so.120


>>> Installing (1 of 1) app-emulation/emul-linux-x86-medialibs-20120520

 * Messages for package app-emulation/emul-linux-x86-medialibs-20120520:

 * Package:    app-emulation/emul-linux-x86-medialibs-20120520
 * Repository: gentoo
 * Maintainer: amd64@gentoo.org
 * USE:        amd64 consolekit elibc_glibc kernel_linux multilib policykit userland_GNU
 * FEATURES:   sandbox
 * Package:    app-emulation/emul-linux-x86-medialibs-20120520
 * Repository: gentoo
 * Maintainer: amd64@gentoo.org
 * USE:        amd64 consolekit elibc_glibc kernel_linux multilib policykit userland_GNU
 * FEATURES:   sandbox
 * QA Notice: The following files contain runtime text relocations
 *  Text relocations force the dynamic linker to perform extra
 *  work at startup, waste system resources, and may pose a security
 *  risk.  On some architectures, the code may not even function
 *  properly, if at all.
 *  For more information, see http://hardened.gentoo.org/pic-fix-guide.xml
 *  Please include the following list of files in your report:
 * TEXTREL usr/lib32/libx264.so.120
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
 * Build finished correctly. Removing temporary files...
 * You can re-run revdep-rebuild to verify that all libraries and binaries
 * are fixed. Possible reasons for remaining inconsistencies include:
 *   orphaned files
 *   deep dependencies
 *   packages installed outside of portage's control
 *   specially-evaluated libraries
dagg@NCC-5001-D ~ $ qfile libavdevice.so.53.4.100
app-emulation/emul-linux-x86-medialibs (/usr/lib32/libavdevice.so.53.4.100)
dagg@NCC-5001-D ~ $ Su revdep-rebuild -ip
Password: 
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 31% ]  *   broken /usr/lib32/libavdevice.so.53.4.100 (requires libpulse-simple.so.0
libpulse.so.0)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/lib32/libavdevice.so.53.4.100 -> app-emulation/emul-linux-x86-medialibs
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --complete-graph=y --oneshot --keep-going --quiet-build=n --pretend app-emulation/emul-linux-x86-medialibs:0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] app-emulation/emul-linux-x86-medialibs-20120520 
 * Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.

emerge --info:
Portage 2.1.10.63 (default/linux/amd64/10.0/desktop/kde, gcc-4.6.3, glibc-2.15-r2, 3.4.0-gentoo x86_64)
=================================================================
System uname: Linux-3.4.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Sun, 27 May 2012 16:00:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo x11 kde enlightenment vmware gamerlay-stable Utopia_Platinia
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula Broadcom PUEL googleearth LOKI-EULA AdobeFlash-10.3 RTCW-ETEULA ut2003 MakeMKV-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -msse4.1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -msse4.1"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --quiet-build=n"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.halifax.rwth-aachen.de/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en he es"
MAKEOPTS="-j10"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=180"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/kde /var/lib/layman/enlightenment /var/lib/layman/vmware /var/lib/layman/gamerlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aio alsa amd64 amr audiofile bash-completion berkdb bidi branding bzip2 c++0x cairo cdda cdparanoia cdr cjk cleartype cli consolekit cracklib crypt css cups curl cxx dbus declarative device-mapper dga dri drm dts dv dvb dvd dvdr dvdread edb emboss encode exif faad fam ffmpeg firefox flac fortran ftp gallium gdbm gif gphoto2 gpm gtk iconv icq id3tag imagemagick java javascript jpeg jpeg2k kde kipi lame lcms ldap libnotify lua lzma mad matroska mmx mng modules mono mp3 mp4 mpeg mtp mudflap multilib nas ncurses nls nptl nsplugin ogg openal openexr opengl openmp openvg oss pam pango pcre pdf perl phonon php plasma png policykit ppds pppd private-headers python qt3support qt4 quicktime readline samba scanner sdl session smp sndfile spell srt sse sse2 sse3 ssl ssse3 startup-notification svg tcpd theora threads tiff truetype udev udisks unicode upower usb v4l v4l2 vcd vdpau vorbis vpx wavpack wifi wma wxwidgets x264 xcb xcomposite xinerama xml xorg xosd xrandr xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel usb-audio" ALSA_PCM_PLUGINS="multi asym rate dmix dshare dsnoop softvol plug extplug ioplug hooks empty route file" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc efi-64" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en he es" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="vesa v4l radeon r600 i915 intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, USE_PYTHON

looking in the need suggests libpulse-simple.so.0 is part of pulseaudio, so either making this package depended on pulseaudio is needed or compile it without pulseaudio support.

I think that latter is better as I don't see and reason why pulse audio should be forcefully installed on a system.

Reproducible: Always
Comment 1 Manuel Rüger gentoo-dev 2012-05-27 21:20:19 UTC
see bug #416751
Comment 2 Pacho Ramos gentoo-dev 2012-05-28 09:00:31 UTC

*** This bug has been marked as a duplicate of bug 416751 ***
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-06-03 14:18:11 UTC

*** This bug has been marked as a duplicate of bug 419473 ***
Comment 4 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-06-03 14:27:33 UTC

*** This bug has been marked as a duplicate of bug 416751 ***