Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 417659 - =dev-libs/glib-2.32* in combination with <dev-libs/gobject-introspection-1.32 breaks building of udev[introspection], upower[introspection], ...
Summary: =dev-libs/glib-2.32* in combination with <dev-libs/gobject-introspection-1.32...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 417665 (view as bug list)
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-05-26 16:12 UTC by Andreas K. Hüttel
Modified: 2012-07-07 13:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (udev-171-r6:20120526-160647.log,37.77 KB, text/plain)
2012-05-26 16:12 UTC, Andreas K. Hüttel
Details
emerge --info (emerge-info.txt,16.06 KB, text/plain)
2012-05-26 16:13 UTC, Andreas K. Hüttel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel gentoo-dev 2012-05-26 16:12:25 UTC
Created attachment 313147 [details]
build log

g-ir-scanner: link: libtool --mode=link --tag=CC gcc -o /var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0 -export-dynamic -march=native -O2 -pipe -ggdb -L. -lgudev-1.0 -L./libudev -L./extras/gudev -pthread -lgio-2.0 -lgthread-2.0 -lrt -lgobject-2.0 -lglib-2.0 /var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.o
libtool: link: gcc -o /var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/.libs/GUdev-1.0 -march=native -O2 -pipe -ggdb -pthread /var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.o -Wl,--export-dynamic  -L. /var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/extras/gudev/.libs/libgudev-1.0.so /var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/libudev/.libs/libudev.so -L./libudev -L./extras/gudev -lgio-2.0 -lgthread-2.0 -lrt -lgobject-2.0 -lglib-2.0 -pthread
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.1/../../../../x86_64-pc-linux-gnu/bin/ld: /var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.o: in function main:/var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.c:457: error: undefined reference to 'g_module_open'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.1/../../../../x86_64-pc-linux-gnu/bin/ld: /var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.o: in function main:/var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.c:86: error: undefined reference to 'g_module_symbol'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.1/../../../../x86_64-pc-linux-gnu/bin/ld: /var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.o: in function main:/var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.c:111: error: undefined reference to 'g_module_symbol'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.1/../../../../x86_64-pc-linux-gnu/bin/ld: /var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.o: in function main:/var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.c:460: error: undefined reference to 'g_module_error'
collect2: ld returned 1 exit status
linking of temporary binary failed: Command '['libtool', '--mode=link', '--tag=CC', 'gcc', '-o', '/var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0', '-export-dynamic', '-march=native', '-O2', '-pipe', '-ggdb', '-L.', '-lgudev-1.0', '-L./libudev', '-L./extras/gudev', '-pthread', '-lgio-2.0', '-lgthread-2.0', '-lrt', '-lgobject-2.0', '-lglib-2.0', '/var/tmp/portage/sys-fs/udev-171-r6/work/udev-171/tmp-introspect7mN6Rw/GUdev-1.0.o']' returned non-zero exit status 1
make[2]: *** [extras/gudev/GUdev-1.0.gir] Fehler 1
make[1]: *** [all-recursive] Fehler 1
make: *** [all] Fehler 2

See attached files for more info
Comment 1 Andreas K. Hüttel gentoo-dev 2012-05-26 16:13:24 UTC
Created attachment 313149 [details]
emerge --info
Comment 2 Rafał Mużyło 2012-05-26 17:33:07 UTC
Any chance you're referring to this :
http://git.gnome.org/browse/gobject-introspection/commit/configure.ac?id=db15e837e324eb228b66beee968e3d5d2eb0cd4e ?
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-05-26 19:16:00 UTC
What versions of glib and gobject-introspection do you have?
Comment 4 Andreas K. Hüttel gentoo-dev 2012-05-27 13:44:46 UTC
(In reply to comment #2)
> Any chance you're referring to this :
> http://git.gnome.org/browse/gobject-introspection/commit/configure.
> ac?id=db15e837e324eb228b66beee968e3d5d2eb0cd4e ?

Looks good, yes... is that already in an ebuild somewhere?

(In reply to comment #3)
> What versions of glib and gobject-introspection do you have?

A slightly unconventional combination I guess...

dev-libs/glib-2.32.2
dev-libs/gobject-introspection-1.30.0-r2
Comment 5 Andreas K. Hüttel gentoo-dev 2012-05-27 13:57:53 UTC
Problem goes away after updating gobject-introspection to 1.32.1.
Comment 6 Samuli Suominen gentoo-dev 2012-05-27 15:24:53 UTC
*** Bug 417665 has been marked as a duplicate of this bug. ***
Comment 7 Pacho Ramos gentoo-dev 2012-05-27 16:01:04 UTC
Can you check if simply rebuilding dev-libs/gobject-introspection-1.30.0-r2 also solve the issue?
Comment 8 Pacho Ramos gentoo-dev 2012-07-07 13:07:29 UTC
(In reply to comment #7)
> Can you check if simply rebuilding dev-libs/gobject-introspection-1.30.0-r2
> also solve the issue?