Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 417239 - If LXDE session is running the kbd input on tty1 is broken (need to press keys twice)
Summary: If LXDE session is running the kbd input on tty1 is broken (need to press key...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: LXDE team (DEFUNCT)
Depends on:
Reported: 2012-05-23 09:25 UTC by Alex
Modified: 2019-06-01 10:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Requested Xorg.0.log file (Xorg.0.log,27.34 KB, text/plain)
2012-05-23 10:06 UTC, Alex

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2012-05-23 09:25:08 UTC
Hi there,
Even though the bug #393681 is fixed I guess (pehaps wrongly) I have a related issue but failed to solve it.
I have gentoo x86_64 stable (apart from few pkgs, like lxdm, which do not exist in stable) and have the following problem:
once lxde session is started on tty7 (using lxdm through /etc/init.d/xdm) the keyboard input on tty1 is broken.
Precisely, I start lxdm using /etc/init.d/xdm and this is in the default runlevel.

If I DO NOT start LXDE session and login on tty1, than everything is ok.

If I DO start LXDE session and after do log in on tty1 I should press each key TWICE in order a symbol to appear. Even to log in. I only can enter username normally. Even enter after that should be pressed twice.

Even if I first login on tty1 and AFTER start lxde session, the input becomes broken on tty1. Once logged out from lxde tty1 resotres its normal behavior.

Once lxde session is closed I can login on tty1 normally.

Any clue, guys, what is wrong?

I did not modify things a lot, really, almost everything is out of the box. I just put 'lxdm' in /etc/conf.d/xdm

I have second x86_64 system and there the behavior is THE SAME.

I have another system, gentoo x86 and there everything works ok on tty1. Both systes are almost identical. I hardly tried to make my new x86_64 be as much close to previous x86 as possible.
BUT there is still a bit older lxdm there, I guess (even though I do 'emerge -DNu world' each Monday). It HAS /etc/lxdm/xinitrc file.
Is it important that this old /etc/lxdm/xinitrc does source files from '/etc/X11/xinit/xinitrc.d'? (see bug #393681 on some issue with that file though)

I have tried to manually put this xinitrc file back to /etc/lxdm/ on my new x86_64 system. But I have noticed no changes.

BTW, I have NO any other desktop managers (gdm, kdm) or enviroments, like gnome, kde, etc.

Well, I understand that I can work on tty2, tty3, instead of tty1, it is not THAT problematic, but would be happy to make gentoo better.
Forgot to state explicitly: ONLY tty1 is affected

Thanks in advance

Reproducible: Always

Steps to Reproduce:
1.lxdm started using xdm in default runlevel
2.start lxde session
3.login (if you still normally enter your password) on tty1
Actual Results:  
Have to press keys twice to have output

Expected Results:  
Normal kbd input

If you have running lxde session and run showkey on tty1 than you see an out put kind of this:
keycode 34 press
keycode 34 press
keycode 34 press
keycode 34 release
keycode 56 release
keycode 56 release
keycode 56 press
keycode 56 release
You notice that not all press/release events are detected

Moreover, sometime the logout from tty1 in this situation lasts forever and kernel throws away the following error:
tty_ldisc_hangup: waiting (login) for tty1 took too long, but we keep waiting...

Really confused ...
Comment 1 Michael Weber (RETIRED) gentoo-dev 2012-05-23 09:41:04 UTC
This behaviour sound familiar,

Can you post the output of `ps ax | egrep (tty|X)` and the current (newest) /var/log/Xorg.*.log file _after_ you logged in on the lxdm/LXDE session?

I assume that any agetty battles with X for the input of an particular terminal.
Comment 2 Alex 2012-05-23 10:05:16 UTC
These are the results:

ps ax | egrep '(tty|X)'
 2960 tty7     Ss+    0:01 /usr/bin/X :0 vt07 -nolisten tcp
 3115 tty1     Ss+    0:00 /sbin/agetty 38400 tty1 linux
 3116 tty2     Ss+    0:00 /sbin/agetty 38400 tty2 linux
 3117 tty3     Ss+    0:00 /sbin/agetty 38400 tty3 linux
 3199 ?        Ss     0:00 /usr/bin/lxsession -s LXDE -e LXDE
 3215 ?        S      0:00 lxpanel --profile LXDE
 3216 ?        S      0:00 pcmanfm --desktop --profile LXDE
 3512 pts/0    S+     0:00 egrep (tty|X)

/var/log/Xorg.0.log is attahced.

I did a reboot just before to make things clear and have not attempted in anyway to log in on tty1. I clearly have logged into lxde because I'm writing this in a graphical environment.
What drives me crazy that my other x86 is free of this trouble. As I wrote it has /etc/lxdm/xinitrc file but again as I wrote, bringing this file on the problematic system did not resolve the issue.
Comment 3 Alex 2012-05-23 10:06:21 UTC
Created attachment 312793 [details]
Requested Xorg.0.log file
Comment 4 Alex 2012-06-14 13:17:06 UTC
Due to HDD crash I had to reinstall the sytem from scratch on x86 laptop and now I can say that the behavior is identical on all 3 laptops I have: input on the tty1 is broken. I do not know what have significantly changed in the renewed x86 but at least now I have a filling that this is platform independent feature. Not sure this helps a lot but is an info anyway.
Comment 5 Hanno Böck gentoo-dev 2019-05-24 18:28:58 UTC
As this is a pretty old bug may I ask if this still happens with latest versions of the LXDE packages?
Comment 6 Hanno Böck gentoo-dev 2019-06-01 10:20:26 UTC
Closing as obsolete, please re-open if you can reproduce on a current system.