Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 41643 - My sound was gone with KDE 3.2.0 but still works in KDE 3.1.5 (with alsa-driver 1.0.2c)
Summary: My sound was gone with KDE 3.2.0 but still works in KDE 3.1.5 (with alsa-driv...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2004-02-15 03:30 UTC by Rene Androsch
Modified: 2004-02-15 09:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rene Androsch 2004-02-15 03:30:12 UTC
Any idea what is wrong?

I have a new arts + all kde packages emerged.
I still have KDE 3.1.5 around.
I also have the newest alsa-driver 1.0.2c

In KDE 3.1.5, I've sound! I can play wav and mp3 files with xmms (1.2.9-r2) and noatun. KDE's sound system is told to use alsa.

In KDE 3.2.0, I've NO sound. When I play a mp3 file with noatun and I open artscontrol -> I see that it plays the sound, the bars are moving. But nothing comes out of the speakers.

So I switched back to KDE 3.1.5 (rc.conf -> XSESSION=3.1.5 instead of 3.2.0) and I've sound again.

I remove ~user/.kde3.2 and copy ~user/.kde3.1 into place. Started KDE 3.2.0 (now I have my old setup back) but no sound again!

Again playing with noatun a mp3 files and starting artscontrol shows moving bars.

By looking into the console: (ps -Af)
//usr/kde/3.2/bin/artsd -F 20 -S 4096 -a alsa -d -n -b 16 -s 60 -m artsmessage -c drkonqi -l 3 -f

The only thing, that looks wrong, is the doulbe / at the beginning!

What can I do to get sound in KDE 3.2.0 working?

BTW: I have arts-1.1.5 and arts-1.2.0 on the system. Maybe I should remove the old one, but will KDE 3.1.5 work with it?

Reproducible: Always
Steps to Reproduce:

Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.3_pre20040207-r0,
System uname: 2.4.22-gentoo-r5 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 2.00GHz
Gentoo Base System version
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59
Automake: sys-devel/automake-1.8.2
CFLAGS="-march=pentium4 -O3 -mmmx -msse -msse2 -mfpmath=sse -funroll-loops
-fprefetch-loop-arrays -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/lib/jboss
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=pentium4 -O3 -mmmx -msse -msse2 -mfpmath=sse -funroll-loops
-fprefetch-loop-arrays -pipe"
FEATURES="autoaddcvs buildpkg ccache sandbox"
USE="X alsa apache apache2 apm arts artswrappersuid avantgo avi berkdb cdr crypt
doc dvd dvdr encode foomaticdb gd-external gdbm gif gphoto2 gpm gtk2 idea imap
imlib java javascript jpeg kde libg++ libwww mad memlimit mhash mikmod mmx motif
mozilla mpeg mysql nas ncurses nls nvidia oci8 odbc oggvorbis opengl oss pda
pdflib perl png pnp python qt quicktime readline ruby samba scanner sdl slang
spell sse sse2 ssl tcltk tcpd tetex tiff truetype usb vim-with-x x86 xml2 xmms
xv zlib"
Comment 1 Rene Androsch 2004-02-15 09:02:11 UTC
The problem was hiding somewhere.
I used s symlink, so that ~user/.kde3.2 points to ~user/.kde3.1.
Then I restarted in KDE 3.1.5 (rc.conf XSESSION=...)
I tested all sounds -> worked again.
Tested sounds -> worked, so I copied the /etc/asound.state file into /tmp
Loaded KDE 3.2.0 -> no sound.
Took a look at alsamixer -> looked quite different than in KDE 3.1.5 (!!).
Left KDE 3.2.0, stopped alsasound. copied asound.state from /tmp back to /etc.
Then in ~user/.kde3.2/share/config, I removed kcmartsrc.
Then I rebooted (just to make sure, nothings hangs -> somethimes the ALSA modules fail to unload completey).

After reboot checked that sound worked (playsound ...) and looked at the alsamixer again -> it was my configuration!

Started KDE 3.2.0 -> enables arts -> noatun plays very well and xmms is playing via alsa and mixing works :)

Testing xmms with xmms-arts-0.4-r6 works :) [xmms-arts-0.6 never works for me!]

Next thing that caused the f#ck sound problem:

Soundcard (module name): snd-via82xx
alsamixer (at the end) "External Amplifier Power Down" -> when this thingy is muted, everything works. Is this enabled -> no sound in KDE 3.2.0 :(

Seems, me KDE 3.2.0 gets stable for me :)
(Only on micro problem with console windows, not always drawing the transparent background correctly, but thats not so important)