Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 415801 - www-client/epiphany-3.4.1 fails test test-ephy-embed-single
Summary: www-client/epiphany-3.4.1 fails test test-ephy-embed-single
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2012-05-13 20:37 UTC by Markus Oehme
Modified: 2014-05-31 06:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,162.77 KB, text/plain)
2012-05-13 20:37 UTC, Markus Oehme
Details
emerge --info (info.txt,5.27 KB, text/plain)
2012-05-13 20:37 UTC, Markus Oehme
Details
build log (epiphany-3.8.2:20131222-193049.log,492.30 KB, text/plain)
2013-12-22 19:38 UTC, Markus Oehme
Details
emerge --info (info.txt,5.59 KB, text/plain)
2013-12-22 19:38 UTC, Markus Oehme
Details
messages in /var/log/messages pertaining to merging of epiphany (grsec-messages.txt,508 bytes, text/plain)
2013-12-22 19:39 UTC, Markus Oehme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Oehme 2012-05-13 20:37:40 UTC
Created attachment 311687 [details]
build log

On my hardened ~amd64 machine with gcc-4.6.2 the test test-ephy-embed-single fails with the following error message.

TEST: test-ephy-embed-single... (pid=9566)
  /embed/ephy-embed-single/new:                                        OK
  /embed/ephy-embed-single/get_from_shell:                             FAIL
GTester: last random seed: R02S18200cbd6993d77ba738d3d3bbcc0282
/bin/sh: line 1:  9544 Terminated              G_DEBUG=gc-friendly MALLOC_CHECK_=2 MALLOC_PERTURB_=$((${RANDOM:-256} % 256)) gtester --verbose test-ephy-download test-ephy-embed-single test-ephy-embed-utils test-ephy-history test-ephy-location-entry test-ephy-search-entry test-ephy-sqlite test-ephy-web-view
make[2]: *** [test-nonrecursive] Error 143
Comment 1 Markus Oehme 2012-05-13 20:37:55 UTC
Created attachment 311689 [details]
emerge --info
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-05-19 21:58:20 UTC
Thanks for reporting; fixed in cvs.

>  19 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
>  epiphany-3.4.2.ebuild:
>  Fix test failure on hardened (bug #415801, thanks to Markus Oehme).
Comment 3 Markus Oehme 2012-06-02 19:29:25 UTC
Sorry to bother you again, but I'm not using the jit flag. I think you need to apply the paxmarking unconditionally.
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-06-04 06:38:59 UTC
(In reply to comment #3)
> Sorry to bother you again, but I'm not using the jit flag. I think you need
> to apply the paxmarking unconditionally.

Is webkit-gtk emerged with USE=jit or -jit?

Does epiphany reliably work at runtime? Do you manually apply any sort of pax marking to it? What does "/sbin/paxctl -v /usr/bin/epiphany" show?

What plugins do you have installed/enabled? (Look at about:plugins in epiphany; if you have something like icedtea-web installed, that may well be the cause of your test failures.)

What shows up in dmesg and/or /var/log/messages when epiphany's tests fail? (Make sure you have CONFIG_GRKERNSEC_RWXMAP_LOG enabled in your kernel configuration.)
Comment 5 Markus Oehme 2012-06-06 21:17:04 UTC
(In reply to comment #4)
> 
> Is webkit-gtk emerged with USE=jit or -jit?

with USE=-jit
 
> Does epiphany reliably work at runtime?

It seems to be a bit strange: If I open google.com as first page I often get the following segfault.

Jun  6 23:13:19 localhost kernel: [793225.162923] grsec: From 192.168.0.194: Segmentation fault occurred at 0000000000000050 in /usr/bin/epiphany[epiphany:20453] uid/euid:1000/1000 gid/egid:1005/1005, parent /bin/bash[bash:28988] uid/euid:1000/1000 gid/egid:1005/1005
Jun  6 23:13:19 localhost kernel: [793225.194284] grsec: From 192.168.0.194: denied resource overstep by requesting 4096 for RLIMIT_CORE against limit 0 for /usr/bin/epiphany[epiphany:20453] uid/euid:1000/1000 gid/egid:1005/1005, parent /bin/bash[bash:28988] uid/euid:1000/1000 gid/egid:1005/1005

But if I first open another page everything runs fine afterwards including Google. An unrepresentative test browsing hit this problem only with google.com and maps.google.com.

> Do you manually apply any sort of
> pax marking to it?

No.

> What does "/sbin/paxctl -v /usr/bin/epiphany" show?

- PaX flags: -------x-e-- [/usr/bin/epiphany]
	RANDEXEC is disabled
	EMUTRAMP is disabled

> What plugins do you have installed/enabled? (Look at about:plugins in
> epiphany; if you have something like icedtea-web installed, that may well be
> the cause of your test failures.)

IcedTea-Web Plugin (using IcedTea-Web 1.2)
LibreOffice Plug-in

both enabled.
They appear multiple times, that is they are listed twice with exactly the same description (which is not what I would expect).

> What shows up in dmesg and/or /var/log/messages when epiphany's tests fail?
> (Make sure you have CONFIG_GRKERNSEC_RWXMAP_LOG enabled in your kernel
> configuration.)

In dmesg I get

[792638.186074] grsec: From 192.168.0.194: denied resource overstep by requesting 4096 for RLIMIT_CORE against limit 0 for /var/tmp/portage/www-client/epiphany-3.4.2/work/epiphany-3.4.2/tests/test-ephy-embed-single[test-ephy-embed:19669] uid/euid:250/250 gid/egid:250/250, parent /usr/bin/gtester[gtester:19648] uid/euid:250/250 gid/egid:250/250

the same line in /var/log/grsec.log and nothing in /var/log/messages. The kernel option is enabled.
Comment 6 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-06-07 05:18:00 UTC
> denied resource overstep by requesting 4096 for RLIMIT_CORE against limit 0

This is an expected message; it just means that when epiphany crashed, it tried to write a core file for debugging purposes, but your ulimit configuration doesn't allow that to prevent your hard drive from filling up with random core files.

The question is why epiphany crashed in the first place.

Does uninstalling icedtea-web make a difference?

Does manually doing "paxctl -m /usr/bin/epiphany" make the google.com crashes go away?
Comment 7 Markus Oehme 2012-06-07 20:56:53 UTC
(In reply to comment #6)
> Does uninstalling icedtea-web make a difference?
> 
> Does manually doing "paxctl -m /usr/bin/epiphany" make the google.com
> crashes go away?

Both things produce no change.
Comment 8 Pacho Ramos gentoo-dev 2013-07-27 11:42:58 UTC
this looks to not fail in 3.8
Comment 9 Markus Oehme 2013-12-20 17:28:41 UTC
(In reply to Pacho Ramos from comment #8)
> this looks to not fail in 3.8

I still see the following error with 3.8.2:

TEST: test-ephy-embed-shell... (pid=14877)                                                                               
                                                                                                                         
(test-ephy-embed-shell:14877): GLib-GIO-ERROR **: No GSettings schemas are installed on the system                       
FAIL: test-ephy-embed-shell                                                                                              
/bin/sh: line 1: 14781 Terminated              G_DEBUG=gc-friendly MALLOC_CHECK_=2 MALLOC_PERTURB_=$((${RANDOM:-256} % 2\
56)) gtester --verbose test-ephy-bookmarks test-ephy-completion-model test-ephy-download test-ephy-embed-shell test-ephy\
-embed-single test-ephy-embed-utils test-ephy-encodings test-ephy-file-helpers test-ephy-history test-ephy-location-entr\
y test-ephy-migration test-ephy-session test-ephy-shell test-ephy-snapshot-service test-ephy-sqlite test-ephy-string tes\
t-ephy-web-app-utils test-ephy-web-view                                                                                  
Makefile:1179: recipe for target 'test-nonrecursive' failed                                                              
make[3]: *** [test-nonrecursive] Error 143
Comment 10 Pacho Ramos gentoo-dev 2013-12-21 17:17:23 UTC
Please provide updated full build.log, emerge --info and look for errors related with denied access in the logs :/
Comment 11 Markus Oehme 2013-12-22 19:38:13 UTC
Created attachment 365904 [details]
build log
Comment 12 Markus Oehme 2013-12-22 19:38:40 UTC
Created attachment 365906 [details]
emerge --info
Comment 13 Markus Oehme 2013-12-22 19:39:44 UTC
Created attachment 365908 [details]
messages in /var/log/messages pertaining to merging of epiphany

This is all I could find in the logs. HTH.
Comment 14 Pacho Ramos gentoo-dev 2013-12-22 19:46:43 UTC
Dec 22 20:32:07 localhost kernel: [1713811.383575] grsec: From 192.168.2.102: denied resource overstep by requesting 4096 for RLIMIT_CORE against limit 0 for /var/tmp/portage/www-client/epiphany-3.8.2/work/epiphany-3.8.2/tests/test-ephy-embed-shell[test-ephy-embed:8755] uid/euid:250/250 gid/egid:250/250, parent /usr/bin/gtester[gtester:8670] uid/euid:250/250 gid/egid:250/250

Looks like a problem with hardened
Comment 15 Pacho Ramos gentoo-dev 2014-05-30 19:05:06 UTC
Still hitting this with 3.10.x or 3.12.x versions?
Comment 16 Markus Oehme 2014-05-30 22:27:06 UTC
Last affected version for me was www-client/epiphany-3.8.2 if my logs are to be trusted.
Comment 17 Pacho Ramos gentoo-dev 2014-05-31 06:27:08 UTC
will close for now then