Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 415789 - app-arch/p7zip-9.20.1-r1 fails tests
Summary: app-arch/p7zip-9.20.1-r1 fails tests
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Justin Lecher (RETIRED)
Depends on:
Reported: 2012-05-13 20:13 UTC by Markus Walter
Modified: 2014-06-01 09:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build log (build.log,244.42 KB, text/plain)
2012-05-13 20:13 UTC, Markus Walter
emerge --info (info.txt,5.27 KB, text/plain)
2012-05-13 20:13 UTC, Markus Walter

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Walter 2012-05-13 20:13:15 UTC
Created attachment 311665 [details]
build log

On my hardened ~amd64 machine with gcc-4.6.2 the test-suite of p7zip fails with the following error message.

Testing     7za433_7zip_lzma/bin/7za.exe     Data Error

Sub items Errors: 1

ERROR during : /var/tmp/portage/app-arch/p7zip-9.20.1-r1/work/p7zip_9.20.1/check/../bin/7za t ../test/7za433_7zip_lzma.7z
Comment 1 Markus Walter 2012-05-13 20:13:31 UTC
Created attachment 311667 [details]
emerge --info
Comment 2 Justin Lecher (RETIRED) gentoo-dev 2012-05-14 13:32:47 UTC
Could you help be on debugging?
Comment 3 Markus Walter 2012-05-14 20:52:07 UTC
I'll try. I poked around in grsec.log and found the following entries:

May 14 22:17:00 localhost kernel: [160743.267718] grsec: From denied RWX mmap of <anonymous mapping> by /var/tmp/portage/app-arch/p7zip-9.20.1-r1/work/p7zip_9.20.1/bin/7z[7z:2257] uid/euid:250/250 gid/egid:250/250, parent /var/tmp/portage/app-arch/p7zip-9.20.1-r1/work/p7zip_9.20.1/check/[] uid/euid:250/250 gid/egid:250/250

I then tried decompression manually and got the same error. I then disabled mprotect via 'paxctl -m /usr/lib64/p7zip/7za' and then the decompression went smoothly. I hope this helps.
Comment 4 Justin Lecher (RETIRED) gentoo-dev 2012-05-30 19:15:06 UTC
is it okay if I mark 7za -m?
Comment 5 Markus Walter 2014-06-01 09:27:35 UTC
This seems to be gone with on version 9.20.1-r5.